Jump to content

[F1 2019] Force Feedback gets turned off on G29 Wheel

Recommended Posts

Hi all,

 

I have an issue that's plaguing my ability to play the game. I have a Logitech G29 wheel and the game just turns of all ffb in the wheel when the game starts. Here are the sequence of events that I go through:

 

 

Share this post


Link to post
Share on other sites

Sorry, accidentally posted before I've finished.

 

1) Start LG driver software

2) Turn on wheel (it calibrates properly)

3) Feeling that there's a FFB pressure on the wheel, I start F1 2019

4) As soon as the game starts, all ffb pressure in the wheel goes limp. Starting any race yields a wheel with no ffb no matter what settings I've changed.

 

I've scoured through all the forums posts I can find on this forum, steam discussions, and reddit. If you find it in google, chances are I've already tried any solutions such as reinstalling LG driver software, delete registry entries, reinstall F1 2019. The only thing that works is reinstalling LG driver software and F1 2019 at the same time; it will work for the first session after reinstall. After this, the game continues to turn off any ffb in my wheel. I'm at a loss and completely unsure of what to do. Help is appreciated!

 

Best,

--R

Share this post


Link to post
Share on other sites

I suppose you have you tried updating the Logitech driver? I have been looking for a similar problem on the forum and found this one. Lot of information which might set you in the right direction.

 

Share this post


Link to post
Share on other sites
9 hours ago, 1512marcel said:

I suppose you have you tried updating the Logitech driver? I have been looking for a similar problem on the forum and found this one. Lot of information which might set you in the right direction.

 

 

Thanks for your response!

 

Yes. I've downloaded the latest drivers from here. It's unfortunately game-breaking for me and I'd really love to figure out how to fix it; or, if it can't be fixed, implore our beloved devs into releasing a hotfix for it! 

Share this post


Link to post
Share on other sites
11 hours ago, repr0bate said:

Thanks for your response!

Yes. I've downloaded the latest drivers from here. It's unfortunately game-breaking for me and I'd really love to figure out how to fix it; or, if it can't be fixed, implore our beloved devs into releasing a hotfix for it! 

I don't think it is related to the wheel or there would be 00s of posts.

Tips: Use a USB 2.0 port on your motherboard - directly.

There are plenty of 3rd party USB 3.0 chips out there, with varying levels of driver integrity. Usually, USB 3.0 ports are coloured blue, if they're all black, then they might all be USB 3.0 or USB 2.0 the motherboard manual will explain.

If you can, please eliminate;

long USB extensions (conversely these work well for dongles to get them away from the PC)

powered or unpowered USB hubs

front panel USB connectors (frequently unshielded, long and sometimes miswired or poorly soldered)

and also try;

repositioning USB RF dongles or USB WiFi adapters (known to create lots of EMI noise in USB 3.0 ports, see ^^)

Finally, the AC adapter for the wheel can be replaced for around £10-£15 (use the 3A variant, the wheel will only draw what it needs, but they can often be out of spec)

Share this post


Link to post
Share on other sites

Thank you for your post. I've tried different USB ports (2.0 and 3.0) and tried a different power outlet. The same results, unfortunately. The reason why I'm thinking it's some interaction with the game and the wheel is that the wheel works fine upon reinstallation of drivers and the game only once. After I close a freshly installed game and reopen it, the problem comes back. But who knows, I'm open to any suggestions still!

Edited by repr0bate

Share this post


Link to post
Share on other sites
1 hour ago, repr0bate said:

Thank you for your post. I've tried different USB ports (2.0 and 3.0) and tried a different power outlet. The same results, unfortunately. The reason why I'm thinking it's some interaction with the game and the wheel is that the wheel works fine upon reinstallation of drivers and the game only once. After I close a freshly installed game and reopen it, the problem comes back. But who knows, I'm open to any suggestions still!

Gonna need a bit more info on your configuration. Try posting a dxdiag 

ftp://ftp.logitech.com/pub/techsupport/gaming/LGS_9.02.65_x64_Logitech.exe is the latest LGS. Not sure about G-Hub (wasn't a thing when I last had a Logitech).

Geek uninstaller is the way to remove and reinstall LGS. Remove, reboot, reinstall, reboot, test wheel in LGS, set default & permanent profile, delete hardware_settings_config.xml, launch game. Check controller option is set correctly in-game, remap any buttons as required, play.

Edited by steviejay69
punctuation

Share this post


Link to post
Share on other sites
On 12/20/2019 at 2:54 AM, steviejay69 said:

Gonna need a bit more info on your configuration. Try posting a dxdiag 

ftp://ftp.logitech.com/pub/techsupport/gaming/LGS_9.02.65_x64_Logitech.exe is the latest LGS. Not sure about G-Hub (wasn't a thing when I last had a Logitech).

Geek uninstaller is the way to remove and reinstall LGS. Remove, reboot, reinstall, reboot, test wheel in LGS, set default & permanent profile, delete hardware_settings_config.xml, launch game. Check controller option is set correctly in-game, remap any buttons as required, play.

 

I've done precisely as you've instructed and the issue still remains 😐

 

DxDiag attached

DxDiag.txt

Share this post


Link to post
Share on other sites

Graphics Driver outdated.

Remove the Focusrite USB audio device for testing.

Remove the ASMedia USB drivers and let W10 configure an inbox driver. (Uninstall the device, deleting the driver via the checkbox.)

Due to the OEM not filling the fields in the UEFI, I can't tell which mobo you have (it's usually ASUS, but many manufacturers do this). It might help if there is a UEFI update, they're very important on AMD boards as is then the relevant chipset driver.

Finally, as is becoming common on these G29 threads, if you have PCARS2 installed that's probably almost certainly the issue. Do this.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×