Jump to content
Sign in to follow this  

Issue with Thrustmaster TX v54

Recommended Posts

hello, I have a problem with my steering wheel.  There is a problem and I do not know if it comes from my steering wheel or the game .. the steering wheel looks more coggy when I turn during a turn .. I no longer have this feeling of fluidity.  And the worst part is that sometimes when I turn on the console, I find the right feeling but it is random and go back to this coggy/notchy feelin .. nothing more frustrating .. have you ever had a similar problem?  thank you in advance 

ps: i juste buy the Tx 2 weeks ago and everything is updated

Share this post


Link to post
Share on other sites
2 minutes ago, Grexfr said:

hello, I have a problem with my steering wheel.  There is a problem and I do not know if it comes from my steering wheel or the game .. the steering wheel looks more coggy when I turn during a turn .. I no longer have this feeling of fluidity.  And the worst part is that sometimes when I turn on the console, I find the right feeling but it is random and go back to this coggy/notchy feelin .. nothing more frustrating .. have you ever had a similar problem?  thank you in advance 

ps: i juste buy the Tx 2 weeks ago and everything is updated

Check the rim is secure. Undo the screw, unscrew the QR and then lift and refit the wheel, tightening QR firmly, the screw needs to go in just to biting point, no need to overtighten.

Share this post


Link to post
Share on other sites
6 minutes ago, steviejay69 said:

Check the rim is secure. Undo the screw, unscrew the QR and then lift and refit the wheel, tightening QR firmly, the screw needs to go in just to biting point, no need to overtighten.

Ok thanks i’ll try.. but if there is a problem with the connections how is it possible that sometime i feel it nice ? 
i will also try with my other rim ( leather )

Share this post


Link to post
Share on other sites
Just now, Grexfr said:

Ok thanks i’ll try.. but if there is a problem with the connections how is it possible that sometime i feel it nice ? 
i will also try with my other rim ( leather )

Can only suggest you try another USB port on the XB1.

The only other possibility is that you have either the FFB turned up too high and the FFB is reduced as the motor starts to overheat.

There is a method to enable the cooling fan from the beginning;

http://ts.thrustmaster.com/faqs/eng/thr_eng_00146.pdf

I think after you come from the G920 you will feel the TX is less strong but more subtle. There is no deadzone between the twin gears and no backlash.

If the cooling method does not work I suggest you try turning the FFB effect down. It will be less strong, but it will stay more consistent. On PC I use 75% feedback strength both in driver setting and in-game. 

There are plenty of YT tuts on how to uprate the cooling fan and mod the housing to get better airflow across the motor.

Share this post


Link to post
Share on other sites
19 minutes ago, steviejay69 said:

Can only suggest you try another USB port on the XB1.

The only other possibility is that you have either the FFB turned up too high and the FFB is reduced as the motor starts to overheat.

There is a method to enable the cooling fan from the beginning;

http://ts.thrustmaster.com/faqs/eng/thr_eng_00146.pdf

I think after you come from the G920 you will feel the TX is less strong but more subtle. There is no deadzone between the twin gears and no backlash.

If the cooling method does not work I suggest you try turning the FFB effect down. It will be less strong, but it will stay more consistent. On PC I use 75% feedback strength both in driver setting and in-game. 

There are plenty of YT tuts on how to uprate the cooling fan and mod the housing to get better airflow across the motor.

Thanks a lot, will try that and go back here to tell you ! 
My ffb is at 77% and i have this feeling sometimes before the fan start to cooling.. 

i just test with my Lether wheel and it feel more fluid.. maybe its juste the TM Open wheel thats give more detail and rumble on corner.. don’t know what to think 

will do some tests, thanks again

Share this post


Link to post
Share on other sites
2 minutes ago, Grexfr said:

Thanks a lot, will try that and go back here to tell you ! 
My ffb is at 77% and i have this feeling sometimes before the fan start to cooling.. 

i just test with my Lether wheel and it feel more fluid.. maybe its juste the TM Open wheel thats give more detail and rumble on corner.. don’t know what to think 

will do some tests, thanks again

Yeah I have the T300 and I prefer the F1 rim to the standard PS rim and the Open Wheel. I think the wheel diameter has a large part to play.

Edited by steviejay69

Share this post


Link to post
Share on other sites
On 12/23/2019 at 7:01 PM, steviejay69 said:

Yeah I have the T300 and I prefer the F1 rim to the standard PS rim and the Open Wheel. I think the wheel diameter has a large part to play.

problem still there despite my tests .. always this feeling that there is something wrong with the feedback, and I really feel that it comes from the game. There are times when the steering wheel is perfect and  is very very fluid and oily.  Others where it is rough and dry .. I can't figure out how or why 😞

Share this post


Link to post
Share on other sites
On 12/24/2019 at 7:48 PM, Grexfr said:

problem still there despite my tests .. always this feeling that there is something wrong with the feedback, and I really feel that it comes from the game. There are times when the steering wheel is perfect and  is very very fluid and oily.  Others where it is rough and dry .. I can't figure out how or why 😞

If you've done the firmware update, changed the fan mode and attached the wheel rim securely then I can only go back to USB.

You could do to try the wheel on a PC, the options for diagnostics are pretty limited on a console.

Share this post


Link to post
Share on other sites

Hello ! A few weeks after my first message I still have a problem with the feedback .. in addition to a huge difference between Time trial and online racing.  It very often happens that my feedback changes completely from one race to another .. since it has become unplayable for me (I play in an Esport team i can’t be competitive like before ) I asked Amazon to send me  a new steering wheel .. I'll come back here to tell you if the problem comes from the steering wheel, or the game!

Share this post


Link to post
Share on other sites

Hi @Grexfr,

If you could let me know how you get on and if the new wheel helps, that would be great.

  • Agree 1

Share this post


Link to post
Share on other sites
28 minutes ago, BarryBL said:

Hi @Grexfr,

If you could let me know how you get on and if the new wheel helps, that would be great.

Sorry but my english is poor haha What do you mean by « how you get on » ?

 

thanks 

Share this post


Link to post
Share on other sites

Hi @Grexfr,

To translate, how the new wheel performs for you and if you experience the same problems as before. 👍

Share this post


Link to post
Share on other sites
1 hour ago, Grexfr said:

Hello ! A few weeks after my first message I still have a problem with the feedback .. in addition to a huge difference between Time trial and online racing.  It very often happens that my feedback changes completely from one race to another .. since it has become unplayable for me (I play in an Esport team i can’t be competitive like before ) I asked Amazon to send me  a new steering wheel .. I'll come back here to tell you if the problem comes from the steering wheel, or the game!

I think you'll find that's game related. If only the FFB was like TT in Online. 

It's not like the community haven't higlighted this multiple times.

@Grexfr this comment is not aimed at you, more at the forum community feedback being disregarded / ignored.

Share this post


Link to post
Share on other sites
8 hours ago, steviejay69 said:

I think you'll find that's game related. If only the FFB was like TT in Online. 

It's not like the community haven't higlighted this multiple times.

@Grexfr this comment is not aimed at you, more at the forum community feedback being disregarded / ignored.

for me the difference between ffb in TT and online is a fact .. I noticed this issue a long time ago and I thought it was just a question of weight but in fact not at all.

 But the real problem for me is a random loss of power from the ffb when I go from one lobby to another, when the settings and tracks are the same .. it's just really unplayable .. so for me  (after having changed my old xbox to an xbox one s, and tested with other accounts) the problem probably comes from the steering wheel .. reason by I’ll try with fresh new one.

Cause really, i tried everything i could .. everything .. since November

Share this post


Link to post
Share on other sites
1 minute ago, Grexfr said:

for me the difference between ffb in TT and online is a fact .. I noticed this issue a long time ago and I thought it was just a question of weight but in fact not at all.

 But the real problem for me is a random loss of power from the ffb when I go from one lobby to another, when the settings and tracks are the same .. it's just really unplayable .. so for me  (after having changed my old xbox to an xbox one s, and tested with other accounts) the problem probably comes from the steering wheel .. reason by I’ll try with fresh new one.

Cause really, i tried everything i could .. everything .. since November

I have never played with the TX so can't comment. But it is the same wheel as the T300 just with 900 degrees of rotation (DOR) rather than 1080.

What DOR do you play with (I use 360)?

Also, have you tried playing with 'Understeer Enhance' ON or OFF (I prefer ON as it tells me when the slip angle is being reached but it does feel like the feedback is turned off)?

Share this post


Link to post
Share on other sites
11 minutes ago, steviejay69 said:

I have never played with the TX so can't comment. But it is the same wheel as the T300 just with 900 degrees of rotation (DOR) rather than 1080.

What DOR do you play with (I use 360)?

Also, have you tried playing with 'Understeer Enhance' ON or OFF (I prefer ON as it tells me when the slip angle is being reached but it does feel like the feedback is turned off)?

I use 360 ! Everything is activate, understeer Enhance ON.. 

there is my settings

80

10

5

5

10

The thing i dont understand is that how it is possible that the feedback change, with same track, same car setup... and its not the overhit security.. cause trust me its clearly unplayable like i said 😞 

 

searching everywhere, i nobody have this issue.. scary thing

Share this post


Link to post
Share on other sites
11 hours ago, Grexfr said:

I use 360 ! Everything is activate, understeer Enhance ON.. 

there is my settings

80

10

5

5

10

The thing i dont understand is that how it is possible that the feedback change, with same track, same car setup... and its not the overhit security.. cause trust me its clearly unplayable like i said 😞 

 

searching everywhere, i nobody have this issue.. scary thing

One last thing to suggest (can't replicate your situation without the same console and wheel)

https://support.thrustmaster.com/en/kb/6763-en/

is to reset the XB1 USB ports as per the Thrustmaster knowledge base article above.

Share this post


Link to post
Share on other sites
2 hours ago, steviejay69 said:

One last thing to suggest (can't replicate your situation without the same console and wheel)

https://support.thrustmaster.com/en/kb/6763-en/

is to reset the XB1 USB ports as per the Thrustmaster knowledge base article above.

Yes !  This is what I do almost all the time. But always the same problem.  I also thought of a possible conflict between the controller and the steering wheel but I tried all possible combinations nothing new évènement with a new controller. I'm getting the new steering wheel today, and this time if I'm going to try not to update and stay in v50!  One thing to note too, I don't have a PC. I used "Parallel Desktop" which emulates a version of windows.  When I update, everything seems ok in the software .. but it may be the cause of the problem ... Thanks again for being there and offering me things to test, I really appreciate it !!

  • Thanks 1

Share this post


Link to post
Share on other sites

Hi @Grexfr,

When you are using the wheel with the pad on, do you interact with the pad at all in any way? (Press the Start button for example)

Share this post


Link to post
Share on other sites

no .. as i said i tested all the combinations ... Start the console with the joystick, with the steering wheel, start the calibration once the game is launched, play without the joystick connected etc etc  everything hahaha

Share this post


Link to post
Share on other sites

Haha no worries,

I'm just thinking if you have the pad/joystick/anything on while using your wheel maybe? Or while you are using the wheel you touch something other than the wheel

Share this post


Link to post
Share on other sites
8 minutes ago, BarryBL said:

Haha no worries,

I'm just thinking if you have the pad/joystick/anything on while using your wheel maybe? Or while you are using the wheel you touch something other than the wheel

The issues with controllers really needs tightening in future releases. Wheels should work seamlessly across all modes with consistent FFB.

It's something that should be expressly tested in beta.

Multiple control schemes should be allowed (3rd party pedals, shifters, button boxes, full keyboard support (thinking of XB1 here), controllers plugged in simultaneously, etc.) and we need rid of that error message saying controls cannot be remapped for those that have a preset, maybe just the 'exclamation point' warning that this key/axis is already mapped to another control.

@BarryBL

  • Agree 1

Share this post


Link to post
Share on other sites
On 1/7/2020 at 1:53 PM, steviejay69 said:

The issues with controllers really needs tightening in future releases. Wheels should work seamlessly across all modes with consistent FFB.

It's something that should be expressly tested in beta.

Multiple control schemes should be allowed (3rd party pedals, shifters, button boxes, full keyboard support (thinking of XB1 here), controllers plugged in simultaneously, etc.) and we need rid of that error message saying controls cannot be remapped for those that have a preset, maybe just the 'exclamation point' warning that this key/axis is already mapped to another control.

@BarryBL

@BarryBL @steviejay69 

Well !  After a few days of testing (I wanted to be sure before I give you a report) I think the problem came from my steering wheel .. I no longer have this impression of rough steering wheel, the force feedback is much more precise and detailed.  So it must have come from a fault with the steering wheel.  It may also be due to the v54 updated with my fake Windows (I'm on Mac).  For the moment I will stay with this version (v50) it seems to me.  However, always this frustrating feeling when I go from TT to lobby, I really think that codemaster should look into it because the problem is real!  the force feedback is much harder and heavier than in online lobby.  Thank you for supporting me, I will come back if I ever feel a new problem !!

  • Thanks 1

Share this post


Link to post
Share on other sites
4 minutes ago, Grexfr said:

@BarryBL @steviejay69 

Well !  After a few days of testing (I wanted to be sure before I give you a report) I think the problem came from my steering wheel .. I no longer have this impression of rough steering wheel, the force feedback is much more precise and detailed.  So it must have come from a fault with the steering wheel.  It may also be due to the v54 updated with my fake Windows (I'm on Mac).  For the moment I will stay with this version (v50) it seems to me.  However, always this frustrating feeling when I go from TT to lobby, I really think that codemaster should look into it because the problem is real!  the force feedback is much harder and heavier than in online lobby.  Thank you for supporting me, I will come back if I ever feel a new problem !!

Yeah, if you mean you've updated the wheel with Windows running in a VM, then that's not really wise. VMs don't always get exclusive control over hardware and ports can be remapped or emulated (equally the wheel could have been faulty).

I would always advocate firmware updates to take place in real mode unless the only option is a Windows flasher (like with the wheel firmware), but even then I'd like Windows to be the bare metal OS.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×