Jump to content
Motorsport Games, Codemasters and FIA World Rallycross Championship presented by Monster Energy partner to create the World RX Esports Invitational Read more... ×
Sign in to follow this  

Livery color bug in multiplayer

Recommended Posts

  •          A short description of the problem:

When hosting a private lobby, the car chosen for the current event will inherit livery colors from the car that was previously used for the same lobby.

Livery pattern stays, but the colors are overwritten, seems to affect the lobby host only.

 

  •          Platform you’re on (PS4, Xbox One, PC, Steam):

Steam

 

  •          Game Version (Shown on the Start screen in the bottom left hand corner):

Latest HotHatch update

 

  •          Game Mode, including if it was Single Player or Multiplayer (Time Trial, Career, Grand Prix, Custom Game etc):

Multiplayer, Private Lobby

 

  •          If in Multiplayer, how many players and how many AI?:

2 players in the private lobby + AI

 

  •         What happened in the lead-up to the problem? Remember: if a bug cannot be reproduced, it cannot be fixed.

Open a private match, invite someone to the lobby, choose any car class, pick any car, that has a livery made by you. We'll be calling this car 'CAR A'

Start and complete the event, after it finishes you'll be back in the lobby.

Then, change the car class, your car will be changed with a default one for the new class, we'll be calling that car 'CAR B'

CAR B will have a livery pattern that its supposed to have, but the livery colors will be inherited from CAR A. If the new class has multiple cars and you change to a different car and then go back to CAR B, the livery colors will update correctly. If the class has only one car, then there's no way to refresh the livery, and you'll be forced to use the 'broken' one.

Not sure if both CAR A and CAR B need to have a player-made livery, for this bug to occur, as I paint all my cars and did not test this with default premade liveries.

Pretty sure it only happens to lobby host, as my playing buddy never complained about this bug... or maybe he just didn't notice, or is not paining his cars by himself.

Sometimes this bug does not even require 2 multiplayer events to occur, and you'll get it on your first multiplayer event - CAR A will then inherit the colors from a car that you last used in some single player event. Had this happen to me once, my multiplayer car livery color changed to the one I was using on my hothatch Mini that I raced in single player a day before...

 

  •          If you get an error message, the exact wording of the error message you're receiving:

No error messages, obviously

 

  •         Any accessories you are using (wheel, pad, etc.):

Using a gamepad

 

  •         If you have any videos or screenshots, please share them. If the video is long, please include a timestamp for when the issue appears:

Didn't take any screenshots, but I can try today, if this is still not clear.

  • Like 1
  • Agree 1

Share this post


Link to post
Share on other sites

Hey - thank you for reporting this and giving so much information. Massively useful for us to investigate further 🙂

If anyone else has also experienced this, please drop your feedback onto this thread. Cheers!

Share this post


Link to post
Share on other sites
Posted (edited)

It also happens on ps4. Right livery but wrong colors. Multiplayer. Controller. 

Edited by KreuZenNL
  • Like 1

Share this post


Link to post
Share on other sites

Same here in public quick match races. Custom liveries wont show the correct colors. I'm on XBox One X.

  • Like 1

Share this post


Link to post
Share on other sites

Also happened to me in Quick Match multiplayer, Steam/PC version.

Share this post


Link to post
Share on other sites

Thanks @RipHawk

Just checked in with the team and they're aware of a couple on minor bugs that will be causing situations like the ones you've all mentioned. We're expecting some improvements in this area in next week's update for the public lobbies, and will continue to work on it towards Season 2 🙂

Share this post


Link to post
Share on other sites
58 minutes ago, ChrisGrovesMCM said:

@RipHawk @Coffeeman89 @KreuZenNL - Were each of you the lobby host in the session? Trying to narrow down the consistencies so we an identify the issues 

No not the host. Happens to a lot of friends in the lobby

  • Like 1

Share this post


Link to post
Share on other sites

So just played some more and it happens also when not the lobby host.

By re-selecting the current car (2x) or switching to another car and then back it will update to the correct livery. It seems to happen after every race (made a custom livery for each car class to test).

Edited by RipHawk

Share this post


Link to post
Share on other sites

So we've been able to reproduce this internally and now working on a fix. As above, we're racing to implement a fix for Season 2, as it's a high priority for us to address 👍

  • Thanks 1
  • Agree 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×