Jump to content
DIRT 5 - Chat about the game and get support here. Read more... ×
Sign in to follow this  

Racing wheel always forcing to the right

Recommended Posts

Hello,

Waiting for the 2nd season of DR2.0 I have decided to remember old good Dirt 3. I was very happy with it back then in 2012, but at that time I did not have the wheel and used my keyboard and chase camera. Now I have Logitech G29 and wanted to try Dirt 3 with it. Unfortunately the game is no longer in Steam due to the licensing issues (so the game is de facto abandon-ware). I managed to get the game from one of my friends as Dirt 3 Complete Edition.

When I tried I have discovered the issue exactly described here: https://steamcommunity.com/app/321040/discussions/1/611702631209592196

Yes, I know, that G29 initially is not supported by Dirt 3, but there are a simple fix for it: https://steamcommunity.com/app/321040/discussions/0/483368433105982953/

In the first link there is a mentioning of the official patch with the fix. But since the game is no longer in Steam I can not download it.

@PJTierney @justbiglee @justbiglee1

 

Is it possible to check the archives and publish the patch/fix on the official support site as stand alone patch?

Or maybe, since the game is abandon-ware it is possible just to publish the solution (the files of Dirt 3 are not initially encrypted) that everybody can implement it for themselves?

Dirt 3 Complete Edition

My hardware: https://asset.msi.com/pdf/main/us/nb/GL72 6QF-697.pdf? and Logitech G29 steering wheel with sifter.

 

Share this post


Link to post
Share on other sites

Lee hasn't worked at Codemasters for years.

I would imagine that since the game has been sunsetted there'll be no reissuing of patches.

Share this post


Link to post
Share on other sites

Then, maybe somebody in the community kept patched version on the game. I saw a few relatively recent videos (dated 2018-2019) of people playing Dirt 3 with G29 without FFB problem.

If you sill have it, please send me the files related to force feedback (by PM if it is not allowed to do it publicly). I will look through them myself, trying to find the fix. Most likely it should be some settings or extra lines in .xml in \forcefeedback settings, but also maybe somewhere else.

Would be nice to organize community support for a good old game abandoned by the developers.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×