Jump to content

DiRT Rally 2.0 - Version 1.12 Bug Reports

Recommended Posts

Posted (edited)

Tracking for oculus rift S via steam using oculus sdk has become glitchy since last update. At one point it was so bad the game would stutter all over the place, the game would reset me to outside the car or in worst cases crash the oculus app. During the daytime it’s barely noticeable but at night when using a light shade it sometimes is unplayable. I’ve diffused my light, put posters on the wall, put items in front of my rig, done everything I can to help the rift S have something to track, but as soon as natural light turns to dark and I turn my lights and lamps on the tracking becomes poor. Putting posters on my wall next to me and in front of me, has improved the tracking, but still nowhere near the same standard as any other vr sim. All my other sims absolutely no problem at all, in fact I didn’t realise a driving sim could have tracking issues until DR2.0. The VR is so close to being perfect, please can you look into tracking for oculus sdk via steam.  Intel 9 9900 overclocked to 4.2, 2080ti, 16GB ram and using all fanatec gear. I get great performance from vr in natural daylight, but night time the tracking goes to pot with artificial lights. My play space also works fine for games like superhot, onward and pistol whip. I am out of ideas on how to help tracking for this game. 

Edited by tombradybaby

Share this post


Link to post
Share on other sites
On 2/13/2020 at 9:16 AM, somethingthing said:

Try to 1) delete your config file and 2) verify integrity of the game on steam. I have absolutely no performance issues and i havent seen anyone else complain about it neither. If your camera view changes randomly it sounds more like a tracking issue than a game issue. What do you mean you set to 16x and 8x? Do other games still work good? Maybe a bad driver update?

You are right it is the tracking that is having issues.

Share this post


Link to post
Share on other sites
Posted (edited)

- Platform: PC Steam Windows 10

- Bug: Intermittent stuttering on the first half of a stage, happens 6/12 approximately.

- Hardware: AMD Ryzen 7 3700X, AMD RX5700 XT, 32GB DDR4 3600Mhz

- Peripherials: Thrustmaster T500 RS wheel (USB) + Fanatec Clubsport Pedals v3 (USB).

Description:

image.png.bc5a5d97b2abcd78361f9c17a106a3e8.png

RiggsDxDiag.txt

Edited by Riggs

Share this post


Link to post
Share on other sites
Posted (edited)

Tried doing the "It Would Be Bakke'RUDE Not To" and "World RX Champion" achievements.

However both wont unlock nor make progress... 
On Steam PC, xbox one controller with the usb wireless adapter, playing 2D.

no achievement progres..png

did all qualifiers.png

rx championship progres.png

Edited by DrubyLuke

Share this post


Link to post
Share on other sites

The Lancer Evo VI is making a funny turbo noise when switching gears, on hood cam. Like if it is constipated.

  • Agree 1

Share this post


Link to post
Share on other sites

Just to be sure, I tried to get "It Would Be Bakke'RUDE Not To" and "World RX Champion" achievements again at the next event. Still no luck...
won every qualifier, got 200 points.
 

Untitled1.png

Untitled2.png

Share this post


Link to post
Share on other sites
Posted (edited)
On 3/7/2020 at 9:38 PM, Riggs said:

- Platform: PC Steam Windows 10

- Bug: Intermittent stuttering on the first half of a stage, happens 6/12 approximately.

- Hardware: AMD Ryzen 7 3700X, AMD RX5700 XT, 32GB DDR4 3600Mhz

- Peripherials: Thrustmaster T500 RS wheel (USB) + Fanatec Clubsport Pedals v3 (USB).

Description:

image.png.bc5a5d97b2abcd78361f9c17a106a3e8.png

RiggsDxDiag.txt

It began stuttering in the service after i finished a stage, so something got wrong during the Loading process, and the stutters carry on to the next stage for at least the first sector, then it's gone. I don't think it can be the stream or the wheeler, because otherwise the game would have to keep stopping during all the stages, all the time.

It also isnt lack of hardware power, because neither my CPU or GPU are at its max and I've even tweaked down some of the settings, including Ground Clover, but the problem persists. Don't mind the clip glitch of the video coming back and jumping, that's just the result of the game stuttering and the stream wanting to compensate. The game simple stutters and freezes that frame, it doesnt go back.

Edited by Riggs

Share this post


Link to post
Share on other sites
  • What platform you're playing on (for PC also state Steam, Microsoft or Oculus).  - PC Oculus Rift x 2 and Pimax x 1  
     
  • What your PC setup/build is like (graphics card, processor etc.). 3 x PC's 2080ti and 1080ti    
     
  • If you're playing on PC, state whether you're in 2D or VR.  - VR x 3
     
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.  3 x PC with wheels and pedals

 

We play Rallycross with only Human Players in private mode single 8 lap races with no AI on 3 PC's in the same room all with their own install of the steam version of the game.

I invite them via steam and they join without issue.

Tracks intermittently have our cars ghosted so we can drive through each other and other times they are solid and we can collide.  It is intermittent.

Sometimes 2 of us can collide and one is ghosted, sometimes we are all ghosted, sometimes we can all collide.

We would like the choice to not be ghosted but there is no choice and it is determined sporadically.

We are not talking about when you are a lap down or something or when your driving too slow as we realise it is ghosted then.  This happens when we are racing properly at full speed and can even vary from race to race on the same track.

A very strange and annoying bug.

Please fix thanks.

 

 

 

Share this post


Link to post
Share on other sites

Bug Report (after reading the patch notes for 1.13).

Two things are still missing for me:

1.) The game still crashes 100% of the time if I try to finish a My Team Rally Career Elite Championship. Happens always late in the championship (last time 4th rally after 1st stage in monaco while driving a Peugeot 206 Rally).

Please ask for more information if needed.


2.) My Team -> Garage -> any Car -> Car stats.
The game still counts a community- and AI monthly as X events started, but always only 1 event ended. No matter what.
X = actual number of events.

Please ask for more information if needed.


The game is close to perfection.
 

Share this post


Link to post
Share on other sites
Posted (edited)

Platform: X-Box One S (latest Firmware & Game Version 1.12.0)
Version: Retail Deluxe + Season 3+4 Pass (all DLC installed including pre-order cars and free cars/liveries)

Where: My Team Rally Career (on Elite, but I believe this doesn't matter)

Description:

The game crashes 100% of the time in the 4th rally, after the 1st stage after the leaderboard showing up. As soon as you press A to continue, the game crashes with a static sound, trying to load the next stage.
This is now the 5th time I tried to complete the championship (1st time in August, 2nd in september, 3rd/4th in February, 5th time a few minutes ago).
This seems to be a specific X-Box One/X-Box One S problem, because all the reports come from these platforms.

@PJTierney I know, I'm quite annoying about this, but it is a critical game breaking bug, that you can duplicate, it happens always at the same place. Please let the team know about this. Please.

What I tried so far:

- using DLC car (SUBARU Impreza 2001 (2 times), Opel Manta 400, Peugeot 206 Rally
- using base game car (Opel Kadett C GT/E)
- using individual tune setup
- not using individual tune setup
- different types of rally combinations
- not using hardcore damage
- hard reset the console (2 times)

Edited by UnderclassGDfan
Added version of the game

Share this post


Link to post
Share on other sites
18 minutes ago, UnderclassGDfan said:

@PJTierney I know, I'm quite annoying about this, but it is a critical game breaking bug, that you can duplicate, it happens always at the same place. Please let the team know about this. Please

The thread is actively monitored, but I don't know specifically how this specific issue's come along. 

Share this post


Link to post
Share on other sites
5 minutes ago, PJTierney said:

The thread is actively monitored, but I don't know specifically how this specific issue's come along. 

@PJTierney I read the patch notes and especially this one:
 

  • Resolved issue where number of Terminal Damages incurred was not displaying correctly in My Team.

is quite close to the one I reported for the Xth time above my last post.

But nothing in the patch notes is even close critical as this one. It is literally not possible to finish a championship. And believe me, I tried everything I can.
I fust fear the support will go down before this is fixed. I plan to play this game for a long time, at least until the next entry comes out.
And I want to beat masters! And I just can't graduate from Elite because of this, it always resets my championship.

Share this post


Link to post
Share on other sites

In cockpit view, when shifting during a turn, the drivers hand continually/constantly switches between the steering wheel and the gear shift lever over and over again quite a while after the gear change has taken place. This issue has occurred since at least v1.8.0 and probably even before that. It is rather distracting. It would be nice if this was fixed.

Xbox One X

v1.12.0

I'm using the standard Xbox One controller.

Share this post


Link to post
Share on other sites
Posted (edited)

In the patch notes for v1.13.0, it says that the team resolved an issue where the rev lights for the Mini Cooper SX1 appeared blurred. In cockpit view, on my Xbox One X, the dashboard and steering wheel rev lights don't illuminate at all on the Mini Cooper SX1.

Xbox One X

v1.12.0

I'm using the standard Xbox One controller.

Edited by FlatOverCrest
spelling mistake

Share this post


Link to post
Share on other sites
Posted (edited)

I started the game the first time and in VR.

What a "great" start:

I cant change my name in driver profile creation and also not afterwards in profile settings.

Great start to already get bugs so early already 😕

 

edit: It shows just the surname on the leaderboards and in the game which I want the game to use anyway. So its fine for me.

Still weird though that it offers to change the names, while you cant then.

 

But I have something positive to say too.

I drove the first time in Finland because I was most excited to experience that many mountains in VR.

And holy moly it was unbelievable with the valve index.

I'm not sure how you did it, but you really feel every crest and every height difference like almost g-forces. Its so amazing 🙂

And that with only 72hz out of my 144hz of the index. I wonder how it would feel on actual 144hz o.o

And you finally fixed the stuttering of the engine. woah! Its so smooth now.

Dirt 4 had always frametime spikes for me for some reason which DR2 doesnt have anymore. But maybe it's the VR which works better with your engine. I didnt try DR2 as flat yet.

Edited by DeMoN1111111

Share this post


Link to post
Share on other sites

PC

I've found a problem with the audio. When I use the headset I can't ear the copilot's voice. No problem if I switch on speakers. Headset are Rog centurion 7.1.

Share this post


Link to post
Share on other sites
Posted (edited)

@PJTierney I was wondering if you could ask around about any possible fix for the Oculus Rift colour banding issue. It seriously makes it difficult to play a track at night, as all you see on a lot of night stages; are massive blobs of dark purples and dark blues. Its on the verge of game breaking in some places, and I often have to resort to using my TV screen instead of VR for night stages just to be able to see where I am going, or upping the brightness to 1.8 in the settings menu. The issue isnt there at all on the SteamVR version, but it is there on both Oculus via Steam and the Oculus Store versions.

Edited by Ialyrn
  • Agree 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×