Jump to content

DiRT Rally 2.0 - Version 1.12 Bug Reports

Recommended Posts

    IMPORTANT:

Read and understand this entire opening post before replying,

as providing the right amount of detail will help out the team immensely in tracking and resolving any bugs that arise, thanks.

 

DR2_19RX_FirstLook_Thumbnail_Ford_YouTube.jpg

 

Before posting, please make sure to follow these guidelines.

Without adequate information the team will have trouble identifying and fixing bugs, so please provide as much info as you can:
 

  • Check if a bug has already been reported.
     
  • If you reported a bug in a previous version of the game, check your game first to see if it's been fixed.     
     
  • If a bug has been reported and you are experiencing the same issue, hit the ❤️ icon.     
     
  • The more popular bug posts will have a better chance of catching the attention of the team.
     
  • Also, this thread allows us to sort comments by how many votes they have, so make use of that feature 🙂      
     
  • If a bug cannot be reproduced, it cannot be fixed.     
     
  • When you experience a bug, please try to trigger said bug again if you can, and show us the steps you went through to trigger it.     
     
  • Text steps are good, video even better.     
     
  • One bug per post please, for our tracking purposes. That way every bug gets its own URL for us to investigate.     

 

     

    Please also provide the following:
 

  • What platform you're playing on (for PC also state Steam, Microsoft or Oculus).     
     
  • What your PC setup/build is like (graphics card, processor etc.).    
     
  • If you're playing on PC, state whether you're in 2D or VR.
     
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.     

Share this post


Link to post
Share on other sites

I am now tired of always reapplying settings when I want to drive a single track now and then. I have not been playing your game anymore. You don't care, then me neither. I have tried everything, reinstalling the game as well, nothing helps. Why don't you force the game to check the .xml settings file exist in the first place?

PS. This is most likely a Cloud Save issue. The useless cloud tries to get the settings file from time when I had GeForce GPU and they won't work with Radeon. This is my assumption. In any case, no .xml files exist and nobody is willing to upload them for me and I don't understand why. Are they sacred or something?

EDIT. Yay! Issue was fixed via email with Codemasters customer service. This case was a classic anti-virus problem, even though I browsed Bitdefender many times. Also remember to find the 'dirtrally2.exe' and make it run as administrator. Sorry for the inconvenience.

Edited by AUTOPELI
update
  • Like 2

Share this post


Link to post
Share on other sites

Finland in daytime/clear and daytime/overcast has a horrible looking thick fog on it. Completely unrealistic for the weather (I live in Finland so I would know, also every single Finnish player says this is not even close to how it looks like in reality), looks painfully awful, and you can barely see the road in what should be crystal clear weather with no fog at all.20200121135222_1.thumb.jpg.d343b7156516f8a23bfc2ea1dbbdc417.jpg20200121135529_1.thumb.jpg.9efc7d5df25f39f65889177826d87041.jpg

20191112171257_1.thumb.jpg.015ea159971092ea94808cf7afa400cf.jpg

 

Yes, I know that you said it's "for performance reasons" but that just isn't a good enough answer. Adding this kind of horrible fog that makes it look awful is absolutely not the right way to increase performance. What you should do is get rid of the fog, or at least tone it down to the same level as Wales (where it's bad enough but at least playable) and increase performance in other ways. The kind of ways the leave daytime Finland looking decent.

 

Look at this. This is a comparison of Finland in Dirt Rally vs. Dirt Rally 2.0. You can see it looks FAR better in DR1, because low graphical fidelity without the fog is far better than high graphical fidelity with a horrible fog slapped on it that completely ruins its looks. Your "visual upgrade" has left daytime Finland looking far worse that it did in DR1.

 

These fake promo screenshots, with no fog at all, are what the real game should look like. As it stands this might as well be from a completely different game. The fact that you can't show real screenshots of daytime Finland would kind of suggest even you at Codemasters are not too happy with how it looks like.

DR2_Location_Finland-(2).jpg

 

 

  • Steam, super deluxe edition
  • 1230v3, GTX 1070, 16gb ram, SSD, Windows 10, SB Z
  • 2D, 2560x1440 60Hz
  • Logitech G920+shifter   
Edited by HoksuHoo
  • Like 4
  • Agree 5

Share this post


Link to post
Share on other sites

Ford RS200 has a very low-res and blurry texture between bonnet and dashboard. Kind of sticks out in an otherwise good-looking interior. I have textures and vehicle details on ultra

20200120162522_1.thumb.jpg.185bd74de14a4f2aa47e2b1e7f27356d.jpg

  • Steam, super deluxe edition
  • 1230v3, GTX 1070, 16gb ram, SSD, Windows 10, SB Z
  • 2D, 2560x1440 60Hz
  • Logitech G920+shifter   

 

  • Like 1

Share this post


Link to post
Share on other sites

Still no mousefunction in VR :classic_mellow:  It is very bad to operate the functions and settings with the steering-wheel-buttons. Especially since everything was unnecessarily nested ...

Share this post


Link to post
Share on other sites

Some tarmac textures have very visible compression artifacts, it's especially visible in daytime Spain where in some places the tarmac is quite prominently purple and green like in this shot, and the one in my previous post. I have textures and track on ultra

20200120165017_1.thumb.jpg.376904f28bc471b29241c0f7c85ba7a2.jpg

  • Steam, super deluxe edition
  • 1230v3, GTX 1070, 16gb ram, SSD, Windows 10, SB Z
  • 2D, 2560x1440 60Hz
  • Logitech G920+shifter   
Edited by HoksuHoo

Share this post


Link to post
Share on other sites

What platform you're playing on: PC, Steam, Oculus Rift S
What your PC setup/build is like: i7 9700K, GTX 1080 8Gb VRAM, 32 Gb RAM
If you're playing on PC, state whether you're in 2D or VR: VR, Oculus Rift Mode
Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.  Using G27 from Logitech

After this patch is impossible to set supersampling in the game (for example, using Oculus Debug Tool or Oculus Tray Tool). The Game starts with supersampling set, in menus, but when I start a race, SS sets to 0.0 or worse. All is horribly pixelated!!

Please, fix this, let it as in 1.11. Driving without SS in VR is a torture. Is like using a Spectrum ZX in 80s.

 

  • Agree 2

Share this post


Link to post
Share on other sites
35 minutes ago, cestomano said:

SS sets to 0.0 or worse. All is horribly pixelated!!

Try to change the MSAA one step  - have a look in the hmd - and then switch back to your normal MSAA. All like it was before. I got a shock too when I started it first time after the pacht:classic_laugh:

  • Like 1
  • Agree 2

Share this post


Link to post
Share on other sites

PC, Steam, VR (HP Reverb)

Picture is horribly pixelated at start of every stage. To resolve this I either have to drive off the starting line and the restart (which is NOT a solution at all) or I can change MSAA to something else, and back to where I want it. This happens *EVERY* time at the start line !! This has to be fixed A S A P !

  • Like 2

Share this post


Link to post
Share on other sites

very unhappy after this patch, vR was looking super, now its a mess, why do you guys keep doing stuff like this with patches? Please test before launching 

  • Like 1

Share this post


Link to post
Share on other sites

PS4 Pro, deluxe owner, season 3+4 owner

2019 WRX: Mandie August is noted with an Audi, but should be a SEAT

image.thumb.jpeg.0f58c825d27822bd335587dcea6d673c.jpeg

2019 WRX: In an AI race, Demoustier has the wrong livery

image.thumb.jpeg.aa5c7c8b24b27683ccd28b55a7465e58.jpeg image.thumb.jpeg.1d088b6dac7b02a223ddd18fcab601c5.jpeg image.thumb.jpeg.629bc5cad3cf7133eddcae0fffee8f3d.jpeg

  • Like 2

Share this post


Link to post
Share on other sites
  • Adjusted visual appearance of FOV adjustments to prevent clipping of car interiors. '

So the clipping issue with Stratos is now fixed, cool. Problem is, the driver position with lowest FOV setting is now far too much forward with several cars. Porsche 911 SC RS is the most striking example I have seen so far, with Lancia 037 almost as bad. This is not really a cockpit view anymore, more of a dashboard view.

20200121190801_1.thumb.jpg.0110f9bdcdc19083eb023a9b6f96f8d7.jpg

Even with the lowest FOV setting it should be possible to have the kind of cockpit view that has A-pillar and instruments clearly visible. Like this:20200121234013_1.thumb.jpg.b635d02bd2fe4808335884b262410553.jpg

The driver position adjust feature is too limited. It does not allow moving backwards from default position and its movement ranges are too short. So how about allowing enabling to move the driver position backwards (and any direction without the overly restrictive limits), so the driver position can be properly adjusted to player preference?

  • Steam, super deluxe edition
  • 1230v3, GTX 1070, 16gb ram, SSD, Windows 10, SB Z
  • 2D, 2560x1440 60Hz
  • Logitech G920+shifter   

 

Edited by HoksuHoo
  • Like 1
  • Agree 2

Share this post


Link to post
Share on other sites
3 hours ago, Flens07 said:

Try to change the MSAA one step  - have a look in the hmd - and then switch back to your normal MSAA. All like it was before. I got a shock too when I started it first time after the pacht:classic_laugh:

Yes, it works !!! Thanks a lot.

In fact, I do this at the start of any race (with HMD always on my face): I go to Menu, I change AA to next value, then apply, then change again to my favourite value, apply again, and exit from Menu to race.

As MongoJon [VR] said, it has to be solved ASAP.

(that bug and all VR bugs detected, filled and not solved since september... :classic_dry:)

 

Share this post


Link to post
Share on other sites

VR is now broken after this update. Its insanely annoying and its making me not even want to play the game. For every single race I have to go into settings and change them back and forth just to get it normal. If you launch into a VR race it starts super pixelated and looks horrible.

 

Please do a hotfix on this ASAP

  • Like 2

Share this post


Link to post
Share on other sites
Hi

The headlights shine too briefly when driving at night. In advance of the car, it fits.
It is very difficult to see the curves at night.

Rally lights illuminate at approx. 150 - 200 meters at night.

Or do you have a tip to change that.

PS: A great game ........
  • Agree 1

Share this post


Link to post
Share on other sites
12 hours ago, cestomano said:

Yes, it works !!! Thanks a lot.

In fact, I do this at the start of any race (with HMD always on my face): I go to Menu, I change AA to next value, then apply, then change again to my favourite value, apply again, and exit from Menu to race.

As MongoJon [VR] said, it has to be solved ASAP.

(that bug and all VR bugs detected, filled and not solved since september... :classic_dry:)

 

have tried this work around, it's an improvement, but still no where near what it was. 

Share this post


Link to post
Share on other sites

I Have the same issue in VR after the update the image is pixelated but this does not happen in the freemode anybody else notice this?

I'll try the MSAA change and hopefully this will help, such a great game in VR please codemasters fix this and share a little love our way.

I'm running on steam with and Index connected to a 2080ti latest drivers and 9900k. 

Does anybody know of any config changes that can help fix it, because if its working fine in the freemode then maybe it's just a bad config. 

Hope they sort this mess out soon. 

Share this post


Link to post
Share on other sites

PC VR - Rift S - Steam version. Same issue as the people above - blurry visuals in VR, fixed by going into settings, adjusting AA, adjusting back, then going back into the race.  I need to do this at the start of every stage.

I've also been noticing irregular lag spikes (every minute or so) since mid december.  If I disable the network the lag spikes stop, so I'm thinking it's network related.

  • Like 2

Share this post


Link to post
Share on other sites

Dirt 2.0 version loves to remove and reposition vehicle parts. Previous version did it to extreme (especially on long game session), latest does it as well. To make it even worse, it repositions randomly night lights as well, sometimes even wheels that causes funny 1-wheel drive moments.

Steam, nVidia 1660 super, Amd Phenom2 1075T, 6core.

TuKAxDH.png

Note: this car is fully repaired.

To solve issue game must be restarted.

Share this post


Link to post
Share on other sites

Im also having the blurry start and need to go into graphics settings and change msaa (each stage!!!!) for it to be better. Pls release a hotfix!

 

 

Edited by somethingthing
  • Like 2
  • Agree 1

Share this post


Link to post
Share on other sites

Fully expected to see the MSAA VR issue hot fixed today. Guess I was wrong. Why was this not picked up in testing? 

  • Like 3

Share this post


Link to post
Share on other sites

VR MSAA issue here as well. This is such a blatantly obvious issue I have to question whether these releases are actually tested in VR before being pushed out.

  • Agree 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×