Jump to content
F1 2020 | KNOWN KEY ISSUES | READ ME!!! Read more... √ó

DiRT Rally 2.0 - Version 1.13 Bug Reports

Recommended Posts

Same problems¬†: never had¬†so many dirt crash¬†than since this update is arrived (but had already few cases before)¬†!! In colin mac rae challenge (impossible to valid¬†anything), in daily challenge, in championships and now : after have registered¬†a setup in a club session !! ūü§¨

Always the same effect : freeze of the screen after last ¬ę continue ¬Ľ button, when red circle turn, huge¬†sound ok the TV and then after few seconds : back to xbox main screen... With or without racenet login : same effect !!

Is somebody @ codemaster working on this problem ? Because difficult to play to this wonderfull colin update (that we paid... ūüėí)¬†if nothing is resolved... Thanks (a french and disappointed player)

  • Like 1
  • Agree 2

Share this post


Link to post
Share on other sites

loss of general fps in vr.  especially with the public.  if I deactivate it in graphic options, the public continues to appear.  I can't disable it.  if under filters x8 to 4x it gets even worse

I9 9900k

Rtx2080ti

Steam versión 

Share this post


Link to post
Share on other sites
Posted (edited)

PC, VR (but confirmed in nonVR PC too)

Steering wheel doesn't calibrate properly for all cars. It calibrates for 540 degree steering lock cars (ie R5 class). But don't match cars with other steering locks.

To reproduce:

  1. Steering wheel controller set up for maximum lock (mine offers 900 degree).
  2. calibrate in-game
  3. enable in-game steering lock
  4. make sure linearity and saturation are default
  5. enable animated steering wheel in cockpit
  6. load any R5 car - compare steering wheels rotation (animated and controller) - they do match
  7. load Subaru Impreza 97. Steering wheels rotation don't match. Change saturation to 75 - it makes steering wheels match for this Subaru. but obviously R5 will not match anymore.

 

Edited by MaXyMsrpl

Share this post


Link to post
Share on other sites
Posted (edited)

Spotted huge difference in RPM indicators in Subaru R4.
This car has 2 additional indicators (next to default gauge). LEDs on steering wheel column and LCD display in the middle of the cockpit.
When LEDs shows full RPM, LCD is somewhere in the half range. By driving the car I'm confident to say LCD is correct. It means LEDs are wrong.

Edited by MaXyMsrpl

Share this post


Link to post
Share on other sites
Posted (edited)

@PJTierney, could you please give a little comment on this, as there are already 2 people who noticed the problem?

Is it possible to get more detailed comment from devs on how "WET" physics was changed in 1.13, as patch notes don't provide enough detailed information?

Added video to illustrate the case.

Version 1.13 - Steam - Super Deluxe Edition

On 3/27/2020 at 8:04 PM, Tigron said:

I guess car physics again was tweaked and this time not the best way. The rear of the car became too slidy. Lateral grip is almost non existent especially in heavy rain. Yes, mud suppose to be slippery, but not like bare ice on summer tires.

It looks like the weight of the car also decreased. It is especially visible with new Subaru Impreza S4. Each curb stone can sand you to the stratosphere. The car is low and Scotland have a lot of sneaky curb object so you will fly high and a lot. At all I have such impression the physics returned a little to Dirt Rally 2015 state, where each curb stone also send your car far and away.

 

13 hours ago, FwyFlyer said:

I believe you are spot on at least when it comes to the PC version.  I think vehicle friction was reduced dramatically to the point where cars now slide off slightly canted roads even when driving mostly straight.  Vehicles have much less side bite and also take much longer to stop than they did pre 1.13 patch.  Moreover, it seems as if all roads were suddenly turned to wet clay.  And, while the effect may be more pronounced on some vehicles it nonetheless exists virtually across the board.

I have literally hundreds of hours into this game on steam and I have driven it nearly every day.  Long story short, the loss of traction caused by the recent patch(es) IS a game breaker!

 

 

Edited by Tigron

Share this post


Link to post
Share on other sites

@PJTierney found a glaring one there: Rear view mirror in the DS21 is inverted(it look like your are looking straight at behind from that mirror instead of acting like a mirror)

On that screenshot, the wooden posts should be on the right on the mirror...they are on the left

20200329124913_1.thumb.jpg.6ab675f197f46d18db60889ca35cde12.jpg

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

On today's Wales daily under heavy rain with the Legacy I've had a wipers issue problem with Auto-Wipers set to off. Car had no damage, and then they stopped working in the first 8th of the stage, leaving me blind.

They would start back after manually starting them via long button press, but then would stop again after some seconds. Setting Auto-Wipers on made them work, and completely stop failing. I'd assume that if this was a random electric problem, at least it'd still have an effect when that assist was on with a random missed wipe (then auto-turn on), but not. Then, after turning auto-wipers off again, a few seconds later wipers stopped working again, making me emergency stop the car again.

Yesterday the exact same thing happened to me in the Rallycross Career on a rainy stage right in the first qualifier after t2, and restarting the race wouldn't solve it, forcing me to drop the event. At that point, I had no idea that enabling auto-wipers would make them work flawlessly.

This situation is completely frustrating on a freshly repaired car, not to say that the results are completely different depending on assists settings. Even then, if this is related to random electric problems, at least it'd be fairer that they randomly missed a wipe instead of turning completely off with auto-wipers off. Looks like a bug.

Edited by AlleyViper

Share this post


Link to post
Share on other sites

Update:

Crashes when selecting quit to main menu too.

Crashed after first race of career using no expansion content.

Crashed in historic and didn't save the result.

There is nothing about this game that is playable right now.

  • Agree 2

Share this post


Link to post
Share on other sites

 

  • Issue:
    "If in Doubt..." Achievement failed to unlock after completing all Colin McRae Scenarios
     
  • Notes:
    All Scenarios completed on Medium (61) difficulty, except for the following, which were done on Very Hard (91):
    Greece 1994
    Argentina 1996
     
  • Platform:
    Xbox One X
     
  • Game version:
    Digital (Standard Edition + Seasons 1 & 2 + Seasons 3 & 4)
     
  • Non-Standard Peripherals:
    Fanatec Clubsport Formula V2, Fanatec CLS Elite Base, Fanatec CSL Elite Pedals LC

 

@UnderclassGDfan¬†and @Eagleizer¬†already reported similar (both did all Scenarios on Very Hard), merely adding what difficulties I did each Scenario on incase it helps identify anything¬†ūüôā¬†

Share this post


Link to post
Share on other sites

Yesterday I completed 4 out of 6 races of a "My Team" Rallycross championship at the Elite level. Today I tried to continue it and at first the server didn't answer, but when it did I received an error message saying that the progress didn't match and was reset. If now I try to access the championship, I need to start it from scratch.

When I played yesterday there were no connection issues and I still have the car I bought after completing the 4th race. Is there a way to recover the "My Team" progress?

Share this post


Link to post
Share on other sites
Posted (edited)
On 3/25/2020 at 7:49 AM, AlleyViper said:

I've had the same experience today (1.13) when trying to go for the Sunday Driver achievement (requires 100% AI). After winning comfortably 4 qualifiers in Hell under Heavy Rain (didn't block faster cars behind me), I then missed Semi-Finals by a surprising difference. Previously on 1.12 I've seen the same under career on Elite level (WRX 2018 class) on a few tracks, while not so much with RX2 where it became way easier to advance to Masters.

Ended up getting the Sunday Driver (Steam) achievement after a second try, just with a slightly faster pace than before w/ the 18' Audi EKS S1 to make sure it would register. Luckily the discrepancy in qualifier times wasn't so huge as before.

Now that I've been trying my luck on Masters RX Career with 2019 cars, it's gone out of hand. Having stuff like 4 consecutive events with 14 wins/2 2nd places on qualifiers, but then always ending on 16th and not reaching semi-finals. This due to differences of 5-15s from last to top drivers on other tiers vs best on mine. Only on a couple of events I could advance (with a 9-11th place), and then progress to the final where 4-2nd place would still be possible for my limited skill, for a final 15th place on the Championship.

I'd rather have the AI on my qualifiers much faster than it is (and then matching times for other "virtual" qualifiers), but then making me remain at a lower tier until I gain that pace, than having times between tiers completely unbalanced vs. the ones I participate on.

I hope CM sorts this before the final updates, as RX becomes unenjoyable if the player is required to lower the difficulty just to match the qualifier times he doesn't participate in to be able to advance to semis, while at the same time making the raced qualifiers AI easier/less challenging than required.

Edited by AlleyViper

Share this post


Link to post
Share on other sites
Quote
8 hours ago, Tigron said:

@PJTierney, could you please give a little comment on this, as there are already 2 people who noticed the problem?

Is it possible to get more detailed comment from devs on how "WET" physics was changed in 1.13, as patch notes don't provide enough detailed information?

Added video to illustrate the case.

Version 1.13 - Steam - Super Deluxe Edition

 

 

@PJTierney

On same software as above...  I believe what is really happening is that front tire grip was reduced a little while rear tire grip was all but eliminated.  This would explain the odd driving behavior post patch including the drastically increased braking distances and the new tendancy to literally slip off roads with the rear tires.  Moreover, the front tires steer reasonably well.  The back tires, on the other hand, drive as if on ice.

I should also add I have had hundreds of hours of REAL LIFE driving in a class 2 offroad sandrail on sand, dirt, clay and mud.  So, I am speaking from experience here.

So, please check on it.  

One other observation, I think grip levels seemed to be messed up in the Oculus SDK Steam PC VR version for a while.  Those same grip levels seem to have recently migrated into the non-oculus version on 1.13 or the prior version.  As a result, I had already switched back from VR to normal.  But now that normal has the reduced group I associated with the VR implementation, normal grip levels are now sub par as well. 

System:  Windows 10. Super Deluxe Edition, Steam, Accuforce pro V2 direct drive wheel, fanatec clubsport 3 pedals, fanatec handbrake, thrustmaster T8a shifter, NLR v3 motion platform, & Oculus Rift S.

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites
On 3/29/2020 at 6:54 AM, Eagleizer said:

Achievement not unlocked... 

 

Hey, had you completed any on a different difficulty before doing them on very hard? Trying to get to the bottom of this.

Share this post


Link to post
Share on other sites
16 minutes ago, CM_Ads said:

 

Hey, had you completed any on a different difficulty before doing them on very hard? Trying to get to the bottom of this.

I found the issue.
Changing the difficulty in any way, will cause this bug.

What I did:

Played the first 2 scenarios on 70.
Changed difficulty to 91.
Re-did those 2 scenarios.
Did all other scenarios except the last one.
Changed difficulty to 70.
Did the last scenario. No achievement.
Changed difficulty to 91.
Did the last scenario. No achievement ("If in doubt"... and "Flat Out").
Re-did many scenarios, changed to 100 etc., nothing.
Changed difficulty to 91.
Settings -> Profile -> Progress reset
Did all scenarios without EVER touching the difficulty option.
Both achievements unlocked! (First on X-Box!)

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

Still color banding with oculus rift. Still too low rendering distance on ground cover.

Edited by somethingthing

Share this post


Link to post
Share on other sites
Posted (edited)
19 hours ago, Tigron said:

@PJTierney, could you please give a little comment on this, as there are already 2 people who noticed the problem?

Is it possible to get more detailed comment from devs on how "WET" physics was changed in 1.13, as patch notes don't provide enough detailed information?

Added video to illustrate the case.

Version 1.13 - Steam - Super Deluxe Edition

 

 

 

The Subaru legacy and Impreza s4 have ridiculously stiff rear anti roll bar settings. The physics have not changed, its just seriously awful default setups on those cars.

For my testing in vr to make sure my graphical settings are ok after any update, i always run wales pant mawr stage, and i always run it in either the group a Impreza ir lancer evo 6 at night in heavy rain (worst case scenario for graphic settings to stress the game fully), and the driving physics feel the same as they always did. I even managed to get 3rd in the world on the last run i did over the weekend.

Check the setup of the car, lower the rear arb a lot.

Edit - Figured since I made such a bold claim about my time/lb posistion post 1.13 update, I better put up a pic to show im not talking out my rear.

OculusScreenshot1585410312.thumb.jpeg.1a52f97aaeec7dd2d3734ba5b4593d1b.jpeg

Edited by Ialyrn
  • Thanks 1

Share this post


Link to post
Share on other sites

Hello. I play in ps4. The trophies of fia wrx are bugged. I won 8 races, and dont give me the trophy also in the races win the 4 preliminare races, the semifinal and the final, but no thropy and the fastest start nothig.

Share this post


Link to post
Share on other sites
Posted (edited)
23 hours ago, neil3646 said:

@PJTierney @CM_Ads

Little update, managed to complete both of todays (Sunday) bonus daily MyTeam stages (R-GT in Scotland, and Legacy in Wales), without any post-stage crash at the "press continue" screen, as has been happening since 1.13 launched. Not sure if you guys have changed anything server side your end, but no problems in MyTeam mode for me today

Unfortunately the Mcrae scenarios still crash after every stage and cannot save any progress ‚ėĻÔłŹ

I take it all back. The S4 MyTeam daily event crashed today, but the Scotland kit car one worked fine

Edited by neil3646

Share this post


Link to post
Share on other sites
Posted (edited)
5 hours ago, UnderclassGDfan said:

I found the issue.
Changing the difficulty in any way, will cause this bug.

What I did:

Played the first 2 scenarios on 70.
Changed difficulty to 91.
Re-did those 2 scenarios.
Did all other scenarios except the last one.
Changed difficulty to 70.
Did the last scenario. No achievement.
Changed difficulty to 91.
Did the last scenario. No achievement ("If in doubt"... and "Flat Out").
Re-did many scenarios, changed to 100 etc., nothing.
Changed difficulty to 91.
Settings -> Profile -> Progress reset
Did all scenarios without EVER touching the difficulty option.
Both achievements unlocked! (First on X-Box!)

I did not understand very well you have to put the difficulty on 70 the first two challenges and then finish them again at 91 after. Do we have to redo all the 91 scenarios? Change the difficulty in the setting menu?

After you start all the tests again in any difficulty does it work?

Edited by nikos88

Share this post


Link to post
Share on other sites

Yup, same here. Not sure if I understood. Maybe just explain what the next steps would be once you started a scenario on any difficulty lower than 'very hard'. 

 

Share this post


Link to post
Share on other sites

Is there anyone who has got the bug where they don't get the "flat out" achievement that never did it on any other difficulty?

So anyone who just did them all on Very hard from the start.

Share this post


Link to post
Share on other sites
1 hour ago, CM_Ads said:

Is there anyone who has got the bug where they don't get the "flat out" achievement that never did it on any other difficulty?

So anyone who just did them all on Very hard from the start. ÔĽŅ

Me what I did I managed 6 events to 100 after no way to get there I lower the difficulty I chained 24 events in very difficult to 91. The last ten I made in very easy for the trophy finished in all the difficulties it is not unlocked.

Just after I did the last ten events in very difficult that I succeeded and no trophy either. A friend also just finished everything easy and nothing on his side. We're on PS4.

Share this post


Link to post
Share on other sites
3 hours ago, siasarrr said:

Hello. I play in ps4. The trophies of fia wrx are bugged. I won 8 races, and dont give me the trophy also in the races win the 4 preliminare races, the semifinal and the final, but no thropy and the fastest start nothig. ÔĽŅ

Have you raced in WRX World Championship mode? If you made them in custom party it doesn't work in this mode.

Share this post


Link to post
Share on other sites

Please fix your pos Colin mcrae challenges cpu times, they are constantly glitched out and giving out ridiculous times.

 

Way to go on a 5 stage challenge doing very well keeping ahead of the cpu then it does 6:08 instead of 6:27 on stage 3 as it should, (5 stage challenge in greece with the s4)

 

 

It's all fine to restart the challenge and get the right time, but when you're halfway though a very hard multi stage and it glitches you have to start over after spending hours getting sufficient times in the first 2 challenges.

 

complete nonsense. It's not complicated to have set times for these things, I'm not sure how you guys managed to make them glitch out.

  • Agree 2

Share this post


Link to post
Share on other sites

Hi, 

I believe I have noticed a Bug with the shifting on the Subaru Impreza S4 that was recently added. Despite it saying it is a manual car, if you choose "manual with clutch or sequential", the game puts it in sequential mode although it says it is manual.

 

  • Agree 2

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×