Jump to content
Sign in to follow this  

Mid 2011 iMac not running DiRT rally when it has better than minimum requirements

Recommended Posts

I just spent like deadass 24 hours downloading DiRT RALLY on my 2011 iMac, to find out that it wont let me play because "This Mac is not supported" Specs: Mid 2011 iMac, 2.7 GHz Intel Core i5, 12gb ram, AMD Radeon HD 6770M 512 MB. I'm not sure but shouldn't that be enough to run DiRT rally at minimum settings? Is there any way to edit the source file and allow my computer to pass as playable? I've already made attempts to delete my specs off of the specifications file. help? Is there any workaround to bypass the minimum requirements page?

Share this post


Link to post
Share on other sites
2 hours ago, AshleyMcLees said:

I just spent like deadass 24 hours downloading DiRT RALLY on my 2011 iMac, to find out that it wont let me play because "This Mac is not supported" Specs: Mid 2011 iMac, 2.7 GHz Intel Core i5, 12gb ram, AMD Radeon HD 6770M 512 MB. I'm not sure but shouldn't that be enough to run DiRT rally at minimum settings? Is there any way to edit the source file and allow my computer to pass as playable? I've already made attempts to delete my specs off of the specifications file. help? Is there any workaround to bypass the minimum requirements page?

Having the minimum specs for CPU, GPU and ram is only half the story when it comes to Macs. The OS and other things matter much more than on windows. Often some games will run on newer Macs, but they wont work at all on older ones. You seem to be in that very circumstance right here. Far as I can tell, by looking at the apple store page for the game; having a 2011 iMac, you may have missed out on system compatibility by about 2 years for game. The information is in the description about what Mac systems it will work on. Not sure if there is a work around, as Apple have some funny idea's when it comes to older hardware on their side. I dont use Macs personally, as I like to be able to game without resctrictions, and price of entry for Macs is way outside my budget. So I cant offer up any solutions for a work around either. But I would like to point to the fact that Dirt Rally 1 originally released in 2015, so 4 years after your imac. The Mac port of the game, according to the wiki page for Dirt Rally, released in 2017. So a further 2 years after that. So that is a 6 year gap from your imac been released to Dirt Rally for the Mac been released. I do hope you find a solution though, as it is a great game if you can get it running.

https://apps.apple.com/gb/app/dirt-rally/id1076935807?mt=12

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×