Jump to content Jump to content

2000 Thrustmaster Force Feedback Wheel Windows 10 64 bit Drivers


Recommended Posts

Just dusted off Formula 1 99 which runs on W10 64 bit quite happily.  But my year 2000 approx wheel doesn't run at all. 

https://support.thrustmaster.com/en/product/ffdrw-en/

Does anyone know if there are any divers/fixes out there??  By the dearth on the www and the Thrustmaster tech support, I guess it is time to recycle it via a bin?

Thanks.

Link to comment
Share on other sites

1 hour ago, thisdisplayname said:

Just dusted off Formula 1 99 which runs on W10 64 bit quite happily.  But my year 2000 approx wheel doesn't run at all. 

https://support.thrustmaster.com/en/product/ffdrw-en/

Does anyone know if there are any divers/fixes out there??  By the dearth on the www and the Thrustmaster tech support, I guess it is time to recycle it via a bin?

Thanks.

Try installing the driver package in Windows Vista Service Pack 1 compatibility mode? If you can reach the Thrustmaster CP then there's a chance.

Link to comment
Share on other sites

1 hour ago, thisdisplayname said:

Thanks.  I found the answer on a Microsoft forum - https://answers.microsoft.com/en-us/windows/forum/all/force-feedback-wheel-problems/1dbdffea-3744-4548-bfa5-32ad2f240310?page=5

So I tried that.

But now the pedals are reversed although in the Thrustmaster control panel they are the right way round??

Do you mean axis reversed (100% throttle with no input and 0% throttle with pedal 100%) or clutch/throttle swapped or brake / throttle swapped?

Link to comment
Share on other sites

On 4/1/2020 at 10:31 PM, thisdisplayname said:

Just the pedals switched. So left is now throttle and right brakes. Axis is correct.  Control Panel checks are perfectly correct.  

The simplest way to do this would be to remap the controls in-game.

Go into the control settings and map the right pedal to throttle and left pedal to brake. Be sure to have pressed the pedals fully and released before you go into the game settings.

Then do the same in the in-game, when remapping be sure to fully press and depress the pedals and save the new scheme and play!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...