Jump to content
Sign in to follow this  

Damage Bug (Xbox One)

Recommended Posts

So I've been getting a damage bug where I will finish a stage with no visible damage on the car then on the next stage it will show my front bumper smashed up and I will have to repair body damage. Now at first I thought maybe I was going crazy and I actually did finish the stage without damage, but today I finished a championship in Germany, went to the main menu, repaired all the damage on the car before starting the next championship in Australia. Right when I get to the first stage on Australia I already have body damage before running a shakedown or running a stage. ***?

  • Agree 1

Share this post


Link to post
Share on other sites
Posted (edited)
5 hours ago, bquick222 said:

So I've been getting a damage bug where I will finish a stage with no visible damage on the car then on the next stage it will show my front bumper smashed up and I will have to repair body damage. Now at first I thought maybe I was going crazy and I actually did finish the stage without damage, but today I finished a championship in Germany, went to the main menu, repaired all the damage on the car before starting the next championship in Australia. Right when I get to the first stage on Australia I already have body damage before running a shakedown or running a stage. ***?

Xbox One X

Version 1.13.0

Standard Xbox One controller

I am experiencing the same thing where I am 100% sure that I repaired the car before the next daily, stage or other event only to go into it the next stage with damage. Sometimes I will even have visible damage that cannot be repaired. The repair menu doesn't show that the vehicle is damaged or give me the option to repair it but the car is obviously damaged. I completed a weekly, repaired the car, went straight into a daily and had visible damage that could not be repaired before the stage. This has happened pretty much since I got the game but is random and I have no idea what is causing it.

Edited by FlatOverCrest

Share this post


Link to post
Share on other sites

PS4 Pro

Version 1.13.0

On the new Impreza S4 the left headlight is broken in my case, it doesn't give any light either, only the right one. Nevertheless, the setup always shows that everything is supposedly fine.

  • Like 1

Share this post


Link to post
Share on other sites

Sometimes there seems to be "transit damage" when advancing between rally events on a championship, resulting in light damage right before first stage. I got that on previous versions too, not sure if intended. (Steam user)

  • Agree 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×