Jump to content

DiRT Rally 2.0 - In-Game Server Connectivity

PJTierney

For general connectivity issues we don't provide one-to-one support on the forums, and you're best off emailing custservice@codemasters.com

Reporting issues in this thread is still useful however, as a large volume of reports in a short space of time clearly indicates wider connectivity issues and helps alert the support team.

 

Any major issues (ie: ones affecting the majority of players) will be posted about on Twitter @dirtgame.

If you're not seeing anything there, then any issue you have is likely isolated to you and/or a very small number of players.

Message added by PJTierney

PJTierney

If you are getting e4669c75-58-58, go here. This is common on Windows 7.

 

 

Message added by PJTierney

Recommended Posts

8 hours ago, Droges said:

sorry for not being more supportive. Curious what the fix was? Another load server? Thnks

Something very technical that I'll do a crappy job at explaining 🙂 

 

In short, certain calls to the server were temporarily disabled (or deprioritised) in order to allow more traffic through at key bottlenecks. 

 

Expecting even more people to play over the weekend, so support is keeping an eye on it.

 

 

  • Agree 2

Share this post


Link to post
Share on other sites
39 minutes ago, PJTierney said:

Something very technical that I'll do a crappy job at explaining 🙂 

 

In short, certain calls to the server were temporarily disabled (or deprioritised) in order to allow more traffic through at key bottlenecks. 

 

Expecting even more people to play over the weekend, so support is keeping an eye on it.

 

 

Yes, you are right. I believe many people they gonna play this days, over the weekend. And why not? It is the best game, if we can connect of course. So keep an eye on it team of CM.Thanks, and let's play. 

Share this post


Link to post
Share on other sites
4 hours ago, PJTierney said:

Something very technical that I'll do a crappy job at explaining 🙂 

 

In short, certain calls to the server were temporarily disabled (or deprioritised) in order to allow more traffic through at key bottlenecks. 

 

Expecting even more people to play over the weekend, so support is keeping an eye on it.

 

 

Would be awesome to get a more technical explanation though 😉 

Thank you for taking your time to fix it properly!

Share this post


Link to post
Share on other sites
Posted (edited)

Don't know if it's relation between in-game connection and clubs web pages, but the latter are staring to fail again:

image.png.47c60b47c611d4944b85718843865b02.png

Edited by MaXyMsrpl

Share this post


Link to post
Share on other sites
44 minutes ago, MaXyMsrpl said:

Don't know if it's relation between in-game connection and clubs web pages, but the latter are staring to fail again:

image.png.47c60b47c611d4944b85718843865b02.png

 

That happens every so often but is generally unrelated to the game, usually I have found it comes back after a few refreshes or when I disable certain plugins on my browser.

Share this post


Link to post
Share on other sites
On 4/9/2020 at 8:23 AM, Maun0Mato said:

Who the hell wants to play historic mode? It has no progression and cars are absolute trash.
90% of the actual game content is unavailable, progress is not saved, some even lost their progress altogether ( like even the progress before this server issue ), patience is not something anyone should ask for in this case.

a) I would not call My Team mode and online MP 90% of game content. that is a hilarious exaggeration.

b) regarding Historic mode. that's an opinion. it uses all the rally classes in the base game, so to call them trash is utter nonsense, as is the claim that it has no progression. if it had no progression everything would be unlocked from the start. 

c) oh look the servers were working for most within an hour or two of my comment

On 4/9/2020 at 9:21 AM, Frankiestail said:

I’m far from new to the game, just never had need to bother posting on forum before now.

then my comment was not directed at you.

Share this post


Link to post
Share on other sites

First of all, WHAT THE HELL IS WRONG WITH STEAM DISCUSSION BOARDS? I'm pretty sure no one wanted to sign up to this forum unless they wanted to complain about the server not working, particularly when this board requires a strong password. I couldn't just use my standard stupidly easy password for ******** I dont care about.

Soooo......."rare" you say. I was really really hesitant to download the 100+ gb when the game isn't much different to DR1 given all the reports of problems with the DR server. I took the plunge, and low and behold, the first time I start the game.......no connection. Seriously.....really seriously!! I also have an extremely stable and fast connection, which most people defending your product were using as a defence.

As a developer, are you really trying to commit suicide?????? You are going about it really well. SOOOO many people hate this online only thing and probably wont buy another game from you depending on how you respond to it going forward.

So the details.
Region: Australia,
What doing: Starting the game

Share this post


Link to post
Share on other sites
Posted (edited)

Nevermind, I got a fix that worked :).

Have a nice weekend
Cya

Edited by RZoltán

Share this post


Link to post
Share on other sites

Just finished the first event of the game and i get this connection failed screen. It says I'll lose my progress if I go to the main menu what kind of garbage is that, why force the player to be online to play the game, that is so stupid.

Platform: PlayStation

Region: Canada

20200411_175926.jpg

Share this post


Link to post
Share on other sites
Posted (edited)

Dirt Rally and Dirt Rally 2.0 not able to connect to racenet. Other codemastersgames havent tried yet.

Dirt 2.0 gives errorcode:  e4669c75-58-58

 

PC, The Netherlands, Steam

 

Didn't play for a while just reinstalled.. But no Dirt for me this weekend then!

Edited by MeNotMe

Share this post


Link to post
Share on other sites

PC / STEAM FRANCE

Error connecting code: e4669c75-3d-58

What is the problem? is there a solution?

Share this post


Link to post
Share on other sites

PC/Steam/Europe/Club event

Connection failed after SS2. Code = 35002aab00477c3-3a311d18-0-2. Been trying for 10 minutes now. This stuff has been going on since release, inexcusable.

 

Share this post


Link to post
Share on other sites
On 4/10/2020 at 6:00 PM, PJTierney said:

 

That happens every so often but is generally unrelated to the game, usually I have found it comes back after a few refreshes or when I disable certain plugins on my browser.

It might be unrelated to the game in the sense that it runs differently, but 99/100 times if I get an connectivity error in-game, I won't be able to log on the site to check either. And vice-versa.

Running really slow for me now as well. Both site and in-game.
PC - Norway
Chrome - Version 80.0.3987.163

Share this post


Link to post
Share on other sites
Posted (edited)

Im getting this one now during my weekly ai challenge. UK / Steam / Win 10 /UK

3ea4fbb8accdb04-3a311d18-0-2

😞

Edited by BillXYZ123

Share this post


Link to post
Share on other sites

Ps4 

UK 

Can get into sessions online racing 

Cannot connect to server 

Psn - online and working and Internet connection over 70mbp 

Share this post


Link to post
Share on other sites
Posted (edited)
On 4/11/2020 at 8:01 AM, RZoltán said:

Nevermind, I got a fix that worked :).

Have a nice weekend
Cya

Would you mind sharing??
Anyone? Haven't been able to connect to Racenet since I reinstalled last week.

Dirt Rally just says it can't connect to Racenet
Dirt Rally 2.0 gives error code  e4669c75-58-58 like I mentioned in my first post
PC Steam The Netherlands

Edited by MeNotMe

Share this post


Link to post
Share on other sites
Posted (edited)

15867460473908229685073266058491.thumb.jpg.2b37871c722320e420c22241a8ae3a6c.jpgPs4 Argentina. Unable to create and join multiplayer parties free mode custom championships. The network works corre ctly in other games. Error to conect. Impossible joining party

15867460473908229685073266058491.jpg

Edited by Maran151

Share this post


Link to post
Share on other sites
Posted (edited)

hi, i play on ps4 , and i had a problem:

i can connect to the servers, but i dont know why, i cant play custom online races or even my friends cant join the championships i create, note that i could do both things, like 3 days ago, but somehow i cant anymore, same problem that the post before

what can i do to fix this ?

thx for ur time

 

Edited by Deadghost25
completing the info

Share this post


Link to post
Share on other sites

What is happening with requests via ps plus? I'm trying to send a request and is impossible to connect

Share this post


Link to post
Share on other sites
2 hours ago, Deadghost25 said:

hi, i play on ps4 , and i had a problem:

i can connect to the servers, but i dont know why, i cant play custom online races or even my friends cant join the championships i create, note that i could do both things, like 3 days ago, but somehow i cant anymore, same problem that the post before

what can i do to fix this ?

thx for ur time

 

I'm having a similar problem, with friend requests via ps plus, I can't join in championships

Share this post


Link to post
Share on other sites
21 hours ago, Deadghost25 said:

hi, i play on ps4 , and i had a problem:

i can connect to the servers, but i dont know why, i cant play custom online races or even my friends cant join the championships i create, note that i could do both things, like 3 days ago, but somehow i cant anymore, same problem that the post before

what can i do to fix this ?

thx for ur time

 

 

18 hours ago, rjbs90 said:

I'm having a similar problem, with friend requests via ps plus, I can't join in championships

 

Just so I get this straight:

 

  1. You're both owners via PlayStation Plus
  2. When you're in Custom / Multiplayer, you cannot join other peoples' Lobbies
  3. When you're in Custom / Multiplayer, other players can't join your Lobbies

 

Is that correct?

 

You've probably already done this, but have you checked your NAT type in PlayStation settings?

Ideally you should be Type 1 or Type 2, Type 3 means something in your console/home setup is refusing connections to other players.

 

Share this post


Link to post
Share on other sites

When i set up my network and test it, this show me nat 2, i think that the free version of the game (that gave us ps plus) doesn't allow to accept friend request, i tried whit a friend who has the physical game, and i could join in a championship.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×