Jump to content Jump to content

[Xbox] Issues connecting keyboard and wheel simultaneously


Racer4446

Recommended Posts

When I connect a keyboard it resets all of my button bindings on my wheel.  In other words, it tries to load a different profile instead of my custom profile.  In the settings, when I plug in the keyboard it activates the "Fanatec Univeral Hub" or something along those lines.  It then tries to use the default button bindings that are assigned to that profile.  Disabling it does not work as it just re-enables itself.  The only fix is unplugging the keyboard.  Granted, I only use the keyboard to name setup saves, but to keep going into settings to make sure my custom wheel profile is in fact loaded after unplugging the keyboard is a PITA. 

Thought I'd add this here as well as it's an issue I recently noticed since returning to the game post 1.22 patch.  The FFB settings on my TX wheel have been weird.  Anything below 70 and the wheel weight seems to disappear.  The numbers don't seem to represent a linear drop/gain in FFB feel.  I used to have it set to somewhere around 50 as I don't like a heavy wheel but still like to have some weight to feel the grip more.  Now I have to have it at 75 where it's just a little too heavy but like I said anything lower and the wheel weight disappears.  Anyone else experience this?

Link to comment
Share on other sites

  • Moderator

Do you connect the keyboard while in the game or before starting the Xbox/game? I use a keyboard and wheel next to eachother because I also use the keyboard to map game game functions. Both appear in at the bottom of my saved wheels/keyboards but sometimes twice were the first is listed as keyboard/wheel and the second listing appears as wheel/keyboard. I found out that the first one is confusing the ffb and messing up my saved settings. Check this out and whenever you have a keyboard plugged in, make sure to choose the wheel/keyboard setting. I might be the other way round because I do this by memory and that fails sometimes (age). If your second issue is not solved by my answer, please make a separate post and delete the second posting in this post as it might be confusing.

Link to comment
Share on other sites

 
 
 
 
 
 
 
5
14 hours ago, 1512marcel said:

Do you connect the keyboard while in the game or before starting the Xbox/game? I use a keyboard and wheel next to eachother because I also use the keyboard to map game game functions. Both appear in at the bottom of my saved wheels/keyboards but sometimes twice were the first is listed as keyboard/wheel and the second listing appears as wheel/keyboard. I found out that the first one is confusing the ffb and messing up my saved settings. Check this out and whenever you have a keyboard plugged in, make sure to choose the wheel/keyboard setting. I might be the other way round because I do this by memory and that fails sometimes (age). If your second issue is not solved by my answer, please make a separate post and delete the second posting in this post as it might be confusing.

I usually start the Xbox.  Once the Xbox is booted I plug in the wheel.  Once that is calibrated I plug in the keyboard and then start the game.  Other times I plug in the keyboard when in the game.  I'll try different startup configurations but if I recall both methods did not stop F12019 from activating the Fantatec Univeral Hub.  If I recall I think 3 things have a checkmark next to them when I have the keyboard plugged in.  The fanatec universal hub (I don't own anything Fanatec), keyboard, and my custom wheel profile.  I will double-check all this later today and post back if I am wrong. 

I will try selecting wheel/keyboard and see if that solves it as well. 

Thanks

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...