Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

Ego dumper crash every race (PC)

Recommended Posts

Posted (edited)

Big fan of the f1 series and I’ve been playing on PlayStation for years and made the switch over to pc for graphical reasons and ease of using tunes already made. Ever since I purchased the game a few weeks ago I haven’t been able to play a full race. It just randomly crashes and brings up the ego dumper screen. My pc is fairly reasonably spec’ed and I’m only running on high settings yet it keeps doing it

My specs

Ryzen 5 2600x

16gb 3200mhz ram

AMD RX 590 graphics card

Im not overclocked and im running xmp profile 1 for my ram

I’ve tried running in dx11 as suggested and I have reset settings by running in safe mode via steam and it lets me get a little further but still crashes out

Any help would be much appreciated Thanks

Edited by YOULLKNOWWHO
Formatting

Share this post


Link to post
Share on other sites

Sorry for capturing your thread but i got the same problem.

Game crashes on Monaco in career mode several times. I haven't tried another race.

My Spec:

Intel I7 -4790k

32gb Ram

MSI Geforce 2080 ti 11gb

nothing overclocked.

I Have tried it on DX11 and DX12...on DX11 the ERROR occures later but the result is the same. Not possible to finish Monaco GP.

 

Kind regards

Michael

 

DxDiag.txt

Share this post


Link to post
Share on other sites
Posted (edited)

There's a pinned notice about the 445.75 drivers being no good. Please DDU and go back to 442.74. DX12 will work with these drivers.

I have had that exact CPU and I know there is errata that causes it to crash when in Turbo mode. If you disable the Turbo in BIOS you may find stability. It is a pretty fast CPU at stock 4GHz!

If you post your board name I will be able to update the uCode of the image in the latest BIOS, although I suspect it may be ASUS Z87-C* (* if it is, it is the latest BIOS and I can't update it with it being encapsulated, so you should use KB4497165; use the W10X64 for 1903 version). But the dxdiag has a B85 driver in there, so my guess might be incorrect.

Is the Silicon Power SSD SATA or m2? (Just interested as I have the m2 NVMe 512GB and it's a steal because it's as fast as a Corsair for less £).

Edited by steviejay69

Share this post


Link to post
Share on other sites
Posted (edited)

My board is the ASUS B85-Pro Gamer and the silicon Power SSD is m2.

and thanks for your help !!!

 

Btw. i'm using the Logitech G935 wireless headset. Is it really possible that this one causes this error like yohan wrote in another thread?

Edited by Miraya75

Share this post


Link to post
Share on other sites
1 hour ago, Miraya75 said:

My board is the ASUS B85-Pro Gamer and the silicon Power SSD is m2.

and thanks for your help !!!

Btw. i'm using the Logitech G935 wireless headset. Is it really possible that this one causes this error like yohan wrote in another thread?

Yes, if it has a USB audio dongle (according to specifications, it does) try GHub updating firmware if available, but yeah, try troubleshooting without. 

The updated 2203 BIOS is here, FWIW. I still can't update the uCode due to encapsulation, so use the KB4497165 update as linked earlier.

SPCC toolbox (I put it on Dropbox as it's behind a verification page so hardlinking isn't possible)

Share this post


Link to post
Share on other sites
9 hours ago, Miraya75 said:

My board is the ASUS B85-Pro Gamer and the silicon Power SSD is m2.

and thanks for your help !!!

 

Btw. i'm using the Logitech G935 wireless headset. Is it really possible that this one causes this error like yohan wrote in another thread?

I still get occasional crashes now and then but since i unplugged my Logitech headphones and my TV hdmi, disabled steam overlay and reverted nvidia drivers it works semi good. The crashes are more far apart, so it's playable. I can't tell 100% that it's the headphones. But it feels like it started running better when i unplugged them. But I still get crashes so idk.. maybe its the wheel. lol it feels stupid writing all this. cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×