Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

[PC]- Logitech G29 has no centering spring

Recommended Posts

Posted (edited)

[PC]- Logitech G29 has no centering spring, F1 2019 AND 2018

 

1.       My issue: My Logitech G29, when playing f1 2018 and 2019 completely lacks 'center spring' effect.  Other force feedback things seem to work, as the wheel is reacting to road elements and such, but otherwise there's no resistance and it's light as a feather and therefore unplayable. No error codes.

2.       What version of the game you are using (Shown on the start screen in the bottom left corner of the screen).  F12019 1.22, f1 2018 1.16

3.       Game-mode? ALL

4.       Are you able to recreate the issue? If so, please include recreation steps on how you encountered this issue.   I can't UNCREATE IT, so yes.  To recreate, I simply attempt to play the game.

5.       How often do you see this problem? Is it the only time or does it always happen? Always.

6.       Have you tried any troubleshooting? We recommend the steps here as a starting point for any issues. Please let us know what troubleshooting methods you have tried while creating this post. Yes.  Reinstalling the program itself.  Varifying files in steam.  Uninstalling logitch software.  Reinstalling logitech drivers.  Tried both Logitech LGS and G Hub.  Tried tweaking the options within those programs. I even tried the 'registry' trick that some users mention in a different forum.  No luck

7.       Any accessories you are using (gamepad, wheel etc) Logitech G29, which has 0 issues on every other software I play (including other codemasters titles)

8.       Any screenshots or video of the issue? If the video is long, please include a timestamp for when the issue appears. No way to show it on a screen.

 

 

Hi all

 

This seems to be a frequent topic but here I am.  

 

My issue: My Logitech G29, when playing f1 2018 and 2019 completely lacks 'center spring' effect.  Other force feedback things seem to work, as the wheel is reacting to road elements and such, but otherwise there's no resistance and it's light as a feather and therefore unplayable.  The same exact wheel in the 2018 PS4 version of the game works perfectly, but I'd much much rather keep all my racing on the PC, Plus I just purchased f1 2019 to play (on pc)

 

Steps taken:

reinstalls, registry edits, different usb ports, etc.  There are a few mentions of a similar problem on these forums but yet nothing has worked for me.

For comparison, every other racing game on my pc works without issue.  iracing, asseto corsa, Dirt Rally 1,  Dirt Rally 2, Dirt 4, Project cars 1 and 2, etc etc. 

I'm not a big settings changer and I play default in almost every driving game... that's all I want to do here...

 

I would love to solve this problem as I really enjoy your games!

Edited by SrcrrMcky
Updated to make it a proper 'bug report'.

Share this post


Link to post
Share on other sites
On 4/10/2020 at 6:58 PM, SrcrrMcky said:

Hi all

 

This seems to be a frequent topic but here I am.  

 

My issue: My Logitech G29, when playing f1 2018 and 2019 completely lacks 'center spring' effect.  Other force feedback things seem to work, as the wheel is reacting to road elements and such, but otherwise there's no resistance and it's light as a feather and therefore unplayable.  The same exact wheel in the 2018 PS4 version of the game works perfectly, but I'd much much rather keep all my racing on the PC, Plus I just purchased f1 2019 to play (on pc)

 

Steps taken:

reinstalls, registry edits, different usb ports, etc.  There are a few mentions of a similar problem on these forums but yet nothing has worked for me.

For comparison, every other racing game on my pc works without issue.  iracing, asseto corsa, Dirt Rally 1,  Dirt Rally 2, Dirt 4, Project cars 1 and 2, etc etc. 

I'm not a big settings changer and I play default in almost every driving game... that's all I want to do here...

 

I would love to solve this problem as I really enjoy your games!

There's plenty of detail here, but please just post a standard bug report. This is a big enough issue to warrant proper support from Codemasters.

Share this post


Link to post
Share on other sites

[PC]- Logitech G29 has no centering spring, F1 2019 AND 2018

 

1.       My issue: My Logitech G29, when playing f1 2018 and 2019 completely lacks 'center spring' effect.  Other force feedback things seem to work, as the wheel is reacting to road elements and such, but otherwise there's no resistance and it's light as a feather and therefore unplayable. No error codes.

2.       What version of the game you are using (Shown on the start screen in the bottom left corner of the screen).  F12019 1.22, f1 2018 1.16

3.       Game-mode? ALL

4.       Are you able to recreate the issue? If so, please include recreation steps on how you encountered this issue.   I can't UNCREATE IT, so yes.  To recreate, I simply attempt to play the game.

5.       How often do you see this problem? Is it the only time or does it always happen? Always.

6.       Have you tried any troubleshooting? We recommend the steps here as a starting point for any issues. Please let us know what troubleshooting methods you have tried while creating this post. Yes.  Reinstalling the program itself.  Varifying files in steam.  Uninstalling logitch software.  Reinstalling logitech drivers.  Tried both Logitech LGS and G Hub.  Tried tweaking the options within those programs. I even tried the 'registry' trick that some users mention in a different forum.  No luck

7.       Any accessories you are using (gamepad, wheel etc) Logitech G29, which has 0 issues on every other software I play (including other codemasters titles)

8.       Any screenshots or video of the issue? If the video is long, please include a timestamp for when the issue appears. No way to show it on a screen.

Share this post


Link to post
Share on other sites
5 hours ago, steviejay69 said:

There's plenty of detail here, but please just post a standard bug report. This is a big enough issue to warrant proper support from Codemasters.

Sure, edited to be a proper report.

  • Thanks 1

Share this post


Link to post
Share on other sites

Hi SrcrrMcky,

Bit of a delayed response here but did you ever manage to fix the issue you were having?

I've just recently started playing F1 2019 again on the pc on my G29 and I'm having a similar thing to what you are describing. It's not game breaking but I definitely feel that the centre spring isn't really working as it should in this game.

I've had a bit of a google on it but not found much on it really.

Thanks

Share this post


Link to post
Share on other sites

Hi Ronb1

 

There was no simple answer on any forum, but a nice guy sent me a PM with a fix.

 

For ME, I have to load the game, see the problem, close the game, open my registry editor and change This

 

Go to HKEY_CURRENT_USER\System\CurrentControlSet\Control\MediaProperties\PrivateProperties\Joystick\OEM\VID_046D&PID_C24F
Test this values, it works for me:
OEMName: "Logitech G29 Driving Force Racing Wheel USB" instead of "G29 Driving Force Racing Wheel"
OEMData: 43 00 08 10 19 00 00 00 instead of 00 00 00 10 00 00 00 00"

 

and then reopen the game.

 

It's a hassle, but it works.  

Share this post


Link to post
Share on other sites

Hi.

I have G920 and have problem with wheel rather than game, after PC restart in F1 my acc pedal is maxed out when I'm not touching it.

In asseto corsa I have to revert Brake and acc pedals to make it work and than in F1 2k19 FFB is very weak or even almost gone.

But the trick with changing values in regedit works fine.

I found that this was because of Project Cars messing something in windows, but since I don't have it installed something still mess with wheel.

Anyway once u change it in regedit, u can export it and just run shortcut and everything is done without entering regedit, bur for me I have to do it everytime I restart/boot PC.

 

Share this post


Link to post
Share on other sites

Hi SrcrrMcky,

That's great! Thank you so much for the reply and also replying so quickly! I'm glad to hear you have yours working :)

I will definately give this a try, I've just packed away for the day today but I'll give this a go tomorrow for sure.

Really appreciate the detail you've put in your response for the fix, is much appreciated 👍

Many thanks

Ronb

 

 

Share this post


Link to post
Share on other sites

Yeah erumasta, I've heard about that problem as well but in my case it happens whether or not I play another game.

 

And Ron, no problem Hope it works...

Share this post


Link to post
Share on other sites

Hi Erumasta,

Thanks also, yes the shortcut sounds like a good idea! Nice and quick, also appreciate your input in this, and good to hear you manged to sort it as well 👍

Many thanks,

Ronb

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×