Jump to content Jump to content

[F1 2019][PC] - In game dead zone but settings ok


Kilson76

Recommended Posts

1.       A description of the issue. Please include any error codes here.

Hello all,

I seem to have an issue with the deadzone for the steering, however its not like all the other issues i have read on here. Within setting calibration the detection of turning of the wheel is instant, it goes from 1 to 100 smoothly in both directions, with no deadzone. However when in game i need to turn the wheel to about 8 before it will detect and at this point the steering jumps straight to 8, ruling out any finer movements. This isn't so bad on corners but on the straights it can cause problems.

Anyone had this issue before? It can pick up all movements in the settings screen but just not when actually in game.

2.       What version of the game you are using (Shown on the start screen in the bottom left corner of the screen)

1.22

3.       Game-mode?

All game modes

4.       Are you able to recreate the issue? If so, please include recreation steps on how you encountered this issue.

Yes. When in setting screen within calibration i can turn wheel any direction and it will register. When in game i make the same movements and it won't register the first few degrees of movement. When movement is detected the wheel will skip the first few degrees of movement. The rest of movement is smooth.

5.       How often do you see this problem? Is it the only time or does it always happen?

Always happens

6.       Have you tried any troubleshooting? We recommend the steps here as a starting point for any issues. Please let us know what troubleshooting methods you have tried while creating this post.

I have tried using, and xbox 360 pad, steam controller and a Ferrari F458 Italia Racing Wheel, also tried them in different usb slots. I have also tried every possible configuration setting with steam and also default settings. I have tried big picture mode and without. I have edited the actionmaps config files within the game directory to remove all deadzones and then recovered to backup. I have also tried all possible in game settings.

7.       Any accessories you are using (gamepad, wheel etc)

Steam controller, xbox 360 pad, Ferrari F458 Italia Racing Wheel.

8.       Any screenshots or video of the issue? If the video is long, please include a timestamp for when the issue appears.

I can get a video if needed, let me know.

 

Link to comment
Share on other sites

2 hours ago, Kilson76 said:

Hello all,

I seem to have an issue with the deadzone for the steering, however its not like all the other issues i have read on here. Within setting calibration the detection of turning of the wheel is instant, it goes from 1 to 100 smoothly in both directions, with no deadzone. However when in game i need to turn the wheel to about 8 before it will detect and at this point the steering jumps straight to 8, ruling out any finer movements. This isn't so bad on corners but on the straights it can cause problems. 

Anyone had this issue before? It can pick up all movements in the settings screen but just not when actually in game.

You need to post a full bug report if the wheel is on the supported list for the game.

Link to comment
Share on other sites

1 hour ago, Kilson76 said:

I believe I have fixed the issue. Looks like the game will always have slight deadzone if a gamepad was detected, even through a wheel, I believe steam was making my wheel detect as a gamepad so the game was applying the deadzone. Whats strange is that the setting page will show no evidence of this, only when actually driving the car. Also it appears to have applied a large linearity independent of what the setting page was set to as well. Anyway disabling any input from Steam, so it never gets involved in controller setup seems to have fixed it and better still handling is now so much better, if a lot harder to get used to. 

Apologies if I wasted anyone's time I did do plenty of searches, just didn't use the correct terms it seems.

Coming back with the fix is extremely valuable so thank you. The search feature is terrible, I give you that!

Link to comment
Share on other sites

Yeah no worries, for me anyway this worked. I just went from the menu bar in Steam:  

Steam - Settings - Controller - General Controller Settings

Within there I just unchecked all the tick boxes, but I believe it was the Xbox Configuration Support check box that was causing the problem.

Hope that helps.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...