Jump to content Jump to content

ERS in F1 2019 not working


Gianchy74

Recommended Posts

I'm using F1 on PS4 with Thrustmaster T300RS and F1 add on wheel set.

The DMT is correctly activating and I can change the configuration parameters, but when I try to change the ERS setting, it is not possible. No adjustment possible.

I have tried to check the settings in the game to be sure to have the ERS enabled, but nothing is changed.


Could someone help me ?

Thanks, Gian Claudio

Link to comment
Share on other sites

In the assist menu you need to have the ERS set to manual. If you are in a multiplayer lobby the assist RESTRICTIONS need to be set to allow manual ERS (can't remember which way around this is worded but I think Automatic mandates the use of Auto ERS regardless of the individual assist setting).

Link to comment
Share on other sites

3 minutes ago, Gianchy74 said:

I' m not in multiplayer, just during weekend event. So the setting ERS to manual is from main menu (out of the event) or in the weekend option ? 

Thanks

I'm not sure, but I would check there yes. I'm sorry but I don't use all the modes.

Link to comment
Share on other sites

45 minutes ago, Gianchy74 said:

I'm using F1 on PS4 with Thrustmaster T300RS and F1 add on wheel set.

The DMT is correctly activating and I can change the configuration parameters, but when I try to change the ERS setting, it is not possible. No adjustment possible.

I have tried to check the settings in the game to be sure to have the ERS enabled, but nothing is changed.


Could someone help me ?

Thanks, Gian Claudio

Ps4 gamer here also.

I am using the same F1 add on wheel from Thrustmaster and the way i do it, is by selecting in the game menu "shortcut" the dials button on my wheel. I am using the left one as fuel in/decrease when rotating and the right dial button as ERS increase/decrease.

 

Can you try with the shortcut?20191005_092838.thumb.jpg.48f52be55807b12f8d1da06936bf8d56.jpg20200329_001129.thumb.jpg.6c4f5abeb1b96d42ce31f032cd483b4f.jpg

Link to comment
Share on other sites

3 hours ago, GioProductions said:

Ps4 gamer here also.

I am using the same F1 add on wheel from Thrustmaster and the way i do it, is by selecting in the game menu "shortcut" the dials button on my wheel. I am using the left one as fuel in/decrease when rotating and the right dial button as ERS increase/decrease.

 

Can you try with the shortcut?20191005_092838.thumb.jpg.48f52be55807b12f8d1da06936bf8d56.jpg20200329_001129.thumb.jpg.6c4f5abeb1b96d42ce31f032cd483b4f.jpg

@GioProductions I think he has the controls already selected, it is just the ability to adjust the ERS at all due to the assist restrictions or assist settings. 

Link to comment
Share on other sites

Hi, ok thanks I' ll try. Till now I have used the menu, configuring the DMT function, but I' m not using shortcut. This because I get the "attention tip" that say, button already used for other function. Just one information, do you have this message when you configure the wheel as shortcut ? The strange thing is that from the menu, I use "PL" button to enter in DMT function and the wheel to navigate and modify settings. They works perfectly for all the other settings, but when I select ERS, no way to get change.

Link to comment
Share on other sites

5 hours ago, Gianchy74 said:

Hi, ok thanks I' ll try. Till now I have used the menu, configuring the DMT function, but I' m not using shortcut. This because I get the "attention tip" that say, button already used for other function. Just one information, do you have this message when you configure the wheel as shortcut ? The strange thing is that from the menu, I use "PL" button to enter in DMT function and the wheel to navigate and modify settings. They works perfectly for all the other settings, but when I select ERS, no way to get change.

Have you updated the wheel firmware, T300 should be v31? (Done on a PC with the wheel in PS3 mode, all the drivers and instructions are on the Thrustmaster website).

If you have and still have the issue, I would delete the custom control scheme and remap the original default profile then save it as custom. It will warn you if you try to map a control that would then be a conflict. So, if there is a conflict, either unbind the existing control using the same key or use another key.

Link to comment
Share on other sites

@Gianchy74 I have loaded the Weekly Event mode (for the first time ever). I have used the custom settings displayed in all other modes. However, in normal gameplay I use Manual ERS.

This is one setting NOT carried through from other game modes, you can see the ERS is Automatic.

It is a list I am working on of all the game settings that are reset or not, carried through or not between modes. This may explain that whilst you thought manual ERS was set, it is not carried to Weekly Event (at least the first time).

20200415111157_1.jpg

Link to comment
Share on other sites

Hi All, thanks a lot for the help. I found that my steering wheel was not updated at the latest revision. I did the update and I found also the settings to put ERS in manual mode. Now everything is fine.

Thanks again, Gian Claudio

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...