Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×
Scheduled Updates and BETA Shutdown - 06/07/2020 Read more... ×
F1 2020 | KNOWN KEY ISSUES | READ ME!!! Read more... ×
Sign in to follow this  

Lobby Host glitch + More

Recommended Posts

@BarryBL I'll tag you so it won't slip trough again. 

1.       A description of the issue:
So a very well known issue with this game and one that still hasn't been fixed is the lobby host glitch. 
This glitch tanks the fps of the host big time very randomly after someone leaves (we have a rule in our league that even if you retire lap 1 you cant leave session for this reason)
Apart from this glitch still being not fixed and causing a LOT of issues.. (even when we make the spectator the host at least it doesn't affect the race but it has the potential to ruin the stream)
it also causes more issues as can be seen in the video where a driver who has this issue gets a penalty by the game. 

The host needs to leave and rejoin session, which has a high chance of causing 'migrating host' for the rest of the race and requiring a restart altogether (this has happened in quite  a few races)

This highlights 3 big issues in one fell swoop: 

1. This lobby host glitch is stil not fixed
2. The penalty system is totally broken (Car behind was not on a hotlap) 
3. We can't turn of these stupid penalties where the game is wrong 90%^of the time. 

2.       What version of the game you are using 
1.22

3.       Game-mode? 
Unranked invite-only. (League race)

4.       Are you able to recreate the issue? If so, please include recreation steps on how you encountered this issue. 
This is a, just keep playing (as the host) and you will notice this happening before long kinda thing. 
Doesn't happen every race. Happens way too often still. It kills races too (Host needs to leave which can kill the lobby)
It can basically ALWAYS happen to the host when someone leaves the lobby

5.       How often do you see this problem? Is it the only time or does it always happen? 
It happens way too often. Luckily not THAT often during league races cause not many people leaving and joining. 

6.       Have you tried any troubleshooting? We recommend the steps here as a starting point for any issues. Please let us know what troubleshooting methods you have tried while creating this post. 

It can happen to anyone who is the host at anytime and it appears to be totally random (187 people can leave just fine and 188 cause the issue) 

7.       Any accessories you are using (gamepad, wheel etc) 

This is not caused by anything like this. 

8.       Any screenshots or video of the issue? If the video is long, please include a timestamp for when the issue appears.   
https://www.youtube.com/watch?v=hInc2jTAKXo

 

Share this post


Link to post
Share on other sites

At the moment, I haven't yet ran into an FPS drop through our leagues, and I've been the host for all 3. However, I did get RKO'd (not naming names 😄) and did leave the lobby. If anyone can confirm maybe if they ran into any FPS drops form our (albeit) small sample size, it would be useful here.

@UP100 @1512marcel @steviejay69 @massa88 anything? I can ask in the thread too.

 

Share this post


Link to post
Share on other sites
Posted (edited)
23 minutes ago, BarryBL said:

At the moment, I haven't yet ran into an FPS drop through our leagues, and I've been the host for all 3. However, I did get RKO'd (not naming names 😄) and did leave the lobby. If anyone can confirm maybe if they ran into any FPS drops form our (albeit) small sample size, it would be useful here.

@UP100 @1512marcel @steviejay69 @massa88 anything? I can ask in the thread too.

 

This does happen in Unranked, but so far our Championship lobbies have been League which seems entirely less stable. Maybe we will have more on Friday, but it's not every time. It's completely random and frustrating but often enough that it simply can't be ignored.

If we took a quick poll before the race on Friday if people can post a Speedtest to London (including you @BarryBL) and indicate whether they are playing wired or wireless that would help to quantify things.

Edit: most users complain if they are at over 60FPS. The game seems to keep the FPS rate but it runs much lower and stutters. ALT-TAB seems to have an effect but you really need to pit to do it safely. I guess if you are a long way away from others on track the AI can do a job while you return.

Edited by steviejay69
High FPS
  • Agree 1

Share this post


Link to post
Share on other sites
Posted (edited)
23 minutes ago, steviejay69 said:

Edit: most users complain if they are at over 60FPS. The game seems to keep the FPS rate but it runs much lower and stutters.

This can happen because the FPS that's being monitored is how many frames are being drawn, not how many "steps" the physics or game code go through. In a simple game (in which the drawing and physics are on a different core for instance) the game/physics side could be running at 25% the speed thanks to the CPU core not being quick enough to process everything, while the drawing side is completely fine.

Edited by UP100

Share this post


Link to post
Share on other sites
Posted (edited)
4 minutes ago, UP100 said:

This can happen because the FPS that's being monitored is how many frames are being drawn, not how many "steps" the physics or game code go through. In a simple game (in which the drawing and physics are on a different core for instance) the game/physics side could be running at 25% the speed thanks to the CPU not being quick enough, while the drawing side is completely fine.

Yes but when this is happening on CPUs that exceed the minimum and even the recommended spec then there's something rotten in Denmark (or Finland for that matter 🙂 )

Do you not think that at this point there is something amiss in the game engine? Because I can think of no other explanation.

Edited by steviejay69
  • Agree 1

Share this post


Link to post
Share on other sites
20 hours ago, steviejay69 said:

This does happen in Unranked, but so far our Championship lobbies have been League which seems entirely less stable. Maybe we will have more on Friday, but it's not every time. It's completely random and frustrating but often enough that it simply can't be ignored.

If we took a quick poll before the race on Friday if people can post a Speedtest to London (including you @BarryBL) and indicate whether they are playing wired or wireless that would help to quantify things.

Edit: most users complain if they are at over 60FPS. The game seems to keep the FPS rate but it runs much lower and stutters. ALT-TAB seems to have an effect but you really need to pit to do it safely. I guess if you are a long way away from others on track the AI can do a job while you return.

i agree with @steviejay69
if we play in league mode i didn't notice any problems with fps drop
it mostly happens in unranked lobbies and ranked
for me that started two patches ago
before game was running quite smothly online

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×