Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×
Scheduled Updates and BETA Shutdown - 06/07/2020 Read more... ×
F1 2020 | KNOWN KEY ISSUES | READ ME!!! Read more... ×
Sign in to follow this  

[PS4] Faulty downshifting

Recommended Posts

Posted (edited)

I recently began playing F1 for the first time using my new Logitech G29 Steering Wheel and after a few races I noticed the game won't consistently register my downshifts.

The upshift works just fine but every few clicks of the left paddle shifter, one click isn't registered which can result in me not being able to properly take a corner.

As mentioned before I'm using a brand new G29. I have also tried the wheel on two other games, Gran Turismo Sport and Dirt Rally 2.0 to be specific. In these two games the left paddle shifter works perfectly so it isn't something to do with the wheel. I have played career mode and time trial mode and the issue is present in both. I couldn't find any similar issues in pre-existing posts, so I made this one.

Edit: I just tested a formula 1 car and the problem isn't present there at all so it is just a formula 2 thing, don't know if this is intended.

 

Edited by Jwoos

Share this post


Link to post
Share on other sites

Probz best to look through that first. Seems a strange one that.

 

 

Share this post


Link to post
Share on other sites
18 hours ago, Jwoos said:

I recently began playing F1 for the first time using my new Logitech G29 Steering Wheel and after a few races I noticed the game won't consistently register my downshifts.

The upshift works just fine but every few clicks of the left paddle shifter, one click isn't registered which can result in me not being able to properly take a corner.

As mentioned before I'm using a brand new G29. I have also tried the wheel on two other games, Gran Turismo Sport and Dirt Rally 2.0 to be specific. In these two games the left paddle shifter works perfectly so it isn't something to do with the wheel. I have played career mode and time trial mode and the issue is present in both. I couldn't find any similar issues in pre-existing posts, so I made this one.

Edit: I just tested a formula 1 car and the problem isn't present there at all so it is just a formula 2 thing, don't know if this is intended.

 

@Jwoos Check the Driving Force shifter is in Neutral. Disconnect any other controllers to troubleshoot.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×