Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×
Sign in to follow this  

EGo dumper error in f1 2019 and AMD

Recommended Posts

Posted (edited)

Hello, I am getting the EGO Dumper error all the time when I try to play the game, with directx 11 and 12.

My graphic drivers and WIndows 10 are updated and I have removed all the apps that use overlays. I have reintalled the game and I am starting the game in 'safemode', but It still crash.

My graphic card is xfx amd radeon rx 5700 xt thicc ii ultra 8gb gddr6

Can someone help me? I attach the logfile.


Thank you in advance.

ego_dumper_error.txt

Edited by UP100
Added 'solved' prefix

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, Goaqi said:

Hello, I am getting the EGO Dumper error all the time when I try to play the game, with directx 11 and 12.

My graphic drivers and WIndows 10 are updated and I have removed all the apps that use overlays. I have reintalled the game and I am starting the game in 'safemode', but It still crash.

My graphic card is xfx amd radeon rx 5700 xt thicc ii ultra 8gb gddr6

Can someone help me? I attach the logfile.

Thank you in advance.

ego_dumper_error.txt

A proper bug report and a dxdiag is required please @Goaqi

Edited by steviejay69

Share this post


Link to post
Share on other sites

If you can add a complete bug report @Goaqi that would be great. Template for this is in the green toolbar at the top of this subforum.

 

Share this post


Link to post
Share on other sites
Posted (edited)

1.       I'm getting the EGO DUMPER ERROR a few seconds laters when I start the game, using DX11 and DX12. I am starting the game now in safe mode and I get the error "d3d device has been removed reason" one in a while.
2.       What version of the game you are using? 1.22
3.       Game-mode? Singleplayer, I haven't tried the multiplayer because the crash.
4.       Are you able to recreate the issue? When I press "any key to continue" (i don't know if that is the message, I have the game in spanish. 
5.       How often do you see this problem? Every time when I start the game. 
6.       Have you tried any troubleshooting? I have checked the driver of the graphic card and Widnows 10 were updated, I have disabled any software that use an overlay, and I am starting the game in safe mode.
7.       Any accessories you are using (gamepad, wheel etc): A wheel, Logitech G29
8.       Any screenshots or video of the issue?

             I get the prompt with the logfile posted in #1 https://forums.codemasters.com/applications/core/interface/file/attachment.php?id=17748.  

             I have get the D3D error 2 minutes ago (attached a screenshot)

2020-05-11 (2).png

EDIT 2:

I have get the EGO DUMPER ERROR again.

I have get the last 2 errors running the game in "safe mode"

I hope someone could help me, thank you again.

Edited by Goaqi
  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Goaqi said:

I'm sorry, I was trying to fix it for hours and I forgot the files.

I've attached the DxDiag and 2 crash_dump, one of DX11 and the other of DX12.

Thank you in advance for the help.

crash_dump#614494-20200511-045820-0.zip

DxDiag.txt

crash_dump#614494-20200511-041730-0.zip

Can you DDU the drivers please? You might want to try my latest stable version 20.1.3 (however I run a RX580)

The crashes seem fairly firmly rooted with the driver, looking at the dxdiag.

Also, it would appear you are a G-HUB user with a G29. Has the wheel been working OK before you experienced the crashes and did you have the issues after updating G-HUB or maybe a GPU driver / Windows update?

Edited by steviejay69

Share this post


Link to post
Share on other sites
59 minutes ago, steviejay69 said:

Can you DDU the drivers please? You might want to try my latest stable version 20.1.3 (however I run a RX580)

The crashes seem fairly firmly rooted with the driver, looking at the dxdiag.

Also, it would appear you are a G-HUB user with a G29. Has the wheel been working OK before you experienced the crashes and did you have the issues after updating G-HUB or maybe a GPU driver / Windows update?

Hello, I have installed the latests stable release and the 20.1.3 version of the drivers using DDU (I was using the experimental and I didn't know) and the game is still crashing.

I use the wheel in many others simracing games and It works perfectly.

I have a R9 480x in other PC and I haven't never an error in F1 2019.

ego_dump.txt

  • Thanks 1

Share this post


Link to post
Share on other sites
2 minutes ago, Goaqi said:

Hello, I have installed the latests stable release and the 20.1.3 version of the drivers using DDU (I was using the experimental and I didn't know) and the game is still crashing.

I use the wheel in many others simracing games and It works perfectly.

I have a R9 480x in other PC and I haven't never an error in F1 2019.

ego_dump.txt

I'm glad you tried the 20.1.3 because the 'stable' 20.2.2 has a lighting bug 🙂 (Monaco tunnel).

I am also glad to hear your G29 works well with G-HUB as there seems to be plenty of others with issues. Logitech aren't maintaining LGS now, so it would seem G-HUB needs to be sorted.

From your crash dump it would appear you are running with V-SYNC off (monitor is correctly detected at 165Hz) For Freesync you should use V-SYNC and enable Freesync in the Radeon driver settings.

I would also be interested if you could try running the Steam FPS counter. Try a Graphics preset that is higher that your current - it looks like you may be running in Low or Medium preset. I recommend changing the setting to HIGH and seeing where your framerate is averaging.

Share this post


Link to post
Share on other sites

Longshot, try to delete the hardware_settings_config.xml file in Documents\My Games\F1 2019\hardwaresettings and see what happens.

 

Share this post


Link to post
Share on other sites

Hello, I have deleted the hardware_settings_config.xml and activated the v-sync, and I have been playing for a while without crashes, but I have this problem now https://steamcommunity.com/app/928600/discussions/0/1639789306548755342/ when I am in the menu, working with the setups of the car, or when I pause the game, the GPU works at 85% at least and I get too high temperatures. If I am running a race, the temperature of the GPU is 60ºC and the GPU works at 45% aproximately.

It seems that the v-sync only works during the race.

Any idea?

I'm so sorry for the inconveniences and thank you so much for any help.

Share this post


Link to post
Share on other sites
3 hours ago, Goaqi said:

Hello, I have deleted the hardware_settings_config.xml and activated the v-sync, and I have been playing for a while without crashes, but I have this problem now https://steamcommunity.com/app/928600/discussions/0/1639789306548755342/ when I am in the menu, working with the setups of the car, or when I pause the game, the GPU works at 85% at least and I get too high temperatures. If I am running a race, the temperature of the GPU is 60ºC and the GPU works at 45% aproximately.

It seems that the v-sync only works during the race.

Any idea?

I'm so sorry for the inconveniences and thank you so much for any help.

This is a known issue (or at least it should be). 

Can you try lowering the in-game refresh to say 120 or 144? 

Can you try altering the video settings between fullscreen (exclusive) and fullscreen (windowed)?

Can you try altering the desktop refresh rate to match that of the game?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×