Jump to content Jump to content

Error 1008:H Master thread


Recommended Posts

  • Moderator
On 4/15/2020 at 6:59 PM, Redducto said:

@YvoTrimbos It didn't work. I tried to go back to 442.74 and upgraded to 445.87 today, but it still didn't work.

445.87 does not fix what Nvidia broke in 445.75 the game worked with 442.74 and hasn't changed.

Drivers are being readied for WDDM 2.7 (which AFAIK needs 2004 or whatever the final build of the next W10 ends up as).

Link to post
Share on other sites

Been screwing with this error for almost a week...although part of that was my own stupid fault by reading the error message telling me to just try again later, so I did.  And again, and again, and again, and again, and again, and again.  If anyone's on Windows 7 getting perpetual "Error 1008:H Couldn't communicate with online services.  Try again in a few moments.", I have the fix.  This worked for me.

 

Following the steps from this post, I downloaded the .msi installer for the Easy Fix from Microsoft (https://support.microsoft.com/en-us/help/3140245/update-to-enable-tls-1-1-and-tls-1-2-as-default-secure-protocols-in-wi#easy).  This added the SecureProtocols entry in the Registry with the referenced value of 0xa8 in the referenced folder/key directories, as the KDB notes it should.

I then navigated to the KEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\ directory to find there were no keys for TLS 1.1 or TLS 1.2.  Right click Protocols -> New -> Key and name the new key TLS 1.1.  Within that key, in the listing on the right, right click -> New -> DWORD Value -> DisabledByDefault.  Its default value is 0, which it should be set to.  Do the same thing again, except name the new key TLS 1.2.  Add the same DWORD Value as the last TLS 1.1 key, DisabledByDefault, which should also be set to 0.

Now close RegEdit, launch F1 2019, and enjoy your connection to online services.

 

To Codemasters: please find a way to identify the status of these registry entries on Windows 7 SP1 users (and/or whichever OS versions apply) and actually inform the user of what the problem is with an avenue to the solution.  If I didn't come across this one single post in all my googlings, I'd still be sitting here with a broken game thinking the problem is server-sided.

To everyone else: please stop suggesting people upgrade to Windows 10.  It's honestly just such a dumb troubleshoot.

 

p.s. thank you FrankThe599Th for helping me fix my game without even knowing you did.  You're a champ, bro.

Link to post
Share on other sites
2 hours ago, steviejay69 said:

445.87 does not fix what Nvidia broke in 445.75 the game worked with 442.74 and hasn't changed.

Drivers are being readied for WDDM 2.7 (which AFAIK needs 2004 or whatever the final build of the next W10 ends up as).

@steviejay69 I did a clean install for driver 442.74 and even so my game did not return to normal. 5 days with the game not working for some reason that only god knows.

 

error.thumb.png.29de5cab83f6761aa3ba3a6a928127e1.png

Link to post
Share on other sites
  • Moderator
9 hours ago, Redducto said:

@steviejay69 I did a clean install for driver 442.74 and even so my game did not return to normal. 5 days with the game not working for some reason that only god knows.

 

error.thumb.png.29de5cab83f6761aa3ba3a6a928127e1.png

Error 1008:H is not caused by the GPU driver. I was merely commenting on another comment about the benefit of newer beta and WHQL releases (that still cause crashes and game instability).

Reading deeper the 445.75 does have more DX11 problems than other APIs, reading feedback on the Nvidia forums and not just with F1.

For clarity, I advise using DX12 API and DCH drivers for the F1 game (Nvidia are still releasing Standard/DCH variants, AIUI the AMD drivers are all DCH). 

Link to post
Share on other sites


I use windows professional 7 64 bits, I'm having this error 1008: h and I can't access F1 2019 in online mode, my version is 1.22, I need an effective solution to this problem. I bought the game through steam but only it does not take the online mode.

Erro 1008;H.jpeg

Link to post
Share on other sites
On 09/02/2020 at 18:39, FrankThe599th said:

Ok, encontrei uma solução para o Windows 7. O problema é que o Windows 7 usa como protocolo seguro padrão TLS 1.0 ou SSL 2.0. Eu acho que algo mudou nos servidores, que eles não aceitam mais esses protocolos seguros.

Há uma correção da Microsoft para definir o protocolo seguro padrão:

https://support.microsoft.com/en-us/help/3140245/update-to-enable-tls-1-1-and-tls-1-2-as-default-secure-protocols-in-wi

Na seção "Correção fácil", há um arquivo para download, que insere duas entradas do Registro. Após reiniciar, meu jogo de F1 usou o novo protocolo seguro e tudo funciona agora.

I love you man, you saved me and thanks to you I can play my F1 2019 online. Thank you very much.

  • Like 1
Link to post
Share on other sites
  • UP100 featured this topic

Good afternoon,

A couple of days ago I bought F1 2019 on PC, but the game is unable to connect to online services due to the 1008H error. I have been reading that many people have had the same problem, but I can't find a real solution to it. I have tried almost everything i could,  such as opening the router ports, reinstalling the game, reseting the router or switching the security protocols by myself, but anything hasn't worked yet. I've also read that some versions of the game have no problem on connecting to the online services, but it seems 1.22 (which is mine) is not working either. I'm currently using Windows 7 and i have read the solution may be switching to Windows 10 too, can someone please confirm that or provide any other possible solution?

Thank you in advanced. 😄 

Link to post
Share on other sites

Hello, guys.

I've just finished downloading the game and tried for the first time. I'm too getting this error.
I'm using Windows 10 and my F1 2019 files are clean as a whistle. Don't know what to do next.

Any thoughts?

Best,
MadM4x

Link to post
Share on other sites
  • Moderator
On 4/29/2020 at 6:56 PM, ManuDR1 said:

Good afternoon,

A couple of days ago I bought F1 2019 on PC, but the game is unable to connect to online services due to the 1008H error. I have been reading that many people have had the same problem, but I can't find a real solution to it. I have tried almost everything i could,  such as opening the router ports, reinstalling the game, reseting the router or switching the security protocols by myself, but anything hasn't worked yet. I've also read that some versions of the game have no problem on connecting to the online services, but it seems 1.22 (which is mine) is not working either. I'm currently using Windows 7 and i have read the solution may be switching to Windows 10 too, can someone please confirm that or provide any other possible solution?

Thank you in advanced. 😄 

To balance out the ridiculous troubleshoot comment earlier, yes I believe upgrading to Windows 10 will solve your issue, whatever it is. You can always go back, system recovery within 7 days or just reinstall with your 7 key after that.

Staying on 7 has to be for a reason, just refusing to upgrade thinking you know all about Windows 10 being the root of all evil then well, there's a word for people like that.

Also same advice applies for Windows 8, same upgrade path, JFDI.

You will NEED W10 for F1 2020, just saying.

https://store.steampowered.com/app/1080110/F1_2020

Edited by steviejay69
Link to post
Share on other sites
On 5/1/2020 at 11:44 AM, steviejay69 said:

To balance out the ridiculous troubleshoot comment earlier, yes I believe upgrading to Windows 10 will solve your issue, whatever it is. You can always go back, system recovery within 7 days or just reinstall with your 7 key after that.

Staying on 7 has to be for a reason, just refusing to upgrade thinking you know all about Windows 10 being the root of all evil then well, there's a word for people like that.

Also same advice applies for Windows 8, same upgrade path, JFDI.

You will NEED W10 for F1 2020, just saying.

https://store.steampowered.com/app/1080110/F1_2020

So I finally updated to Windows 10 and it actually worked, as long as I keep all my router ports open. Thank you very much for the help!! 😄 

  • Agree 1
Link to post
Share on other sites

@BarryBL

PS4/ Version 1.22

I received this error code after the Weekly event Mexico Grand Prix. I finished 1st and after the podium celebration it went to the communicating with online services screen and then it said this session is no longer available. It also said I was not signed into PSN Network.... which I was. After the game did whatever it did and brought me back to the home screen, I went to check if my score had been uploaded to the leaderboards. It was uploaded but the problem here is I was not able to view my total time and I was not able to view my score breakdown. I like to screenshot it and keep it. Is there anyway that the score breakdown is available for you to send to me? Is it stored somewhere in the online services? I have no clue how it works. I just know it has to exist somewhere because I was given a score. The score also appears to be correct which is good, I qualified 143rd and am currently sitting P14. If it can't be retrieved it's not the end of the world, just thought I would inform you this problem exists.

PSN ID 

The_IckleBickle 

Link to post
Share on other sites

Hello, a play F1 2019 in Steam, and now everytime when a will play F1 my game don't connect with server. I tried to scan the game files, but it didn't work, and it's the only game on my PC that I can't play online.

Link to post
Share on other sites
  • Moderator
7 hours ago, UaiTim said:

Hello, a play F1 2019 in Steam, and now everytime when a will play F1 my game don't connect with server. I tried to scan the game files, but it didn't work, and it's the only game on my PC that I can't play online.

I've merged your thread here. Take a look around 🙂

Link to post
Share on other sites
  • Moderator
6 hours ago, PhilipOwusu said:

I bought the f1 2019 game on my Xbox one and I can’t seem to connect to online services. I don’t have Xbox live or play online, is this the reason?

Online services need an internet connection. IDK if XBL has a mode similar to old Silver on X360? 

Link to post
Share on other sites

Hello,

Disclaimer : I'm not an english speaker.

Well, I've been getting this error (called Error 1008:H) for more or less 2 months. I don't know how I could fix it actually, I tried to check my firewall, to restat my connection and those things usually useless. 

So, I can't play in Chrono mod, online with other ppl and I'm feeling like scammed cause I (have?) paid 60€ for this game and I can't play it normally.  

 

If you have a solution, I accept it with pleasure. 🙂 

 

 

 

 

 

Edited by Bullegum
Link to post
Share on other sites
On 4/17/2020 at 12:01 AM, TheMonso said:

Been screwing with this error for almost a week...although part of that was my own stupid fault by reading the error message telling me to just try again later, so I did.  And again, and again, and again, and again, and again, and again.  If anyone's on Windows 7 getting perpetual "Error 1008:H Couldn't communicate with online services.  Try again in a few moments.", I have the fix.  This worked for me.

 

Following the steps from this post, I downloaded the .msi installer for the Easy Fix from Microsoft (https://support.microsoft.com/en-us/help/3140245/update-to-enable-tls-1-1-and-tls-1-2-as-default-secure-protocols-in-wi#easy).  This added the SecureProtocols entry in the Registry with the referenced value of 0xa8 in the referenced folder/key directories, as the KDB notes it should.

I then navigated to the KEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\ directory to find there were no keys for TLS 1.1 or TLS 1.2.  Right click Protocols -> New -> Key and name the new key TLS 1.1.  Within that key, in the listing on the right, right click -> New -> DWORD Value -> DisabledByDefault.  Its default value is 0, which it should be set to.  Do the same thing again, except name the new key TLS 1.2.  Add the same DWORD Value as the last TLS 1.1 key, DisabledByDefault, which should also be set to 0.

Now close RegEdit, launch F1 2019, and enjoy your connection to online services.

 

To Codemasters: please find a way to identify the status of these registry entries on Windows 7 SP1 users (and/or whichever OS versions apply) and actually inform the user of what the problem is with an avenue to the solution.  If I didn't come across this one single post in all my googlings, I'd still be sitting here with a broken game thinking the problem is server-sided.

To everyone else: please stop suggesting people upgrade to Windows 10.  It's honestly just such a dumb troubleshoot.

 

p.s. thank you FrankThe599Th for helping me fix my game without even knowing you did.  You're a champ, bro.

This has worked for me. THANKS A LOT MAN !! 

Link to post
Share on other sites

Hi,

 

ive been playing the game for about 2 weeks and every time I login I get this error code and cannot play online so have only been able to play single player. I have tried restarting my modem, restarting pc, reinstalling but nothing seems to work. Since have also played other games and this is the only game i seem to have this problem with getting online. 

 

im using the steam DirectX 11 version. When I start the game it says 1.22 in the bottom left corner. 

 

my specs:

Windows 7 Ultimate 64bit

GA-78LMT-USB3 

AMD FX 4300

GTX 970



EDIT: Problem solved by adding TLS 1.1 and 1.2 as mentioned above in previous posts. Thanks for the help. 
 

 

 

DxDiag.txt

Edited by RStereo
Problem solved
Link to post
Share on other sites
  • 1512marcel changed the title to Error 1008:H Master thread
  • BarryBL pinned this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...