Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

F1 2019 - [PS4] - MFD Shortcut delay on G29

Recommended Posts

So I have a Logitech G29 racing wheel with the L2 and R2 button assigned to respectively decrease and increase the ERS Mode. The issue is that when I press those buttons quickly, the game doesn't record all the inputs. For example, if I'm in ERS mode 5 (Hotlap) and want to go to Mode 0 (none) as quickly as I can, I'll press the L2 button 5 times as quick as I can. But after pressing the L2 button 5 times in a very small amount of time, I'll be in ERS mode 2 or 3. The game doesn't record all the inputs. If I take my time though, it records all the inputs

This issue doesn't only apply to the L2 and R2 button! The L3/R3, -/+ and the red rotary switch all have the same issues. I went on GT Sport to see if the issue came from my wheel but as expected, I didn't have that problem on this game. The issue is related to the game, not to my wheel.

So my conclusion is that the game is too slow to record all inputs or there is input lag with the G29 wheel.

Platform: PS4

Version: 1.22 (but the "bug" was there in all previous versions, even on previous games)

The problem is always present, it's impossible to avoid it.

Accesories : G29 Racing wheel

Here's an example: https://streamable.com/efwofa. I'm in ERS Mode 5 and press quickly 5 times my L2 button to go to ERS mode 0 (you can hear the 5 fast clicks in the video). But after clicking quickly 5 times, I'm only in ERS mode 2 instead of ERS mode 0.

 

  • Agree 1

Share this post


Link to post
Share on other sites
Posted (edited)

This delay is in the F1 game, i have the Thrustmaster F1 Add on wheel on Ps4 and have the same issue. I know for sure they will not fix this for the F1 2019 game.

We had another topic regarding the MFD delay also. Have a look at the topic. 

Edited by GioProductions
Text

Share this post


Link to post
Share on other sites
Posted (edited)

I can confirm this issue on PC with Fanatec gear (F1 Esports wheel & CSL Elite wheel base). It seems like a universal issue with the game when using MFD shortcuts. Without using shortcuts you can switch the fuel and ERS modes much faster and more importantly consistently. 5 presses = 5 switches. With shortcuts enabled you need a very specific time gap between each press for them to register all.

I must say it's highly annoying and makes managing the Fuel and ERS so much more stressful because you need to double check if you're in the correct mode.

Edited by Wiidesire
  • Agree 1

Share this post


Link to post
Share on other sites

I did some more testing! Instead of using L2/R2 for ERs mode, I tried my square and cross. And guess what, the issue is still there. It confirms that the problem has nothing to do with the buttons you use or the gear you have. It's within the game itself.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×