Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

Problem with the Fanatec Formula V2 steering wheel in F1 2019

Recommended Posts

Posted (edited)

Hello everyone,

maybe someone can help me. I'm playing F1 2019 with the Fanatec Clupsport Steering Wheel Formula V2 on Xbox, so I have a little problem with that.

I can't use these buttons: LT, RT, LSB, RSB

Although I have pedals, the LT and RT button are set on the steering wheel as brake and gas.

The LSB and RSB button on the steering wheel are also set as upshifting and downshifting.

So far I have not found any solutions to the problem on the Internet and here in the forum. 

Edited by Machtkarton3525
Misspellings

Share this post


Link to post
Share on other sites
1 hour ago, Machtkarton3525 said:

Hello everyone,

maybe someone can help me. I'm playing F1 2019 with the Fanatec Clupsport Steering Wheel Formula V2 on Xbox, so I have a little problem with that.

I can't use these buttons: LT, RT, LSB, RSB

Although I have pedals, the LT and RT button are set on the steering wheel as brake and gas.

The LSB and RSB button on the steering wheel are also set as upshifting and downshifting.

So far I have not found any solutions to the problem on the Internet and here in the forum. 

Wheelbase? I see you are on XB1. 

You need to connect to a PC and update stuff. The more info you can give, the more people will be able to help.

  • Agree 1

Share this post


Link to post
Share on other sites

Here are some information I could find.

I use the CSL Elite Wheel Base v1.1

I have already done all the updates.

Version numbers:

Pc Driver : 336 

Driver: Fanatec_64_driver_beta

Wheel Base Firmware: 656

Wheel Base Motor Firmware: 22 

Steering Wheel Firmware: 28 

  • Thanks 1

Share this post


Link to post
Share on other sites

Well, I would use the 334 driver from the v2 page. Beta....only go there if you have unresolved issues with the last issued driver.

Not sure if you can revert firmware suggested by a beta driver. If you can wait, I will have this base by the end of the month.

Stupid question: On console you MUST plug the pedals into the wheelbase. Not directly to USB.

If you check the wheel mode the indicator is GREEN?

Share this post


Link to post
Share on other sites
1 hour ago, steviejay69 said:

Well, I would use the 334 driver from the v2 page. Beta....only go there if you have unresolved issues with the last issued driver.

Not sure if you can revert firmware suggested by a beta driver. If you can wait, I will have this base by the end of the month.

Stupid question: On console you MUST plug the pedals into the wheelbase. Not directly to USB.

If you check the wheel mode the indicator is GREEN?

Yes I'm not sure I can reset the proposed firmware.  

I can wait.

Yes, the pedals are only connected to the wheelbase. 

The indicator is green.

  • Thanks 1

Share this post


Link to post
Share on other sites

The QSG has the mappings for each platform, not sure if this is something you haven't seen or might find useful.

Try deleting any custom profiles in game and then check the default map for correct operation.

As I haven't any experience of a wheelbase or wheel in the Fanatec software, not sure how much I can offer, plus the wheel would be in PC mode for the diagnostic. But you could use the PC to check for correct control operation? (I only have pedals at present).

I would imagine that in-game the Fanatec shows up as one controller - try disconnecting other devices like pads (or the recently added AFAIK keyboard support).

  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, steviejay69 said:

Das QSG verfügt über die Zuordnungen für jede Plattform. Sie sind sich nicht sicher, ob dies etwas ist, das Sie nicht gesehen haben oder das Sie möglicherweise nützlich finden.

Versuchen Sie, benutzerdefinierte Profile im Spiel zu löschen, und überprüfen Sie dann die Standardzuordnung auf korrekten Betrieb.

Da ich keine Erfahrung mit einem Radstand oder Rad in der Fanatec-Software habe, bin ich mir nicht sicher, wie viel ich anbieten kann, und das Rad würde sich für die Diagnose im PC-Modus befinden. Aber könnten Sie den PC verwenden, um den korrekten Steuerungsbetrieb zu überprüfen? (Ich habe derzeit nur Pedale).

Ich würde mir vorstellen, dass der Fanatec im Spiel als ein Controller angezeigt wird - versuchen Sie, andere Geräte wie Pads (oder die kürzlich hinzugefügte AFAIK-Tastaturunterstützung) zu trennen.

I just removed the pedals from the steering wheel and removed the controller from the Xbox (I use the controller for the headset). Nevertheless, the LT, RT buttons are displayed as gas and brake. And the RSB and LSB buttons for upshifting and downshifting. 

In the following days I will ask the Fanatec Support.

 But still thank you for your help @steviejay69

save_0.png

Share this post


Link to post
Share on other sites

"Differential erhöht" wählen und auf "X Lösen drücken" ... damit erscheint "Nicht zugewiesen" wenn alles gut geht.

Share this post


Link to post
Share on other sites
3 minutes ago, PFive said:

"Differential erhöht" wählen und auf "X Lösen drücken" ... damit erscheint "Nicht zugewiesen" wenn alles gut geht.

Das ist nicht das Problem☺. Die Tasten RT, LT, LSB und RSB werden auf dem Lenkrad Fanatec Formula V2 als die Tasten angezeigt die im Screenshot zu sehen sind. Da ich ja aber mit dem Lenkrad schon Hoch- und Herunterschalten kann, und mit dem Pedale Gas geben und bremsen kann sind die Tasten so zu sagen doppelt belegt. 

Share this post


Link to post
Share on other sites
Posted (edited)

And when you do not use the controller as headset? Could you make a screenshot from the "Steuerungsschema"?

I can imagine that there is a conflict between the buttons and that the buttons on the Formula v2 wheel take priority over the buttons on the controller.

Edited by PFive
Extra information

Share this post


Link to post
Share on other sites
12 minutes ago, Machtkarton3525 said:

Das ist nicht das Problem☺. Die Tasten RT, LT, LSB und RSB werden auf dem Lenkrad Fanatec Formula V2 als die Tasten angezeigt die im Screenshot zu sehen sind. Da ich ja aber mit dem Lenkrad schon Hoch- und Herunterschalten kann, und mit dem Pedale Gas geben und bremsen kann sind die Tasten so zu sagen doppelt belegt. 

Wenn die doppelt belegt sind ist Lösen in das MFA Shortcuts die einzige lösung? Oder nicht?

Share this post


Link to post
Share on other sites
3 minutes ago, PFive said:

Wenn die doppelt belegt sind ist Lösen in das MFA Shortcuts die einzige lösung? Oder nicht?

Ja, sollte ja eigentlich bloß ein Beispiel sein, was angezeigt wird wenn ich diese Tasten drücke. Denn normalerweise sollte bei dem Lenkrad, wenn ich jetzt zum Beispiel die Taste LSB auf “Differntzial erhöhen“ legen will, nicht das Schaltsymbol auftauchen, sondern es sollte LSB angezeigt werden. 

Share this post


Link to post
Share on other sites
21 minutes ago, PFive said:

And when you do not use the controller as headset? Could you make a screenshot from the "Steuerungsschema"?

I can imagine that there is a conflict between the buttons and that the buttons on the Formula v2 wheel take priority over the buttons on the controller.

I've already removed the controller and headset and just connected the steering wheel. Nevertheless, I can't prove the Buttons.

I will contact Fanatec Support in the next few days.

save_3.png

save_2.png

save_1.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×