Jump to content
F1 2021 | BETA | Details and how to Apply Here Read more... ×
FORUM MAINTENANCE | 11/05/2021 AM Read more... ×

Grid 2019 - textures get blurred after a while

Recommended Posts

Hello,

I've recently purchased grid 2019 on steam. I've played a couple of hours with no problems at all, but now after a couple of races, my textures get blurred really hard. I'm playing on GTX 1050 Ti, on medium preset. Game runs about 48-60fps, no overheating, no crashes. Tried different graphics settings already, always happens after a couple races. Already tried verifying game cache via steam and updating drivers.

 

Thank you for replies :)

lq.png

Share this post


Link to post
Share on other sites

I'm having the same problem, very frustrating, I tried close the game and open it again, sometimes works sometimes doesn't, guess I'll just sit here and wait til someone send help with you .-.

Share this post


Link to post
Share on other sites

i'm having the same problem playing on GTX 1050 Ti. when this occurs the loading times takes to long and forces me to restart, very annoying. also i've noticed that sometimes the livery gets blurred just after the car passing the start line on classification lap. several months later and no one gives a damn.

Share this post


Link to post
Share on other sites

little late in the game but i found that the problem seems to be related to vsync. when livery gets blurred in carrer mode i'd went back to main menu/video settings and turned vsync on, then i started a custom race and voilà everyting was normal. but resuming the race of carrer mode the livery became blurred again. well, i've accepted that this game is poorly optimized (for pc at least) and i restart it everytime this happens. geforce experience app can't even optimize it (i saw the log file, there is an error in the script for this game, it is ridicoulous).

Share this post


Link to post
Share on other sites

finally I may have found the solution guys! I have increased memory size for texture streaming and everything is fine until now after hours playing!
so basically what I did was edit hardware_settings_config.xml file located in %USERPROFILE%\Documents\My Games\GRID (2019)\hardwaresettings (Windows)

before:

<texture_streaming sizeInMiB="512" clampMipTo="12" />

after:

<texture_streaming sizeInMiB="1024" clampMipTo="12" />

hope it helps! 😊

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×