Jump to content Jump to content

Problem with G920 accelerator


magricajj

Recommended Posts

Hello dear colleagues !! I play F1 2019 with Logitech G920 steering wheel. But yesterday I went to play and my accelerator is accelerating alone. But the problem only happens in F1. I did a test in other games but in them, the accelerator pedal is normal. I have already done some procedures like: * reinstalling the steering wheel driver; * recreate user files within the documents folder; * check the integrity of files within steam; * reinstall the game. I hope someone helps me to solve this problem.

Link to comment
Share on other sites

Try this:

Open registry editor (regedit) and change This

 

Go to HKEY_CURRENT_USER\System\CurrentControlSet\Control\MediaProperties\PrivateProperties\Joystick\OEM\VID_046D&PID_C24F
Test this values, it works for me:
OEMName: "Logitech G29 Driving Force Racing Wheel USB" instead of "G29 Driving Force Racing Wheel"
OEMData: 43 00 08 10 19 00 00 00 instead of 00 00 00 10 00 00 00 00"

Export this after, and than if problem after PC restart comeback, simply run shortcut to exported reg file and u are good to go.

Link to comment
Share on other sites

1 minute ago, Erumasta said:

Try this:

Open registry editor (regedit) and change This

 

Go to HKEY_CURRENT_USER\System\CurrentControlSet\Control\MediaProperties\PrivateProperties\Joystick\OEM\VID_046D&PID_C24F
Test this values, it works for me:
OEMName: "Logitech G29 Driving Force Racing Wheel USB" instead of "G29 Driving Force Racing Wheel"
OEMData: 43 00 08 10 19 00 00 00 instead of 00 00 00 10 00 00 00 00"

Export this after, and than if problem after PC restart comeback, simply run shortcut to exported reg file and u are good to go.

@Erumasta Are you willing to test and confirm this?

Delete your in-game and LGS controller profiles (or back them up via LGS for reinstallation later if you so wish).

Uninstall LGS with Geek Uninstaller. Reboot.

Install GHub. Reboot. Set controller profile. Play.

Your old dxdiag showed you using LGS, but it is no longer updated by Logitech. 

If you have no success you can revert to LGS by uninstalling GHub with the Geek Uninstaller.

The constant complaints about Logitech controllers is getting very repetitive and if nothing is done, the situation persists. Quite honestly I'd like the issue to be taken up by Logitech as well, but I know their tech support is pretty useless.

Link to comment
Share on other sites

I use Ghub and still every time I restart PC I have to run this fix or in F1 my acc pedal will be maxed out.

I've tried before with LGS but had same issue, so once I fixed it by uninstalling GHub, unplug wheel, pc restart, install ghub, plug whell and everthing was ok till next pc boot, than with ghub installed i have to run reg fix.

IF only I could change this reg value to read only.

Link to comment
Share on other sites

2 hours ago, Erumasta said:

I use Ghub and still every time I restart PC I have to run this fix or in F1 my acc pedal will be maxed out.

I've tried before with LGS but had same issue, so once I fixed it by uninstalling GHub, unplug wheel, pc restart, install ghub, plug whell and everthing was ok till next pc boot, than with ghub installed i have to run reg fix.

IF only I could change this reg value to read only.

Do you have PCARS 2 installed?

Link to comment
Share on other sites

20 hours ago, Erumasta said:

Try this:

Open registry editor (regedit) and change This

 

Go to HKEY_CURRENT_USER\System\CurrentControlSet\Control\MediaProperties\PrivateProperties\Joystick\OEM\VID_046D&PID_C24F
Test this values, it works for me:
OEMName: "Logitech G29 Driving Force Racing Wheel USB" instead of "G29 Driving Force Racing Wheel"
OEMData: 43 00 08 10 19 00 00 00 instead of 00 00 00 10 00 00 00 00"

Export this after, and than if problem after PC restart comeback, simply run shortcut to exported reg file and u are good to go.

did not work    😞

17 hours ago, steviejay69 said:

Você possui o PCARS 2 instalado?

Yes!! But I play so bad. kkkkkkk

Link to comment
Share on other sites

20 hours ago, steviejay69 said:

@Erumasta Are you willing to test and confirm this?

Delete your in-game and LGS controller profiles (or back them up via LGS for reinstallation later if you so wish).

Uninstall LGS with Geek Uninstaller. Reboot.

Install GHub. Reboot. Set controller profile. Play.

Your old dxdiag showed you using LGS, but it is no longer updated by Logitech. 

If you have no success you can revert to LGS by uninstalling GHub with the Geek Uninstaller.

The constant complaints about Logitech controllers is getting very repetitive and if nothing is done, the situation persists. Quite honestly I'd like the issue to be taken up by Logitech as well, but I know their tech support is pretty useless.

it also didn't work

Link to comment
Share on other sites

3 hours ago, steviejay69 said:

@magricajj do you have an Administrator user account on the PC? How does your G920 connect to the PC? Can you ensure you use no hubs and USB 2.0? Really not comprehending these Logitech issues....

Yes, all these steps and also the most advanced ones I have ever done.
my user is an administrator, I'm not using a USB Hub, everything is connected correctly. even in other games the G920 is operating normally.

Link to comment
Share on other sites

after many attempts I got it as easy as possible. I edited the button commands within the game. and now I'm happy again. thank you very much to everyone who sent help. I hope this topic helps other people. add me to steam, michel_bo.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...