Jump to content Jump to content

[BUG] 24Hz upon every game launch, unless manually re-set to 59Hz every time.


Recommended Posts

System Spec
i7 950
Radeon 7950 crossfire
AMD 15.6 June 22 drivers
win 8.1 64bit

Steps to reproduce
Happens upon game launch.
Has been a problem since the day Dirt Rally was released.

Your recent history of races

Which stage were you within the championship\custom event?

How long was your current session?
Happens upon game launch.

Which graphics preset were you using?
Happens with any preset.

Sony EX720 TV for display. This is a true 120Hz panel (no interpolation) set to 60Hz from within windows (also 59, 50, 24 etc, for debugging purposes - makes no difference though).
HDMI cable.

Using Riva Tuner statistics server to display FPS.
Game starts, as soon as the very first splash screen shows, FPS default to 24, despite having chosen 59Hz from the in-game video options.

I need to set the value to something different than 59Hz within the in-game video options, and re-set it to 59Hz for the setting to stick ...temporarily.
Upon next game launch, same thing all over again.

Vsync settings dont matter, whether forced from the driver, or within the game.
Hertz settings from windows monitor settings dont matter either.

Disabling crossfire entirely from CCC does not matter either.

With crossfire enabled, alt-tabbing out to windowed mode the counter shows 59 fps. When alt-tabbing again to go fullscreen, it shows 24fps again.

Good thing is, after the switch to something other than 59Hz, and back to 59, everything runs great.

Link to post
Share on other sites

Other thread titles on the steam forums about the same issue:

"Bug Report: Wrong refresh rate on TV-Screen"
"For the setting of the refresh rate"

Could a staff member please give at least a sign of aknowledgment of this game breaking issue?

Link to post
Share on other sites
Same here (captured with Dxtory):

This is a bug that was present in previous Codemasters games, at least since Grid 2:

Grid Autosport

Grid 2:

I have a 290x with a DVI Acer 120Hz as Secondary display and an HDMI as Primary that is connected to an Onkyo receiver and then to a projector.
It doesn't matter if I disconnect the secondary display or not. Every time the game launches, the Primary display refresh rate is set to 24Hz, even if the game is still set to 60, 59, 50 or whatever in the Config menu.

Very disappointed to see the same problem being carried on across 3 different games from the same studio.
BTW, this problem does NOT happen in any other games I play.

Is there anybody else with similar configuration suffering this problem too?
Link to post
Share on other sites
Thanks for your detailed post.

How this issue still persists after 3 released titles ( i didnt know that, thanks for reporting ) is beyond me.

Its got nothing to do with your setup being exotic, with the display/ projector/ receiver combo and what not.
In my case, there is a single GPU, then there is an HDMI or DVI->HDMI cable (tried both types just in case).
I tried all AMD drivers from 14.12 Omega up to the most recent 15.6 beta. I did a thorough uninstall in-between installations with DDU (Display Driver Uninstaller). I also tried messing with windows monitor settings, setting the TV to anything available, which is 23, 24, 25, 29, 30, 50, 59, 60 Hz.

It does NOT matter. The game wants to start with 24Hz, even though i set it to any option available from in game. The next launch will always be 24Hz.

No other game i have played on the PC had such an issue.

Theres already quite a few people over on steam forums with the same problem.
Link to post
Share on other sites

Hey, i stumbled upon something that could be considered as a workaround.

I chose a super-sampling resolution from the in-game video options, like 2560x1440 (my TV is 1080p). A lower res, (but still higher than the native res of your display) works too.
Then i restarted the game because the resolution change messed up the aspect ratio of the menus and only a restart could fix that.
Next game launch, it was set to 60Hz, 2560x1440.
By running a non-native resolution, it actually remembered the 60 Hz setting.

I got a Radeon 7950 which does not support supersampling resolutions by default like the newer Radeons do, so i had to use a tool named VSRenable.
To whoever might be interested, this tool makes it possible to choose Virtual Super Resolutions from within games/desktop, which as the name implies are resolutions higher than what your display supports.

Instructions and download links for the tool on the first post:

This tool is supposed to work on older AMD HD 5XXX , 6XXX and 7XXX (Tahiti), RX 2XX (Hawaii) Series GPUs.
The obvious drawback is the extra GPU horsepower needed to support those supersampling resolutions, but at least now it keeps the Hz settings everytime the game is launched. Also you could lower / turn Anti-Aliasing OFF now, since supersampling takes care of jagged edges. Extra AA on top of running a supersampling resolution could be overkill/an unnecessary burden for your GPU.

Codemasters please look into a true fix for this issue.

Link to post
Share on other sites
  • 1 month later...
And 0.6 version still have the same bug.

Setting a VSR resolution is not a very good workaround. At 1080p my 290x can maintain constant 60fps at Ultra, but at 1440p that's totally impossible.

Come on Codies...     how hard can it be to fix this stupid bug?
Link to post
Share on other sites
  • 2 weeks later...
Turn your V-Sync off

As i mentioned in the OP, "Vsync settings dont matter, whether forced from the driver, or within the game."
Thanks for replying though.
Also, there is too much tearing with Vsync OFF anyway, which would be another big compromise.

There is no other way around it, there needs to be an official proper fix. Whats annoying though, is that this issue 1) either appears to still not be aknowledged, or 2) purposely ignored, since it carries over from past titles.

Could you as a mod get this info to someone willing to hear?
Either way its annoying enough to put people off from buying these titles unless tested first. Oh well.

Link to post
Share on other sites
  • 1 month later...
No idea if it happens with Nvidia too, but it is easily reproductable in any AMD. Happens using hdmi with 7970, 290x and 390x at least.

Thanks for answering and acknowledging the problem. Hope you are able to fix it soon and forever for upcoming titles too.
Link to post
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...