Jump to content
Bug Reporting - PLEASE FOLLOW RULES AND COMPLETE REPORTS Read more... ×

G29 does not work at all on F1 2020

Recommended Posts

On 11/6/2020 at 4:28 PM, steviejay69 said:

Did you try deleting the hardware_settings_config.xml and verifying the files on Steam?

This now. Delete any in-game custom controller schema. Then do the above with the game closed. Then try to play after the files are verified. Go into the controller options in-game as see the wheel is detected. Do not modify the controller schema until you have verified it's detected.

  • Like 1

Share this post


Link to post
Share on other sites

the only thing i noticed is that the ps3/ps4 switch seems to be loose and unusualy easy to switch
and its not working in f1 2019 as well

 

Edited by mjg1301

Share this post


Link to post
Share on other sites

@steviejay69  Actually it makes no difference - in either the PS3 or PS4 position G HUB will still detect the wheel and switch it to PC mode. 

@mjg1301I could do with a full list of games that you've tried the wheel with please.  Also, is the wheel present and working when you test it in the Game Controllers app in Windows (joy.cpl from the run window)?

  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, LogiUK said:

@steviejay69  Actually it makes no difference - in either the PS3 or PS4 position G HUB will still detect the wheel and switch it to PC mode. 

@mjg1301I could do with a full list of games that you've tried the wheel with please.  Also, is the wheel present and working when you test it in the Game Controllers app in Windows (joy.cpl from the run window)?

@LogiUK is that different to with LGS? Asking for a friend 🙂

Edited by steviejay69

Share this post


Link to post
Share on other sites
Quote

I could do with a full list of games that you've tried the wheel with please.  Also, is the wheel present and working when you test it in the Game Controllers app in Windows (joy.cpl from the run window)?

i played F1 2017, F1 2018, F1 2019 (all on ps4)
then i got myself a pc and played f1 2019 and f1 2020 
and yes everything seems fine in joy.cpl

Edited by mjg1301

Share this post


Link to post
Share on other sites
Quote

 

ok, its now detected in the menu, force feedback not working properly (pressure goes away as i go into a gamemode and try to drive)
the throttle bar is stuck at 50%, if i try to map the throttle paddle on it, it only shows '2-'
the clutch paddle controlls the throttle, quite weird
its actually the same on f1 2019

by the way: i rightclicked on f1 2020 in steam library, >properties>steam input per-game setting
i changed the default option to 'forced off' and then the wheel was at least detected in the game menu

 

 

Edited by mjg1301

Share this post


Link to post
Share on other sites

what did you exactly do to get it fixed @jacob2000?

thanks for your answer 😛

 

 

Edited by mjg1301
update: i got the paddleproblem fixed (even though the '2-' remains at the mapping menu) but the force feedback is very weird going in the straight line and there is basically zero spring, tested all the possible settings in Logitech GHub

Share this post


Link to post
Share on other sites

 

@mjg1301 Sorry for the slow response - the forum isn't notifying me of updates and the last week has been crazy busy.

The wheel losing forces as you load the game is completely correct behaviour - this is because the game has loaded the FFB engine and now has control and they're not implementing any kind of centering spring whilst in menus.  G HUB makes no difference to force feedback (except for Trueforce games as you can adjust the sliders within G HUB). What are your full force feedback settings in-game?

Share this post


Link to post
Share on other sites

Hi, i bought a Logitech G29 in PS4 for especially playing F1 2020. When i bought it all worked fine, i did the my carrer practices for the first grand prix (i dont remember the name) and when i had to do the Classification all worked as ****, when the wheel set to a 90 degree position the game started to detect the wheel as it was in 180 degrees position, so i could'nt play nothing. I tested to recalibrate the wheel, restart mi PS4 and resetting the game and nothing worked, I just assume it is a bug. Please answer as soon as possible for me enjoying the $60 dollars I spent only for playing with the wheel. 

Share this post


Link to post
Share on other sites
7 hours ago, JoacoDuenas5 said:

Hi, i bought a Logitech G29 in PS4 for especially playing F1 2020. When i bought it all worked fine, i did the my carrer practices for the first grand prix (i dont remember the name) and when i had to do the Classification all worked as ****, when the wheel set to a 90 degree position the game started to detect the wheel as it was in 180 degrees position, so i could'nt play nothing. I tested to recalibrate the wheel, restart mi PS4 and resetting the game and nothing worked, I just assume it is a bug. Please answer as soon as possible for me enjoying the $60 dollars I spent only for playing with the wheel. 

You need to test the wheel operation elsewhere, another game title or on a PC. 

Share this post


Link to post
Share on other sites
On 1/20/2021 at 5:38 AM, steviejay69 said:

You need to test the wheel operation elsewhere, another game title or on a PC. 

Hi, I alredy tested it in Dirt Rally 2.0 and in The crew 2 and all work fine..

  • Thanks 1

Share this post


Link to post
Share on other sites

Try:

It sounds like you have messed around with the steam controller settings, so my advice would be to disable that in the game properties. You do this by right clicking on the game in question and selecting "properties", and then under the "controller" tab, changing "Steam Input Override for F1 2020" to "Disable Steam input".

In this case, you would right click on F1 2020. This is most likely an issue with steam. Please send me over your copy of the screen below.

image.png

Share this post


Link to post
Share on other sites
7 hours ago, BarryBL said:

Try:

It sounds like you have messed around with the steam controller settings, so my advice would be to disable that in the game properties. You do this by right clicking on the game in question and selecting "properties", and then under the "controller" tab, changing "Steam Input Override for F1 2020" to "Disable Steam input".

In this case, you would right click on F1 2020. This is most likely an issue with steam. Please send me over your copy of the screen below.

image.png

Well, I actually play in PS4.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×