Jump to content
Bug Reporting - PLEASE FOLLOW RULES AND COMPLETE REPORTS Read more... ×

Recommended Posts

Hello everybody!

Yesterday I started F1 2020 and played some hrs with my Logitech G920. Everything worked fine for me, but after rebooting my PC the Throttle is stuck at 100%. I have tried to reinstall the Logitech G Hub, it helped till the next reboot. Then the same Problem is back. In other Games the pedals work fine (also on the Xbox), I only have problems in F1 2020 and 2019 on PC. I don't want to reinstall the G Hub everytime I play F1... 

I am using Win10 with the latest Update. Logitech G Hub is also on the latest update.

 

Share this post


Link to post
Share on other sites

1.       A detailed description of the issue. Please include any error codes and add your platform here. 

No Error Codes, using PC (Steam) - description is mentioned above. But here again:
Ingame the calibration says "100%", without pressing the clutch. I can fix it by reinstalling the Logitech G Hub and removing old files. After several reboots (due to the new installation) it works till the next reboot, then the bug appears again.


2.       What version of the game you are using (Shown on the start screen in the bottom left corner of the screen) 

Version 1.03


3.       Game-mode? 

Any mode (it doesn't care about MP or SP)


4.       What are your replication numbers? Minimum test attempts are 4. Please also add EXACT replication steps for us to try too. 

Tested it 8 times. Remove Logitech G Hub, plug off the wheel, restart PC, reinstall Logitech G Hub, plug in the wheel, start game, check calibration (0% input), close game, restart PC, start game, check calibration (100% input)


5.       What troubleshooting have you attempted? Please always try to attempt to fix the issue. Do you have the latest drivers? Have you check your connectivity settings?

I have tried plug in and off the wheel, restarting PC, restarting Logitech G Hub, reinstalling Logitech G Hub, checked on Xbox if the clutch is broken or dirty (no it is not!), tried other USB-ports


6.       Please provide a video recording of your game crashing so we can see where the issue occurs?

Probably no need to record it, you will only see 100% and many restarts... At the moment it works, but within the next reboot it will be buggy again.


7.       [ For PC ] – Please add a DXDiag to your post.   

DxDiag.txt

Share this post


Link to post
Share on other sites

Try this:

Run regedit

Go to HKEY_CURRENT_USER\System\CurrentControlSet\Control\MediaProperties\PrivateProperties\Joystick\OEM\VID_046D&PID_C24F

Test this values, it works for me:

OEMName: "Logitech G29 Driving Force Racing Wheel USB" instead of "G29 Driving Force Racing Wheel"

OEMData: 43 00 08 10 19 00 00 00 instead of 00 00 00 10 00 00 00 00"

Share this post


Link to post
Share on other sites
Posted (edited)
  1. I am with the same issue, run regedit did not fix it. A can not play because the Throttle is stuck at 100%. I am using Logitech G29 wheel. It just happen in F1 2020, in F1 2018 the wheel works fine.
Edited by Sodney

Share this post


Link to post
Share on other sites

Is there an update on this bug and how to fix it? The game was working absolutely fine until approx 4 days ago and now nothing I do fixes the issue. I have uninstalled GHub and all remaining files, and also uninstalled F1 20 and the issue persists. I have tested the peddles elsewhere and the issue is only on the F1 20 game. We seem to have the same issue with F1 games every year with the Logitech G920 

A fix would be aprrieceated as the game is currently unplayable 

Thanks 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×