Jump to content Jump to content

AMD GPUs No video signal


Recommended Posts

Jumping in late here, but any luck on getting the game to run?  I have an XFX Fatboy RX590 and Ryzen R7 2700x and have had the same issue. Usually a hard crash, black screen and fans whirring. Literally no other game has done this for me, not even other Codemasters titles (Dirt Rally 2.0, GRID). Ended up trying to get a refund even though it's past the refund period. Just makes me sad because the game is awesome when it actually works.

Link to comment
Share on other sites

  • 1 month later...

Getting the same issues over the last few months aswell.

It did disappear for a while but after the last update its happening even in the menus. (infact thats where it happens most frequently when im navigating around the main menu (between shop, achievements etc.) I tried underclocking the GPU incase it was temperatures but it still occurs. Its worrysome as my season pass purchase is ticking and im scared to enter the game because  i have a fear this issue might be doing damage to my system.

I'd like to help get to the bottom of this. Where would i find f12020 log files?

Other notes

Ryzen 5 3600, Sapphire Pulse rx 580 4gb, msi b450 mortar max, 16gb 3200 cas16 ram, Windows 10 fully updated, Thrustmaster t300, Asus strix kb, Func Msrv3 mouse.

  • its happened on both Direct x 11 and 12
  • its happened with asynchronous compute on and off

Has anyone tried pressing "Win+Ctrl+Shift+B" on your keyboard? i've heard this combination can restart the graphics driver. (thats if its the graphics driver thats causing this issue.)

Link to comment
Share on other sites

  • 4 months later...

No working solution yet? This happens to me in F1 2020(steam) and F1 2019(game pass). Tested reinstalling, drivers update and rollback, and changing graphical settings. Also updated windows.

Full screen makes both my monitors black and gpu fan to 100%, im forced to switch of the PC by brute froce. If i play windowed mode it cretes a crash dum at least

I have ryzen 2600 on x470 AOURUS ULTRA GAMING mbo and rx580 8GB, 16gb ram.

egodumper.txt

 

Update: happened again in myteam when simulating free practices, also happens when i try to load older myteam save, and randomly in flashbacks, replay mode, and 3 times when changing graphical settings before even aplying, just moving a slider, and with different graphical settings, like from very high to high.

Link to comment
Share on other sites

Didnt see that, I have Enhanced Sync off, but maybe i should disable freesync too? I will give it a test.

Thanks

 

Update: Played for 2 hours without a problem, i disabled freesync and caped frames ingame to 90 with f1 settings, played at high 1080p.

Super helpful, thanks again.

Link to comment
Share on other sites

  • 3 weeks later...

I guess there is still no fix for this?
Bought the game just yesterday (Steam version) and got the same problem. It occurs most of the time already in the menus basically the same as Suju described it.
Tried different settings mentioned in this thread like
- FreeSync on/off
- EnhancedSync on/off
- Async Compute on/off
- dx11 and dx12
- capping Framerate manually
- different graphics presets
but doesn´t make any difference still crashing.

Ther are no problems with other games like F1 2019, Dirt Rally 2.0, ACC even Cyberpunk.

I´m running a Ryzen5 3600, RX590 (Adrenalin 21.4.1), 32gb ram, 1080p/144Hz display
No overclocking everything stock.

So any other suggestions on how to fix this?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...