Jump to content
Bug Reporting - PLEASE FOLLOW RULES AND COMPLETE REPORTS Read more... ×
F1 2020 |NEW PATCH AND DRIVER RATINGS | READ ME!!! Read more... ×

Stutter Fest on F1 2020 (PC)

Recommended Posts

1.       A detailed description of the issue. Please include any error codes here. 

F1 2020 is stuttering so bad on my system and I have tried everything to my knowledge to fix this issue. The stuuters seem to only happen when out on track and not when in menus or pits etc. This issue also affected F1 2019 but thought a new game might fix any issues with the game.

I'm honestly very disappointed and its taking all the fun out of my racing. I do not have this issue with any other game on this PC and that includes iRacing, Star Wars Battlefront 2, Jedi Fallen Order etc

 

My PC is:

RTX 2080, Intel i7 8700k, Asus ROG STRIX Z370 F, water cooled, 4 x 8GB 3200MHz CORSAIR VEGENCE RAM, 250GB Samsung M.2, 120GB SSD 2.5", 4TB hard drive, 2 x 1TB hard drives. 750W power supply


2.       What version of the game you are using (Shown on the start screen in the bottom left corner of the screen) 

1.03

3.       Game-mode? 

My team, Multiplayer all game modes


4.       What are your replication numbers? Minimum test attempts are 4. Please also add EXACT replication steps for us to try too. 

It is happening of every race circuit I race on and is very random when the stuttering is happening.

5.       What troubleshooting have you attempted? Please always try to attempt to fix the issue 

I have clocked the CPU/GPU, Unclocked CPU/GPU, tried on different hard dives HHD/SSD/M.2 Bought more RAM 16GB to 32GB. Refresh rate in game, refresh rate in control panel, frame cap at 60 fps, 72fps, 144fps, Did a fresh install of operating system windows 10, set priority high on the CPU process of F1 2020 EXE, tried numerous graphics settings, tried guides on internet, turned of Game mode, turned off performance mode. Even bought a new wheel from Logitech G920 to Fanatec CSL elite F1 set, 

6.       What peripherals are you are using (gamepad, wheel make & model etc) 

Fanatec CSL elite F1 set with CSL load cell.

7.       Any screenshots or video of the issue? If the video is long, please include a timestamp for when the issue appears.  

 

DxDiag file attached

DxDiag.txt

Share this post


Link to post
Share on other sites

I too have this exact same problem with different specs, just here to bump your post as my friend has the same issue aswell.

GTX 1050 ti, 8gb RAM, AMD A8 6600k APU, game installed on HDD, windows 10 64-bit.. Frame rates completely normal except for a persistent stuttering that makes the game very unenjoyable, occurs in all game modes. Playing on a G920. Game version 1.03, same as OP.

Share this post


Link to post
Share on other sites
2 hours ago, Hasvesterooo said:

There are some steps mentioned on this article. Not sure how well they work though.

Thank you for linking that, it did help with some of the stuttering however it didn’t get rid of it for me completely, hopefully a fix is coming from codemasters.

Share this post


Link to post
Share on other sites
3 hours ago, cameroncrawshaw said:

I too have this exact same problem with different specs, just here to bump your post as my friend has the same issue aswell.

GTX 1050 ti, 8gb RAM, AMD A8 6600k APU, game installed on HDD, windows 10 64-bit.. Frame rates completely normal except for a persistent stuttering that makes the game very unenjoyable, occurs in all game modes. Playing on a G920. Game version 1.03, same as OP.

In your case it's probably just the fact that you're on an old low end system. That's a 2013 CPU with integrated graphics. It's not a very fast one with todays standards. The 1050 ti isn't a very fast gfx card either today. And then, 8GB ram is the bare minimum for gaming on windows 10. All put together it's no wonder that you have stuttering. Sad but true.

Share this post


Link to post
Share on other sites

Have you tried enabling V-Sync? That gives smoother frame rate.

Also, if you've got SSRT Shadows turned on, disable it. It reduces performance substantially. 

On a somewhat related note, there's a setting called CS Geometry Culling that's supposed to improve performance if turned on. It's not available in the in-game menu, only in the config file. I read that it caused crashes for some people in F1 2019, though, so be warned. I'm going to test this setting myself tomorrow.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

I'm going to be honest I have had enough and disappointed of trying to find a solution to this issue that seems to be a issue in the last few series of F1 games. I expect glitches in games and that they get patched but not for this long with not much mention from codemasters on the issue in the past. 

 

I do know Steam can also be a cause of stuttering in games and wish there was a way of not having the game on steam and buy from MS store or Epic or Origin

Edited by CardConvict

Share this post


Link to post
Share on other sites

how do you change from DX12 to DX11 mode when launching the game? it only asked this on the first load after install, how do you change it now?

Share this post


Link to post
Share on other sites
2 minutes ago, hardbaked said:

how do you change from DX12 to DX11 mode when launching the game? it only asked this on the first load after install, how do you change it now?

If you start from the Steam Library you get the choice. If you start from the desktop shortcut it throws you into DX12.

 

  • Like 1

Share this post


Link to post
Share on other sites
1 minute ago, steviejay69 said:

If you start from the Steam Library you get the choice. If you start from the desktop shortcut it throws you into DX12.

 

Thanks for the advise, will try that, 🙂

  • Thanks 1

Share this post


Link to post
Share on other sites

@BarryBL Will this be looked into as I would love to know more about what the developers actually know about this considering its a known issue for the past few years

Share this post


Link to post
Share on other sites
10 hours ago, HDR10 said:

Have you tried enabling V-Sync? That gives smoother frame rate.

Also, if you've got SSRT Shadows turned on, disable it. It reduces performance substantially. 

On a somewhat related note, there's a setting called CS Geometry Culling that's supposed to improve performance if turned on. It's not available in the in-game menu, only in the config file. I read that it caused crashes for some people in F1 2019, though, so be warned. I'm going to test this setting myself tomorrow.

Tried DLSS and got the black screen as others have reported so going to try the CS Culling option and see how I get on

Share this post


Link to post
Share on other sites
37 minutes ago, CardConvict said:

Tried DLSS and got the black screen as others have reported so going to try the CS Culling option and see how I get on

I think I pointed out in the other thread that DLSS requires developer support. It won't be added to the F1 game as the development time won't benefit anything other than a small subset of users. Same reason that VR is not in the title year on year.

Share this post


Link to post
Share on other sites
2 minutes ago, steviejay69 said:

I think I pointed out in the other thread that DLSS requires developer support. It won't be added to the F1 game as the development time won't benefit anything other than a small subset of users. Same reason that VR is not in the title year on year.

I'm honestly trying anything I can to stop stuttering and yes you did point out and I understood what you said, still doesn't change the fact I have issues in F1 code master games were developers don't seem to be wanting to help or point me and others in a direction.

Share this post


Link to post
Share on other sites
1 minute ago, CardConvict said:

I'm honestly trying anything I can to stop stuttering and yes you did point out and I understood what you said, still doesn't change the fact I have issues in F1 code master games were developers don't seem to be wanting to help or point me and others in a direction.

They can't deal with all the issues at once. It's frustrating but this issue is quite important. Game crashes will be prioritised over stuttering issues. I'm afraid we have to try to figure out the issues then when we have them replicated clearly they can see the issues and fix them quicker. It's not going to happen for a couple of patches at least.

The game does not support all the new toys Nvidia are pushing. So the choice is clear, revert to an older driver or an older version of Windows.

Personally (and I'm quite an early adopter normally) the noises I'm getting from 2004 are that it's an update best avoided like 1809 and others before it, but I understand that not everyone will easily be able to revert to 1909. To revert the graphics driver, you should DDU. This is best done in Safe Mode with your internet disconnected.

The new driver should be loaded and you should delete the hardware_settings_config.xml file to recreate an out of box detection.

Currently I'm working with the older more stable branch (442.74 was stable with F1 2019) and I've not been able to force a crash. 

You should try framelimiting and I've been syncing the desktop refresh to the same value as the in-game. I'm also using Fullscreen (Windowed) as it's easier to drop in and out of the game with less hassle. I've not had any audio drop-outs or major loss of FFB (except online in one race).

e.g. I'm running a 144Hz display but from benchmarking can see that the system can hold 100FPS mostly so I've set the cap at 99FPS and the desktop at 100Hz. This ensures my GPU is utilised but not nailed. V-SYNC was awful for input lag, but V-SYNC OFF capped seems better.

It's frustrating as there were hardly any graphics issues with the beta (and I'm going to say that now, not bothered if it's against anything I signed) yet the released game is a crapshoot in exactly that area. 

It's interesting the two game areas that crash the most are the ones not tested, TT and MyTeam. I understand the reasons for their non-inclusion but this (and the final beta week build) have been an absolute slap in the face for all those directly involved at the sharp end of testing.

So believe me, I am super frustrated by what's been served up by the devs but it's not the fault of the beta testers nor the dev liaison. This is squarely on those responsible for the game code.

I'm hopeful that at least some of the issues found in beta will make the next couple of patches, all this release day build stuff is going to be a long haul because it's new to this game, but old to the title. 

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, CardConvict said:

Tried DLSS and got the black screen as others have reported so going to try the CS Culling option and see how I get on

CS Culling didn't seem to improve anything.

Fortunately, I'm getting a very smooth experience with v-sync on.

Edited by HDR10
  • Thanks 1

Share this post


Link to post
Share on other sites
13 hours ago, HDR10 said:

CS Culling didn't seem to improve anything.

Fortunately, I'm getting a very smooth experience with v-sync on.

I also tried v-sync both in game and control panel with no affect still stuttering

Share this post


Link to post
Share on other sites

I have a i7-4790K, GTX 1080, 16gb of 2133 RAM, and have the game installed on an SSD, and I still get massive FPS issues & stuttering if I try to play on windowed fullscreen mode. The performance increases slightly when switching to fullscreen only, but it's still not at the performance level it should be at with the rest of the graphics settings tuned down.

 

Looking back on Reddit though shows a similar thread for this for 2017, 2018, and 2019, so this just seems like it's a common issue. Hopefully there's a cure-all method to allow smooth performance in windowed fullscreen soon.

Share this post


Link to post
Share on other sites

I'm also having this same issue on xbox one. How is this even possible? I lag only when I play multiplayer and it's not choppy lag it's just a steady 5 or 10 fps. It's terrible. Started today. I tried letting the system cool and reconnecting internet. My speed is very good. What is up?

Share this post


Link to post
Share on other sites
Posted (edited)
On 7/18/2020 at 11:34 PM, xZora said:

I have a i7-4790K, GTX 1080, 16gb of 2133 RAM, and have the game installed on an SSD, and I still get massive FPS issues & stuttering if I try to play on windowed fullscreen mode. The performance increases slightly when switching to fullscreen only, but it's still not at the performance level it should be at with the rest of the graphics settings tuned down.

Looking back on Reddit though shows a similar thread for this for 2017, 2018, and 2019, so this just seems like it's a common issue. Hopefully there's a cure-all method to allow smooth performance in windowed fullscreen soon.

Overclock. Even I only went with 1866 RAM and it is plenty fast enough. Also there is errata on the CPU that Turbo can corrupt data. Suggest Turbo set OFF in BIOS.

Can issue a uCode fix for most boards of that era if you link your make and model or the shortcut is KB4497165 v4 (if running 1903/1909; maybe WU has sent that or 2004 has it built). Haven't had the opportunity to run F1 2020 on that CPU and board (or 2004) as I sold it to fund a Ryzen.

Edited by steviejay69

Share this post


Link to post
Share on other sites

Random stutters or one when someone join a lobby was a problem till 1.06 or even 1.05 when this was fixed, can't believe codies fubar it again and its back.

its unbelievable how they handle this game, SC bugged af, stutters, and then they post that black merc is in game -_-

I just hope that F1 esport gonna be a disaster so maybe then codies wake up.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×