Jump to content
Bug Reporting - PLEASE FOLLOW RULES AND COMPLETE REPORTS Read more... ×
F1 2020 | PODIUM PASS SERIES 2 NOW LIVE| READ ME!!! Read more... ×

Communicating with Online Services Message taking up all of the screen Master Thread

Recommended Posts

Hi.

The game keeps telling me every 25 seconds "connecting to online services..." in the upper left corner.
No matter where I am...main menu, loading screen, offline AI-race, cutscene...just everywhere it's telling me that it's connecting.

I don't seem to have online-connection problems at all, but this is annoying.

Is there a way to disable this message?
Don't wanna play offline, but this makes me furious.

Share this post


Link to post
Share on other sites

i can 100% agree with that it sucks i can drive 1 online game and then i need to restart the game or the Connect to Online service pops up every 30 secs

Share this post


Link to post
Share on other sites

This happened to me in a ranked race and I had to pause and let the AI take over and my car crashed with another and that was that. My rank and rating is gonna be F'd now. It was my second race. I had pole as well and was ahead before the first turn when it happened.

Share this post


Link to post
Share on other sites
Posted (edited)

Happened to me yestrday online one shot Q 25% race, unranked Lobby

Started on start of the race and poping up every few seconds

had to retire 

 

 

 

Edited by massa88

Share this post


Link to post
Share on other sites

I haven't completed a multiplayer race yet due to communication with online services flashing every race, so I tried time trials and after 4 or 5 laps got a Ego dumper almost every time trial this is typical of Codemasters every f1 every year has major bugs.

Share this post


Link to post
Share on other sites

I get the message top left every online race I play,  I've ignored it so far, but also reproduced the issue of it taking up the fullscreen once so far on PC during qualifying, it went away before the race started though. On PC.

Share this post


Link to post
Share on other sites

1.       "Communicating with online services" message keeps popping up at regular intervals during use of online features 
2.       1.03 
3.       Weekly Event - France - Race
4.       Occurred twice before in league lobby as host, not sure how to replicate. Sorry. 
5.      Installed latest drivers, verified game files.
6.       https://youtu.be/MLcHT6sEuB0

7.      DxDiag attached.

DxDiag.txt

Share this post


Link to post
Share on other sites

Yea someone needs to fix this asap, my internets connections good as well and I cant even play the game now? I paid for the Schumacher Edition not to have silly problems like this that stops me racing entirely.

  • Agree 2

Share this post


Link to post
Share on other sites
4 hours ago, choubu said:

Yea someone needs to fix this asap, my internets connections good as well and I cant even play the game now? I paid for the Schumacher Edition not to have silly problems like this that stops me racing entirely.

Same problem here and my internet is super fast???

Share this post


Link to post
Share on other sites

I keep getting this aswell. So frustrating that they don’t seem to have sorted their game at launch when we’re paying this much money. Keep getting kicked out from online races halfway through even when I’m still connected to Xbox live. 

Share this post


Link to post
Share on other sites

1.       A detailed description of the issue. Please include any error codes here 

When launching the game before I hit the main menu I am on “communicating with online services” going around and around. Restarting the game or console doesn’t help    And as such I cannot play the game at all. 


2.       What version of the game you are using (Shown on the start screen in the bottom left corner of the screen) 

1.04 / PS4 Pro / Schumacher edition. 


3.       Game-mode? 
 

Not able to get into a game mode  


4.       What are your replication numbers? Minimum test attempts are 4. Please also add EXACT replication steps for us to try too. 
 

Tried 5 times. Simply launch the game. 


5.       What troubleshooting have you attempted? Please always try to attempt to fix the issue 
 

Power cycling the console and restarting the game. 


6.       What peripherals are you are using (gamepad, wheel make & model etc) 
 

PS4 controller, Astro A50 headset. 


7.       Any screenshots or video of the issue? If the video is long, please include a timestamp for when the issue appears.  
 

No

Share this post


Link to post
Share on other sites

I am having the same issue on PS4, It’s making it extremely difficult to complete a race let alone be competitive 

Share this post


Link to post
Share on other sites

+1 for PS4 here: it wasn't an issue while I was playing ranked yesterday, but trying to do the Paul Ricard event today it was overlayed every 3-4 seconds.

Share this post


Link to post
Share on other sites

I keep getting the same on ps4 "communicating with online services" repeatedly popping up during online games, occupies the entire screen and makes game unplayable 

  • Agree 1

Share this post


Link to post
Share on other sites

This issue also happens to me on PC with steam version.

The whole screen is popping over and over again, very hard to keep drving...

My OS version is windows 10 2004(19041.329).

I'm using fullcone NAT(what maybe called by NAT 1,  also I can see NAT type is open in Xbox network setting).

My game report code is EDBD-DDJX-CXBE-CEHE.

Share this post


Link to post
Share on other sites
Posted (edited)

A good temporary fix is to have the "Connecting with Online Services" not block the entire screen. It usually happens after I finish my first ranked race. I have to restart the game to get rid of it.

PS4 here as well.

Edited by ark13700

Share this post


Link to post
Share on other sites
Posted (edited)

Ive Exactly the same issue,everytime I back out of time trial its on the centre of the page and stays there to the point i am forced to dashboard. 

Im part of a racing league community and we have held a 50% every night since the 7th and I've only been able to compete in 1 race. 

I either get kicked on launch or mid wY through qualy

Codies please help 

Xbox one 

Edited by Hubbadee

Share this post


Link to post
Share on other sites
Posted (edited)

Hi, I've tried contacting code master through Twitter, Facebook, Email etc since last Tuesday...

Every 5 seconds in solo/multiplayer/home screen i am being spammed with a message at the top left (communicating with online services) its the most distracting thing ever, I play everything on simulation, 100% races so when that pops up its the most distracting thing ever which usually leads to me making errors causing me the race.

My Internet settings are perfect, nat type etc are all good no issues there, is there a way to hide the services messages they shouldn't be showing up unless I'm on the multiplayer page/podium pass page, no need for them to show in solo surely?

Attached a screenshot to show the specific message I'm spammed with 

RNFetchBlobTmp_d8gmquh22i987ge6qfr8fs.jpg

Edited by RMC44
spelling mistake

Share this post


Link to post
Share on other sites

Why oh why does it have to be in massive letters in the middle of the screen sometimes, happened in tine trail, I couldn't see where I was going and crashed. Happened in an online game, *** ?  Couldn't see where I was going, it is usually in top left in small letters.

 

This is so annoying, is it a bug or just put there to make you crash ?

Grrrr

 

Share this post


Link to post
Share on other sites
Posted (edited)

Hello.

Version 1.0.2 Xbox One

F1 2020 often hangs when I want to go back to the main menu from the time trial or Grand Prix.

Then the "Connect to online services - please wait " screen appears. and then nothing happens !!!!

The "Connect to online services - please wait" screen no longer disappears. Then I have to restart the game!

Not every time. But very, very often.

My internet connection and Xbox Live configuration are ok.

Please fix it!

So the game is not playable if the only solution is to restart the game!

thank you

Edited by allfred

Share this post


Link to post
Share on other sites

Had it full screen today and crashed. Really dumb thing to have pop up

Share this post


Link to post
Share on other sites

I have a horrible skill rating because it not only happened during qualifying but it also happened in 3 of the 5 races I did. I CANNOT play ranked races unless I want to retire from my screen being blocked and the AI taking over and crashing. Bull$h!+

Share this post


Link to post
Share on other sites

1.       Communicating With Online services Pops Up During Racing online and singleplayer and in the menus every 5 seconds the game is unplayable...
2.       Game Version: 1.03
3.       Game-modes: Any (Time Trial, Grand Prix, Carrer, Ranked, Unranked)
4.       I start the game and after 30 40 mins of gameplay the game dissconnects from time trial and dosent even load the leaderboards and dosent upload vaild times and this communicating screen keep comes up in every 5 seconds
5.       router restart 3 times, pc restart, verifyed steam game files
6.       FANATEC CSL ELITE PS4 F1 SET
7.      my video link:

the video is 4 minutes long but it keeps happening from the beginning till the end

Share this post


Link to post
Share on other sites

I don't dare to play multiplayer until this issue is fixed. Hopefully rather sooner than later.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×