Jump to content Jump to content

BUG - Can't upgrade Facilities in My Team


Recommended Posts

Hi,

1. So I've upgraded my Facilities but in Aerodynamics, Chassis and Personnel departments I'm stuck waiting for some upgrades after the dates of completion have passed. (Images will show better)

All dates on screenshots (4Jul, 4Aug, 5Sep, 13Jun, 17Mar and 4Aug) have already passed. Those upgrades were made in first and second seasons, I'm on third season.

It's not like they've failed and now I have to upgrade them again, they're just stuck, like the game is still waiting for those dates.

I'd just like to be able to upgrade them without starting a new my team file.

2. Version 1.04 - PS4 Deluxe Schumacher Edition. (Played straight out of the box for about 17/19 races, only then I updated to version 1.04 (could be the reason of the bug).

3. My Team

4. I think replications numbers doesn't apply here. All other departments and upgrades are working fine. 

5. Closed and restarted PS4 and game, shutting down facilities and restarting them didn't help either.

6. Controller

7.

F1® 2020_20200713104905.jpg

F1® 2020_20200713104615.jpg

F1® 2020_20200713104625.jpg

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...
On 7/13/2020 at 12:18 PM, Abacelar27 said:

Hi,

1. So I've upgraded my Facilities but in Aerodynamics, Chassis and Personnel departments I'm stuck waiting for some upgrades after the dates of completion have passed. (Images will show better)

All dates on screenshots (4Jul, 4Aug, 5Sep, 13Jun, 17Mar and 4Aug) have already passed. Those upgrades were made in first and second seasons, I'm on third season.

It's not like they've failed and now I have to upgrade them again, they're just stuck, like the game is still waiting for those dates.

I'd just like to be able to upgrade them without starting a new my team file.

2. Version 1.04 - PS4 Deluxe Schumacher Edition. (Played straight out of the box for about 17/19 races, only then I updated to version 1.04 (could be the reason of the bug).

3. My Team

4. I think replications numbers doesn't apply here. All other departments and upgrades are working fine. 

5. Closed and restarted PS4 and game, shutting down facilities and restarting them didn't help either.

6. Controller

7.

F1® 2020_20200713104905.jpg

F1® 2020_20200713104615.jpg

F1® 2020_20200713104625.jpg

Hello @Abacelar27, did you find a solution?

Link to post
Share on other sites

Same problem in my game. I've managed to upgrade some parts ok e.g. fabrication, even though other sections, e.g. reliability, are stuck. I'm not sure how or why - don't know if progress was lost after the last update was installed - but I'm nervous about upgrading more. At the moment I'm just piling up cash and hoping either a fix is found or the departments upgrade again when the due date rolls back round next season, like tricking itself into completing again or something. I really hope this is being looked at though - the lack of a response on here about it makes me worry it's getting overlooked.

Link to post
Share on other sites

Frustrating that despite being reported by about 15 people weve had no feedback on whether this will be fixed. I started my My Team back in early July. Have had My Team on hold ever since waiting for  fix. Seems alot of us are in same boat :(

Link to post
Share on other sites

Well, running it on past the same date in the following season doesn't work. Made it back to March 21st, the earliest date for my incomplete upgrades, and nothing has changed. Still saying due March 21st. My Team is really quite broken until this gets sorted. Such a shame as the rest of the game is fantastic.

 

First time I've bought F1 at release; think I'll wait 6 months in future until the kinks are ironed out and no doubt the game will be cheaper by that point anyway.

Link to post
Share on other sites
  • Administrator

Hi everyone,

For users affected, can you please provide your savegame files so we can investigate further. 

Just to grab some extra detail for my report, can users who have been affected please add:

  •  Do the upgrades just sit in 'pending' stage.
  •  Do you receive any mail regarding the upgrades?
  •  A short video of users who have experienced this adding the timeline for the calendar, if possible, would really help illustrate the issue to the devs.

I'm running my own save (just started S2) and not yet experienced this, but, granted, I'm just going into Level 2 of the upgrades. 

Link to post
Share on other sites

1. I had upgraded facilty specs successfully before the patch. I started my team with no patches as I have slow internet and it was still downloading. My facilities were successfully upgraded. Then patch 1.04 or 1.05 hit and I went into my game and the facilities I'd previously upgraded were now saying spec 0 again. They also now had complete dates next to them that had long since passed. Another user said the bug also occured for him after one of the patches.

2. I cant remember but I'm pretty sure everything was normal regarding the succesful facility upgrade until the patch seemed to effectively reverse it and freeze it at spec 0. 

3. I can make a video tonight if it helps. I have uploaded screenshots previously as have a few others.

 

How do I provide save file from ps4? Is the save named somewhere?

 

Thanks for investigating.

Link to post
Share on other sites
7 hours ago, BarryBL said:

Hi everyone,

For users affected, can you please provide your savegame files so we can investigate further. 

Just to grab some extra detail for my report, can users who have been affected please add:

  •  Does the upgrades just sit in 'pending' stage.
  •  Do you receive any mail regarding the upgrades?
  •  A short video of users who have experienced this adding the timeline for the calendar, if possible, would really help illustrate the issue to the devs.

I'm running my own save (just started S2) and not yet experienced this, but, granted, I'm just going into Level 2 of the upgrades. 

 

Link to post
Share on other sites

Hopefully, this is my save file for you to look at.

I'm one season on from when the upgrades were done or are "due". My save is at a point just after the date for one of the upgrades, and just before one of the others, so if the game is run on a bit you'll see the next upgrade won't come either.

The majority of the upgrades all went through fine. I'm not sure what version of the game I had at that point, but once I'd upgraded to 1.06 they all regressed to not being due. There was also one that I am sure was being upgraded and then never did, so that one didn't regress as such but simply never came online. But since then the rest have all upgraded fine.

I'm not sure if I installed a few patches all at once as by the time I actually got to sit down and play the game 1.06 was the next patch to come out, so I may have done several patches in one go.

I've tried to upload a video but it's taking an age to upload for some reason. I'll link to it when I can.

.rofile

Link to post
Share on other sites
On 8/11/2020 at 2:27 AM, BarryBL said:

Hi everyone,

For users affected, can you please provide your savegame files so we can investigate further. 

Just to grab some extra detail for my report, can users who have been affected please add:

  •  Do the upgrades just sit in 'pending' stage.
  •  Do you receive any mail regarding the upgrades?
  •  A short video of users who have experienced this adding the timeline for the calendar, if possible, would really help illustrate the issue to the devs.

I'm running my own save (just started S2) and not yet experienced this, but, granted, I'm just going into Level 2 of the upgrades. 

Just sits in pending 

Link to post
Share on other sites
  • Administrator
On 8/14/2020 at 9:22 PM, emjay2kay said:

For some reason the videos aren't uploading from my PS4 to my actual YouTube account, so I'm not sure where they're going. I can take a video on my phone and upload that if this is still needed?

Hi @emjay2kay,

That's good enough proof for me, or just link the Youtube videos if thats easier.

Link to post
Share on other sites

Have started getting this in my team save as well.  Below is a youtube link showing the facilities as they appear at the moment, these where all working fine prior to applying 1.07.

If we take chassis department its showing within Facilities as:
Fabrication 1
Build Time 1
Quality control 1
Resource Point Generation 3

However if you jump to 43 seconds in the video its appearing as though nothing is applied to the 4 above sections. 

I'm not sure if this is related but is the amount of resources being collected each week (480) correct if all the faclilties are showing as Resource Point Generation 3?

 

Link to post
Share on other sites
On 8/17/2020 at 10:10 AM, BarryBL said:

Hi @emjay2kay,

That's good enough proof for me, or just link the Youtube videos if thats easier.

Here we go! Managed to sort the video out.

 

Since this video was taken, I am now getting that newer bug where the upgrade lines don't show, but I think that's already been reported and with developers. The issue here is still that the dates for these upgrades have been and gone, and those sections cannot now be upgraded further as they remain "pending".

As you can see from the calendar, I'm on the 16th April. The upgrades for 11th April and 11th March have obviously passed without taking effect, and obviously are not supposed to be due next year. All of the upgrades in the video which are showing as due after the 16th April are all from the previous year, so have already been and gone. 

All my recent upgrades have gone through fine, which is how everything else has been able to continue. It's just that block which all got rest of sorts following the download of a new patch (1.06 I think).

The video Thormit posted above is not the same issue that everyone else in this topic are talking about I don't think.

Hope this helps and it can be resolved soon.

Cheers,

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...