Jump to content Jump to content

Weird Force-feedback on last kerbs at Zandvoort and Spain


Recommended Posts

Okay, so did you make the registry change before even testing the wheel?

I strongly advise to stay with the default installation, regardless of the video as it is already some months old and the Logitech support in the game has been recently updated. @LogiUK @BarryBL

Delete any custom control schema in F1 2020. Disconnect the wheel. Verify Steam files.

Uninstall GHub with Geek Uninstaller (and LGS if you have it) with the wheel removed.

Use this Logitech Driver Cleaner to remove any vestiges of old drivers.

Use USBDeView to check there is nothing left. You can edit / remove old entries if this is the case.

Get the latest GHub and connect your wheel to install it. Don't make any changes!

Link to post
Share on other sites

I tested before of course. I installed LGS last night and ffb is back with the kerb bug. I will try again now with the steps. Maybe driver cleaner will make it work.

  • Like 1
Link to post
Share on other sites
Posted (edited)

Steps I did now and currently wheel is showing in DeView:

  • Delete custom schema in game
  • Disconnect the wheel
  • Verify game files
  • Uninstall LGS with Geek Uninstaller
  • Delete LogiShd in %appdata% and %programdata%
  • Execute Logitech Driver Cleaner
  • Check USBDeView

image.thumb.png.dc75fa03651d36e3d5ef63fc95aa3039.png

I did it afterwards:

  • I selected all G29 things and right clicked > uninstall driver.
  • Restarted my PC checked again no g29 shown is list.
  • I connect my wheel
  • Install G Hub
    • Downloading resources for g29
    • Initializing profile
  • Check deView for driver
    • image.png.1625f3ea1ca57a26dcbea9e60680d5dc.png
  • Open F1 2020 > Time trial (I didnt even changed rotation to 360)
  • Hit barriers go over kerbs etc with default g29 schema
    • no ffb coming from these
  • wheel was on PS3 mode, I switched into PS4 and wheel recalibrated itself again I tried 2 steps above but result is same.
Edited by CZPZ
afterwards
  • Thanks 1
Link to post
Share on other sites

@steviejay69 I have some good news 😂🎉

I switched back to LGS with the steps you told me, and the weird effect is gone. I don't know what fixed it, bios update? Its been busy 2 days for me and for you 🙏. Thank you for all the help. 

Untitled.thumb.png.c5bbb5fccb980a7912d2ee69d99e6167.png

Link to post
Share on other sites
7 hours ago, CZPZ said:

@steviejay69 I have some good news 😂🎉

I switched back to LGS with the steps you told me, and the weird effect is gone. I don't know what fixed it, bios update? Its been busy 2 days for me and for you 🙏. Thank you for all the help. 

Untitled.thumb.png.c5bbb5fccb980a7912d2ee69d99e6167.png

It’s odd, that’s for sure. BIOS updates can have undocumented effects, they often correct CPU or chipset errata or resolve compatibility issues. They sometimes contain updated modules for certain functions or hardware.

My concern is that GHub doesn’t work well for you yet LGS (which is no longer supported by Logitech) does. The really brave money tries to get GHub working - use Macrium Reflect (although Windows System Image should work) to take a snapshot of the working config, then you can remove LGS once more cleanly using the tools and see if the BIOS update was responsible. The backstop is you can restore the snapshot if it doesn't.

It’s possible that the Driver Cleaner or USBDeView have removed some crud from your Windows installation that was being temperamental. Or, as has been stated by AMD that the AGESA update really does remove any USB niggles - I think though it is supposed to manifest itself as a cycling USB disconnect / reconnect?

But I’m glad we have solved it. Perseverance pays off in the end 👍

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...