Jump to content
Bug Reporting - PLEASE FOLLOW RULES AND COMPLETE REPORTS Read more... ×

Patch 1.05 - Messed up wheel controls

Recommended Posts

Is this only on the Xbox? I am on a PS4 - but have not updated yet. 

Share this post


Link to post
Share on other sites

1.       A detailed description of the issue. Please include any error codes here. 

After patch 1.05 the cockpit view is stuck in look to apex. Cannot change it. If I switch to pod camera, the whell make me look left and right instead.

2.       Platform

xbox one


3.       What version of the game you are using (Shown on the start screen in the bottom left corner of the screen) 

1.05
4.       Game-mode? 

All
5.       What are your replication numbers? Minimum test attempts are 4. Please also add EXACT replication steps for us to try too. 

Have three users sharing the game. Is not an issue for the other 2. My game was not saving prior to patch 1.05 in Russia Now the camera view from cockpit is stuck in look to apex (seems like full) and changing the number makes no difference. Tried it in time trial as well as my team. Logged in and out to my game twice. Turned off console once and switch between the two other profiles once each.

Tried creating a new custom whell set up, trued default TMX set up.


6.       What troubleshooting have you attempted? Please always try to attempt to fix the issue 


7.       What peripherals are you are using (gamepad, wheel make & model etc) 

Thrustmaster TMX wheel
8.       Any screenshots or video of the issue? If the video is long, please include a timestamp for when the issue appears.   

  • Like 1

Share this post


Link to post
Share on other sites

Seems really strange, as I can't repro on PC or Xbox, so far that I've tried. I'll pass this onto our testing team with your reports and see if they can replicate. Please continue to add full reports and feedback where possible, might help us discover a method of replication

Share this post


Link to post
Share on other sites
48 minutes ago, Dufalump said:

Exactly, some people fail to realise that. I didn’t have a problem before this patch and don’t have a problem with any other games or previous F1 games. The dude just can’t accept that Codemasters is at fault.

I can accept that Codemasters are at fault. As I pointed out, there are many instances where the first thing that people do is blame the game before even looking at anything else.

Steps you've tried, times reproduced - often no steps, no replication.

Thank you for updating the firmware, you're welcome. If people did it, we wouldn't need to eliminate it - every time.

If people come out with the "if it ain't broke, don't fix it" repsonse, this is why you get the fragmentation of reporting, the recurring issues - no they're just at the same point that everyone who had it and resolved it was at when they had it.

If we all update together, there will be a tsunami of responses. As it's fractious, then it's fractious in response, fractious in resolution. Tedious for those who fixed the issue to remember back when what the fix was, because we've moved on to different issues.

The bug that people are having WAS an issue on PC, it's been FIXED in 1.05 - duplication of the right stick onto the wheel axis and pedals.

People on console are reporting this issue, irrespective of wheel. That I can lay with Codemasters - the XBox is pretty much a Windows PC. BUT, console players do not often update firmware, do not restart the console (sleep or snooze) and have a different idea of how and when to connect peripherals.

So thanks for your considered response. You don't know me, so don't try to tell me what my views are or paint me as someone I'm not.

Share this post


Link to post
Share on other sites
11 minutes ago, steviejay69 said:

I can accept that Codemasters are at fault. As I pointed out, there are many instances where the first thing that people do is blame the game before even looking at anything else.

Steps you've tried, times reproduced - often no steps, no replication.

Thank you for updating the firmware, you're welcome. If people did it, we wouldn't need to eliminate it - every time.

If people come out with the "if it ain't broke, don't fix it" repsonse, this is why you get the fragmentation of reporting, the recurring issues - no they're just at the same point that everyone who had it and resolved it was at when they had it.

If we all update together, there will be a tsunami of responses. As it's fractious, then it's fractious in response, fractious in resolution. Tedious for those who fixed the issue to remember back when what the fix was, because we've moved on to different issues.

The bug that people are having WAS an issue on PC, it's been FIXED in 1.05 - duplication of the right stick onto the wheel axis and pedals.

People on console are reporting this issue, irrespective of wheel. That I can lay with Codemasters - the XBox is pretty much a Windows PC. BUT, console players do not often update firmware, do not restart the console (sleep or snooze) and have a different idea of how and when to connect peripherals.

So thanks for your considered response. You don't know me, so don't try to tell me what my views are or paint me as someone I'm not.

You don’t know me either so don’t tell me to do the same.

Share this post


Link to post
Share on other sites
39 minutes ago, BarryBL said:

Seems really strange, as I can't repro on PC or Xbox, so far that I've tried. I'll pass this onto our testing team with your reports and see if they can replicate. Please continue to add full reports and feedback where possible, might help us discover a method of replication

Not sure if I append it to my bug report or how you want this. Brand new profile, default TMX wheel settings on xbox one.

The picture of the camera settings and the result on the video. When the view looks back is when the brake pedal is depressed.

D9B3D2E7-F328-481E-A70F-3BEE21C3CDEC.jpeg

80812BBC-E64F-479C-9887-60AA6DD5236E.jpeg

Share this post


Link to post
Share on other sites
1 hour ago, BarryBL said:

Seems really strange, as I can't repro on PC or Xbox, so far that I've tried. I'll pass this onto our testing team with your reports and see if they can replicate. Please continue to add full reports and feedback where possible, might help us discover a method of replication

The problem is linked to data saved in the cloud, when the user avatar is created.
If the player had already created an avatar before patch 1.05, the steering wheel does not work properly on the xbox account in which it was created.
If the player uses an xbox account on which he had not played the game before patch 1.05, the controls work correctly.

Is the avatar data created hosted on the Microsoft or Codemasters cloud?

Share this post


Link to post
Share on other sites
4 hours ago, dwin20 said:

Is this only on the Xbox? I am on a PS4 - but have not updated yet. 

I've not had an issue on PS4 with Thrustmaster T300RS. Not sure if I was lucky or PS4s are all OK though.

Edited by Ultra3142
  • Thanks 1

Share this post


Link to post
Share on other sites
12 minutes ago, hermespires said:

The problem is linked to data saved in the cloud, when the user avatar is created.
If the player had already created an avatar before patch 1.05, the steering wheel does not work properly on the xbox account in which it was created.
If the player uses an xbox account on which he had not played the game before patch 1.05, the controls work correctly.

Is the avatar data created hosted on the Microsoft or Codemasters cloud?

Not entirely true. We have 4 avatars. The 1 that bought the game and a second one both played prior to patch 1.05 and were un affected. The 3rd is messed up and no matter what settings are changed the problem persists ie the look to apex is on full in cockpit and the pod camera will look left and right if the wheel exceed a certain turn radius.

The 4th avatar was never used for F1 2020, when I tire it the wheel replicated the 3rd accounts issue.

Share this post


Link to post
Share on other sites

I've added all the information, and this direct link, to the developers for further investigation

 

Share this post


Link to post
Share on other sites
4 hours ago, Dufalump said:

You don’t know me either so don’t tell me to do the same.

I didn't tell you to do anything, I thanked you for trying the firmware. You lost nothing and potentially gained undocumented improvements (or cumulative stated improvements since your last firmware). I can see you're struggling to comprehend, but small mercies you can at least read. There is hope for you, don't give up will you? 😄

Share this post


Link to post
Share on other sites

Xbox
Thrustmaster TMX
Brake = Look back
Wheel left = look left
Wheel right = look right

Unbinding buttons dont work.
Recalibration dont work
Creating new wheel setup dont work
Hard reset dont work.
UNPLAYABLE.

 

how am i supposed to dont hit anyone in leagues when overtaking and having this glitch GET ME A DAMN FIX

Share this post


Link to post
Share on other sites

i get out of this that there is no fix

and as soon as i tried the delete everything thingy it didnt work and i lost all my setups and my team stuff now

 

Edited by wiardi18

Share this post


Link to post
Share on other sites
13 hours ago, Brandonisy316 said:

this may seem like common sense but all i did was 

1. force shutdown the game 

2. turn off the xbox one, wait 2 minutes then unplug xbox power supply, unplug all TX wheel accessories(power, pedals, usb)

3. wait five minutes, (go get a snack and a drink)....plug TX wheel and accessories back in without the USB......plug xbox back in and power up.....connect TX wheel USB

4. enjoy 

Yeah, you did already post that. 

Share this post


Link to post
Share on other sites

Same bug here In my main account, all modes, g920 with custom mapping and basic one

I tried with an account I never opened f1 2020 with and after creating the avatar I tryed TT and everything was fine 

 

Share this post


Link to post
Share on other sites
16 hours ago, steviejay69 said:

The bug that people are having WAS an issue on PC, it's been FIXED in 1.05 - duplication of the right stick onto the wheel axis and pedals.

Well, I was in a Ranked MP session last night and the wheel controls were working the camera, so you can scratch that as a fix @BarryBL

Share this post


Link to post
Share on other sites

Hi everyone,

To update on this one, it is currently with our testing team pending my unsuccessful replication on my desk. They also have more wheels to test, so we can cast a bigger net to identify and diagnose the problem. Thank you for your patience.

Share this post


Link to post
Share on other sites

Using a Logitech G29 on the PC.
When using a Flashback and fast forwarding using the R2 button, it will also look back on the camera.

By default the same button is mapped for looking back, but before 1.05 it would NOT look back, only fast forward.

Issue seems to be happening in all gamemodes.

Share this post


Link to post
Share on other sites
On 7/22/2020 at 10:36 AM, Aef251 said:

1.       A detailed description of the issue. Please include any error codes here. 

After patch 1.05 the cockpit view is stuck in look to apex. Cannot change it. If I switch to pod camera, the whell make me look left and right instead.

2.       Platform

xbox one


3.       What version of the game you are using (Shown on the start screen in the bottom left corner of the screen) 

1.05
4.       Game-mode? 

All
5.       What are your replication numbers? Minimum test attempts are 4. Please also add EXACT replication steps for us to try too. 

Have three users sharing the game. Is not an issue for the other 2. My game was not saving prior to patch 1.05 in Russia Now the camera view from cockpit is stuck in look to apex (seems like full) and changing the number makes no difference. Tried it in time trial as well as my team. Logged in and out to my game twice. Turned off console once and switch between the two other profiles once each.

Tried creating a new custom whell set up, trued default TMX set up.


6.       What troubleshooting have you attempted? Please always try to attempt to fix the issue 


7.       What peripherals are you are using (gamepad, wheel make & model etc) 

Thrustmaster TMX wheel
8.       Any screenshots or video of the issue? If the video is long, please include a timestamp for when the issue appears.   

 Update, deleted user data and restarted but the camera/controller issue continues. Only main account of 4 is unaffected. Tried also to unbind all controls and redo them one by one. No luck

Share this post


Link to post
Share on other sites

1.       A detailed description of the issue. Please include any error codes here. 

After patch 1.05 the camera view turns with the steering wheel and looks back under braking.

2.       Platform

xbox one


3.       What version of the game you are using (Shown on the start screen in the bottom left corner of the screen) 

1.05


4.       Game-mode? 

All


5.       What are your replication numbers? Minimum test attempts are 4. Please also add EXACT replication steps for us to try too. 

Have two users sharing the game. Is not an issue for the other profile. The camera view turns with the steering wheel and looks back under braking. Logged in and out to my game multiple times. Turned off console, hard reset console, deleted saved files, switched between the profiles, switched between camera views and changed the configuration of the steering wheel in the controler settings. I have noticed that I can enable two steering wheels at the same time and I am unable to disable either of them (selecting disable does nothing).


6.       What troubleshooting have you attempted? Please always try to attempt to fix the issue 

See above.


7.       What peripherals are you are using (gamepad, wheel make & model etc) 

Thrustmster 458 spider


8.       Any screenshots or video of the issue? If the video is long, please include a timestamp for when the issue appears.   

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×