Jump to content
Bug Reporting - PLEASE FOLLOW RULES AND COMPLETE REPORTS Read more... ×
F1 2021 | BETA | Details and how to Apply Here Read more... ×

Patch 1.05 - Messed up wheel controls

Recommended Posts

6 hours ago, Hobo05 said:

Scratch that... Worked to start with then suddenly stopped working after the game crashed and I had to restart

Yeah never worked for me.

Share this post


Link to post
Share on other sites

Are there any updates or official word on this issue? The game is unplayable for lots of us with wheels on Xbox. Can the patch be reverted on xbox? Should we ask for a refund of the game and go back to F1 2019?

Share this post


Link to post
Share on other sites
5 hours ago, Scorpion390 said:

I found a kinda fix for it 

In generic settings change mfd car setup panel to “also use look around” then when playing the bug doesn’t happen when the mfd is open but only on the first page and also the second page in race mode. Then you can kinda race normally but recommend only messing with mfd on straights. 

That's it! That's what I must of done to get it working off the MFD.
 

Thank you 

Share this post


Link to post
Share on other sites
6 hours ago, Scorpion390 said:

I found a kinda fix for it 

In generic settings change mfd car setup panel to “also use look around” then when playing the bug doesn’t happen when the mfd is open but only on the first page and also the second page in race mode. Then you can kinda race normally but recommend only messing with mfd on straights. 

Thanks. This has basically fixed my game as I always play with the MFD on and only mess around with it on straights. Been so frustrating not been able to play. Everyone who is having this issue, do the exact same thing this guy has said and it will fix the game.

Share this post


Link to post
Share on other sites

isnt great we all get to pay to be beta testers, hang on that is to generous.  Alpha testers.  Not on you Barry, but as someone who has been gaming since the 90's the way quality control drops every year is quite staggering.   Back in the day developers would actually beta test the games themselves.

Edited by rooztek
  • Like 1
  • Agree 2

Share this post


Link to post
Share on other sites

Is there an update on progress for this issue? When are we likely to get a fix?

The game is unplayable at the moment!!!

Share this post


Link to post
Share on other sites

The MFD method works but its not a fix, its a workaround.
It still needs to be fixed.

  • Agree 1

Share this post


Link to post
Share on other sites

Somehow mine has fixed itself completely (don't know for how long)

 

I noticed that the preset controls wasn't enable (when before no matter what I did one was always enabled)

 

Now only my custom control is enabled and the the glitch has gone.

Sorry I can't give more details as I have no idea how this happened.

 

But the generic setting work around stated above at least makes the game partially playable.

Share this post


Link to post
Share on other sites

Could it be that the presets for the wheel settings were somehow changed on the recent patch due to the  unavailable option of disabling wheel setups?

 

Share this post


Link to post
Share on other sites
18 hours ago, Scorpion390 said:

I found a kinda fix for it 

In generic settings change mfd car setup panel to “also use look around” then when playing the bug doesn’t happen when the mfd is open but only on the first page and also the second page in race mode. Then you can kinda race normally but recommend only messing with mfd on straights. 

Works in cockpit as long as I stay on the first 2 MFD screens. If I communicate with the pits or go to another screen it goes back to full loo to apex till I get back to one of the first to screens.

At least sort of playable.

Share this post


Link to post
Share on other sites
you can even do it like that with the MFD. However, when the MFD screen changes by itself to show some problem in the car (wing damage) for example, the bug already happens
Edited by Amatolino

Share this post


Link to post
Share on other sites
On 7/24/2020 at 12:38 PM, BarryBL said:

The issue is with developers awaiting a reproduction method and a diagnosis. We're continuing to test to get a consistent method of replication.

However, I have some advice from the devs. If you can test this and feedback to me here on what happened, it would be really appreciated:

"Could you ask for someone who’s got the issue to boot the game, then on the main menu unplug the wheel and plug in their Xbox controller. Then use the Xbox controller default setting (which it should automatically use) to load into the game and on the track. Drive around, check to see whether the camera is working correctly on that profile when using the controller instead of the wheel. Then they can plug their wheel back in (either on the track or back in the main menu) and using the default settings, check to see if the issue remains/has returned now they’ve got the wheel back in."

 

I’ve tried Racing with controller now. There is no issue when Racing with controller. 
But when switzsching to whell again, the issue returns. Uforunatly. 
 

Narrowing a bit down, I can see that the breake issue (looks back) switches when the breake pedal is applyed more than 50%. Less than 50% breake it works normal. 
Same with turning wheel.

When turning the wheel more than 90 degrees the issue appears (looks left/right).   
Under 90 degrees turn works fine. 
 

Futhermore I have discovered that if I ise my Old Xbox profile, there is NO issues. 
Changing to my New profile, and the issues are back. So it might acutually be a profile issue?

Share this post


Link to post
Share on other sites
6 hours ago, LinuzWiz said:

I’ve tried Racing with controller now. There is no issue when Racing with controller. 
But when switzsching to whell again, the issue returns. Uforunatly. 
 

Narrowing a bit down, I can see that the breake issue (looks back) switches when the breake pedal is applyed more than 50%. Less than 50% breake it works normal. 
Same with turning wheel.

When turning the wheel more than 90 degrees the issue appears (looks left/right).   
Under 90 degrees turn works fine. 
 

Futhermore I have discovered that if I ise my Old Xbox profile, there is NO issues. 
Changing to my New profile, and the issues are back. So it might acutually be a profile issue?

Definitely since out of three profiles on our xbox, the original/main is fine, but the other two are messed up.

 

Share this post


Link to post
Share on other sites

@BarryBL with the 1.06 patch coming in a few days to xbox is this issue fixed within the update or will we have to wait for a patch after the 1.06?

  • Agree 2

Share this post


Link to post
Share on other sites

This update not only didn’t fix it but now the controller is messed up. I use my right thumb stick to control my MFD and now it turns the camera every time I do it. I mean seriously what is going on?!

Share this post


Link to post
Share on other sites

If they messed it up with 1.05, how is it they cannot just undo it? The game was working great for me under 1.03.

Share this post


Link to post
Share on other sites

Unfortunately, this bug is no longer a priority, given the new bugs contained in patch 1.06.
It sounds like a joke, but besides having to deal with the bugs that already exist, each new patch brings new bugs

Share this post


Link to post
Share on other sites
On 7/24/2020 at 2:05 PM, BarryBL said:

Thanks for the initial feedback guys, I'll want to get a wider amount of users reporting the same as yourselves so I can go back to devs with your information. I think the weekend should suffice in terms of time. For all users, please keep trying the test in my previous post and add your findings. Really good information guys, keep it up.

 

BarryBL, what's the latest update? We haven't had one in a while....

Share this post


Link to post
Share on other sites
I think that your entire quality control process needs to be urgently reviewed.
The irony is that the name of the company is "codemasters"
  • Haha 1
  • Agree 3

Share this post


Link to post
Share on other sites

Hi everyone,

For users with multiple profile experiencing this issue, can you please provide details of both profiles usernames (in private messages), so we can see if there is any anomalies in the profiles.   

We are still working on replicating the issue. Can you also add when the profile was created and logged into F1 2020 for the first time. No exact dates needed, but was it pre-1.05 or post 1.05

Share this post


Link to post
Share on other sites

Hi There!
I just installed the patch 1.06, but still got the steeringwheel bug. (when I brake it looks back, and so on. You know about it.)
And i still didn't got the Pitcoins.
Am I the only one, who still got this problems?
Kind regards

Share this post


Link to post
Share on other sites

Had this bug (break looks back, turn left = look left, turn right = look right) since the 1.05 update. I was hoping it would be fixed when I loaded the game up today since I installed 1.06 yesterday. I'm on Xbox using Thrustmaster 458 wheel. Is this bug nearly fixed, the game is unplayable with the bug.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×