Jump to content
Bug Reporting - PLEASE FOLLOW RULES AND COMPLETE REPORTS Read more... ×
F1 2020 | PITCOINS NOW ASSIGNED - ONLINE SERVICES BACK ONLINE| READ ME!!! Read more... ×

Patch 1.05 - Messed up wheel controls

Recommended Posts

Posted (edited)
7 hours ago, BarryBL said:

Hi everyone,

For users with multiple profile experiencing this issue, can you please provide details of both profiles usernames (in private messages), so we can see if there is any anomalies in the profiles.   

We are still working on replicating the issue. Can you also add when the profile was created and logged into F1 2020 for the first time. No exact dates needed, but was it pre-1.05 or post 1.05

I’ve sent them to you. But just to share. 4 profiles pre-date installing f1 2020. One was only used after patch 1.05 to test the problem. I also created a 5th profile after 1.05 and it was still buggy. So no rhyme or reason that I can see.

The work around worked until the newest bug showed up. Now the game cannot advance.

 

To be clear. The main profile has zero issues at the moment.

Edited by Aef251
Additional information
  • Like 1

Share this post


Link to post
Share on other sites

Another one too everyone,

If you are experiencing this issue on your profile, and its the only profile you have on your Xbox, please also let me know in PM's. What I need is:

  1.  Gamertag
  2.  When you installed F1 2020 on your Xbox - What patch number here for this would be fine
  3.  Did you experience this issue pre Patch 1.05 or post 1.05?

At the moment, we are collecting different users and profiles to try and dig deeper to understand the issue and identify the fix. At this moment in time, we cannot find a method of replication from our internal tests, so we are trying to get as much information as possible to get a diagnosis. We can understand the frustration with this issue, and thank you for your patience. 

 

Share this post


Link to post
Share on other sites

So we started a second my team under the primary account and replicated the wheel and game settings. So far no camera/wheel issue and no save issues or crashes to home screen. I even made the same decions regarding 16 race calendar and team activities.

Share this post


Link to post
Share on other sites

Hi everyone,

We are still working on this and have a small update for you.

Can users attempt to totally sign out of all profiles, and then sign into just 1 of them (through the Xbox dashboard menus) and see if this is a workaround for the issue. Please feed back to me, regardless of result, so I can add to developers. We have a diagnosis in test, but still working on its reliability to make sure we identify the issue correctly. 

Share this post


Link to post
Share on other sites
1 hour ago, BarryBL said:

Hi everyone,

We are still working on this and have a small update for you.

Can users attempt to totally sign out of all profiles, and then sign into just 1 of them (through the Xbox dashboard menus) and see if this is a workaround for the issue. Please feed back to me, regardless of result, so I can add to developers. We have a diagnosis in test, but still working on its reliability to make sure we identify the issue correctly. 

So if I sign out of the account that bought the game, and try to go back with only one of the secondary profiles active I get a “Something went wrong” and am told to sign in with the account that bought the game. So I have to sign in with at least the main account working

Attempt 1 Sign in with Main account and a secondary account active

-Main works, 2nd crashed to home screen

-Re load game, secondary has issue.

Attempt 2 Sign in both active

-Sign out of Main

-Get notice DLC no longer available, crash to home screen

Attempt 3 Sign in with Main only

-Sign in 2nd and sign out main return to game “Something went wrong” sign in with account that bought game

Attempt 4 Sign in with Main

-Sign in to 3rd account, sign out main “Something went wrong”

Attempt 5 sign in with Main and 2nd active

-switch to second account and deleted save data, crash to home screen

Attempt 6 Sign in with main only active

-Swith user to 2nd account delete all saved data, crash to home screen

Attempt 7 Reset xbox, Sign in with main active and 2nd account at title screen

-delete user data, works get calibration screen

-create avatar problem persists

-sign out of main account, sign out of main account

-DLC unavailable message pops up on title screen

-go to time trial, crash to home screen, wants me to sign back in using main account

Attempt 8 Sign in with only main account

-switch user to 2nd account

-Sign out of main account “Something went wrong” sign in with account that purchased the game.

 

So without the main account active, I cannot get very far- unless I am doing this wrong.

Share this post


Link to post
Share on other sites
Posted (edited)

Now all of the DLC has been deleted from all accounts!!

 

And are now back????

Edited by Aef251

Share this post


Link to post
Share on other sites
3 hours ago, BarryBL said:

Hi everyone,

We are still working on this and have a small update for you.

Can users attempt to totally sign out of all profiles, and then sign into just 1 of them (through the Xbox dashboard menus) and see if this is a workaround for the issue. Please feed back to me, regardless of result, so I can add to developers. We have a diagnosis in test, but still working on its reliability to make sure we identify the issue correctly. 

@BarryBL out of curiosity, is this a digital game issue, or are people also having this problem with disk versions? Because I don’t see how I can get into the digital version without the main account being logged in so I can access the game.

Share this post


Link to post
Share on other sites

As you asked @BarryBL, here it is the issues im having.

 

1.       Throttle pedal is recognized as a "Z" button, while clutch pedal is recongnized as the throttle pedal. Also, total lack of wheel sensibility on track, the wheel only goes "live" when i go on curbs or off track.

2.       PC - Steam
3.       Was ok on 1.03, but bugged on 1.05. The video was made on 1.06, not showing any difference from 1.05
4.       All game modes
5.       What are your replication numbers? Minimum test attempts are 4. Please also add EXACT replication steps for us to try too.  - everytime i log on the game.
6.       What troubleshooting have you attempted? Please always try to attempt to fix the issue  - Reinstalling F12020 and GHUB software. Everything is fine with my wheel, because i use it everyday on iRacing
7.       What peripherals are you are using (gamepad, wheel make & model etc) - Logitech G29
8.       Any screenshots or video of the issue? If the video is long, please include a timestamp for when the issue appears.   -  https://www.youtube.com/watch?v=kVia8BKCzyQ&feature=youtu.be

Share this post


Link to post
Share on other sites

I am having the same issue on xbox with a g920 it controls the camera really annoying 

Share this post


Link to post
Share on other sites
Posted (edited)

It has been 10 days since i first emailed customer support witch has been no help whatsoever with my issue regarding my logitech g920 controlling my camera breaks look back wheel look side to side and throttle up. It is unplayable and unbearable how it has been allowed to happen and how long it has taken. This is not the quality i or anyone elce is expecting from a game developer who charges 60-70 dollars for a game and does not test for bugs before an update. The game is unplayable and so far there has been nothing in the way of a fix or news of a fix .

It was working completely fine until 1.05 and that update just completely disrupted my play of the game. 1.06 was not helpful in alevating this problem at all. 

Edited by Bob7449
  • Agree 1

Share this post


Link to post
Share on other sites
16 hours ago, Bob7449 said:

It has been 10 days since i first emailed customer support witch has been no help whatsoever with my issue regarding my logitech g920 controlling my camera breaks look back wheel look side to side and throttle up. It is unplayable and unbearable how it has been allowed to happen and how long it has taken. This is not the quality i or anyone elce is expecting from a game developer who charges 60-70 dollars for a game and does not test for bugs before an update. The game is unplayable and so far there has been nothing in the way of a fix or news of a fix .

 It was working completely fine until 1.05 and that update just completely disrupted my play of the game. 1.06 was not helpful in alevating this problem at all. 

the most interesting thing is that the
problem was in update 1.05 and came to 1.06 and nothing was fixed. Many people with this problem and they just ask for feedback, more
feedback? And Codemaster? When
anger gives feedback to
we who bought the game and couldn't play because of the update that messed up everything?

Share this post


Link to post
Share on other sites
Posted (edited)

Build 1.03 My Team worked on the main account and the 2 secondary accounts my sons and I use and the steering wheels worked for all 3 as well.

Patch 1.05;the secondary accounts both develop the wheel/camera issue and my secondary account crashes repeatedly refusing to load saved games and glitching in calendar activities.

Oh I miss the old days.

Edited by Aef251

Share this post


Link to post
Share on other sites

I have exactly the same issues

 

I have a thrustmaster 458 spider xbox one wheel

I was playing grand prix

when I brake I look back even it is bound to a (then when I press a I don't look back)

when I turn far enough i look either left or right

I only got the game yesterday so I am in the newest release of the game 

please fix It's unplayable!

Also I have only used one account 

Share this post


Link to post
Share on other sites

I have this issue as well. Fanatec dd2. When i hit brakes it shows the camera view behind me.  Tried rebooting, changing the wheel, reset xbox, tried a logitech. Etc nothing worked. But my other account worked ok

 

i tried 2019 f1 and everything works. If i do a lap in 2019 and then switch to 2020, then 2020 starts to work on my profile 

if i start xbox up again after it hoes to sleep it stops working   Same bug . If i lap 2019 f1 then go back to 2020 it does work again

 

 

Share this post


Link to post
Share on other sites

I have the same issue, when braking the camera looks back, when steering it goes left or right. I tried restarting the game, restarting my xbox but nothing works. I hope you can fix this because it is unplayable. Also on my brothers account everything works just fine. I tried with the controller and it works fine but when I switch to the wheel it glitches again.

Edited by StefRBR33

Share this post


Link to post
Share on other sites
4 hours ago, NametoShow said:

I have this issue as well. Fanatec dd2. When i hit brakes it shows the camera view behind me.  Tried rebooting, changing the wheel, reset xbox, tried a logitech. Etc nothing worked. But my other account worked ok

 

i tried 2019 f1 and everything works. If i do a lap in 2019 and then switch to 2020, then 2020 starts to work on my profile 

if i start xbox up again after it hoes to sleep it stops working   Same bug . If i lap 2019 f1 then go back to 2020 it does work again

 

 

Tied it,but did not complete a lap, only a couple corners in 2019 and then went to 2020- no luck.  I’ll try a full lap later, but did you use TT or something else in 2019, and is the problem on a secondary profile or your primary?

Share this post


Link to post
Share on other sites
10 hours ago, Aef251 said:

Tied it,but did not complete a lap, only a couple corners in 2019 and then went to 2020- no luck.  I’ll try a full lap later, but did you use TT or something else in 2019, and is the problem on a secondary profile or your primary?

I have an account set up for my daughter which is the default when opening xbox and my account which is the main account on which the game was purchased 

i need to enter passcode everytime i want my profile used

i start 2019 f1. Select user enter my passcode and start driving. Verify braking and everything is working and then quit to main menu.  Hit xbox button and switch to 2020 and continue in my career and all works

if i start 2020 first it will give me bug.  If i start 2020 without driving in 2019 it gives me the bug

hope this helps

Share this post


Link to post
Share on other sites
11 hours ago, NametoShow said:

I have an account set up for my daughter which is the default when opening xbox and my account which is the main account on which the game was purchased 

i need to enter passcode everytime i want my profile used

i start 2019 f1. Select user enter my passcode and start driving. Verify braking and everything is working and then quit to main menu.  Hit xbox button and switch to 2020 and continue in my career and all works

if i start 2020 first it will give me bug.  If i start 2020 without driving in 2019 it gives me the bug

hope this helps

Actually now my daughters account never works

Share this post


Link to post
Share on other sites

any progress on this, as it is unplayable for one user profile now 

same bug - turn wheel too much and the camera changes, brake hard and the camera shows behind

Share this post


Link to post
Share on other sites

1.       A detailed description of the issue. Please include any error codes here. 

a) press on brakes and the camera shows behind the car

b) turn wheel hard right and camera shows way to the  right

c) turn wheel hard left and camera shows way to the left

2.       Platform

a) XBOX One


3.       What version of the game you are using (Shown on the start screen in the bottom left corner of the screen) 

1.05
4.       Game-mode? 

Team mode
5.       What are your replication numbers? Minimum test attempts are 4. Please also add EXACT replication steps for us to try too. 

a) One one user profile, i get this every time i start up to play. I get this from a hard reset of the XBOX, hard reset of the fanatec wheel. I can solve the issue by first lapping F1 2019 with the same set up and it will let me play the game normally. This is a pain in the butt as it creates delay when wanting a quick session It does this in all modes of play i tried. Predominantly in team career mode. It has occurred in grand prix mode and time trial.

b) on other user profile, i cannot solve this, i get this error on the camera controls occurring every time no matter if i play 2019 first or reboot, etc.

c)
6.       What troubleshooting have you attempted? Please always try to attempt to fix the issue 

a) reset xbox,

b) restarted xbox

c) tried different wheel profiles

d) tried to rebind controls and tried to delete camera controls for look back, created new profile, nothing worked

e) tried other games on my xbox, Asseto Corsa, PC Cars 2,Horizon, F1 2018, F1 2019 --> all other games work fine.

f) this problem did not exist on original version of the game

g) unplugged fanatec wheel, checked all connections, different cable, 

h) beat my head against the wall in frustration

i) read this post many times and yet to see any reason to have hope for solution
7.       What peripherals are you are using (gamepad, wheel make & model etc) 

a) Fanatec DD2 Formula V2 wheel, pedals
8.       Any screenshots or video of the issue? If the video is long, please include a timestamp for when the issue appears.   

 

Share this post


Link to post
Share on other sites

Has anyone received communication about this? After waiting for my wheel to arrive only to have this happen, it's super frustrating, especially since this wasn't a problem BEFORE the updates 1.05. 

 

  • Agree 1

Share this post


Link to post
Share on other sites

This just started for me this morning on xbox and on controller. 

I can't use another profile. 

Luckily I live in Australia though so I can get a full refund. 

How do you screw something up that worked fine for ten years. Seriously

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, Digimouse said:

Has anyone received communication about this? After waiting for my wheel to arrive only to have this happen, it's super frustrating, especially since this wasn't a problem BEFORE the updates 1.05. 

 

Nothing recent. The last I heard was what BarryBL posted in this thread. CM is having trouble replicating the problem and is trying to understand the issue from our bug reports.

I am suspicious that the wheel issue is related to an inherent instability when I play the game in a secondary profile. Game crashes, refuses to save or load games after a few races etc.

Since it worked prior to 1.05 both in terms of game saves and wheels it is obviously related to a fix that made in 1.05. Also it is clear that it is not something glaringly obvious in the coding.

Lucky for me there are enough save game slots for myself and two sons to use on one account. Still, it would be nice to not have to change camera settings, wheel settings and assists every time I play.

Share this post


Link to post
Share on other sites

This is the same issue we having on another topic:
 

 

Somehow this topic is shown as RESOLVED, which is not.

 

Codemasters is doing a terrible job

 

Share this post


Link to post
Share on other sites

Hi,

I don't generally visit the forums but have been a reliable Codemasters customer since 2010.

I bought the Schumacher version of F1 2020 for £65 and began playing it on day 1 (7th July).  Around two weeks later, I experienced all the problems stated by others here (brake looks back, steering left and right looks in those directions) and have been completely unable to play the game since.

I don't understand what's needed for the error reporting but it shouldn't be necessary anyway - It's clearly a widespread issue which is affecting many.

Seriously guys, £65 for a handful of days gaming, then weeks of unplayability. It's completely unacceptable and I won't buy future editions unless you seriously pull your finger out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×