Jump to content
Bug Reporting - PLEASE FOLLOW RULES AND COMPLETE REPORTS Read more... ×

2019 crash carried on into 2020

Recommended Posts

Hi,

In the very last week of using F1 2019, the game would crash as it tried to load my last savegame. It would run through the opening screens until it got to the point where it would need to open the savegame and then I would get the EGO Dumper 'We're sorry, but your game has crashed!' screen. At this point all I could do was hit the 'Send Report' button. I repeated this half a dozen times or more over a couple of days before admitting to myself that this was a game breaking issue that wasn't going to fix itself. The only option I had was to uninstall and reinstall the game which made no difference. Not knowing how the system works I could only assume that the savegame file was either in a location on my PC and was still being called up at the start of the game or it was being downloaded from somewhere else.

As it happened, it wasn't a huge deal as I knew I was going to get my copy of F1 2020 within a few days. However, the EGO Dumper page still appears when loading 2020 but doesn't crash the game. This is what happens;

a. I launch 2020 from the desktop shortcut

b. I see the Steam black box saying 'Preparing to launch F1 2020'

c. I get the EGO Dumper page and hit the 'Send Report' button.

e. The game then loads to the front page (with the 4 drivers and 'Press Any Button', and showing 'Version 1.05') but the screen is frozen - background music is playing but pressing any button on the keyboard doesn't do anything.

f. At this point the game hasn't gone full screen so I can see that in the quick launch bar the F1 2020 icon is showing orange so I press the Windows Start key which returns me to the desktop.

g. I click on the icon and it takes me back to the game front page where pressing any button now works and the game loads as it should.

I think I have covered everything you need in your 'bug report' template but I will continue with it here;

1.       As above

2.       PC
3.       V 1.05
4.       N/A
5.       As above - ie with F1 2019 probably 6 - 8. With F1 2020 every time I load the game (at least once per day).
6.       F1 2019 I uninstalled and reinstalled the game
7.       Fanatec McLaren GT3 wheel, CSL Elite wheelbase and Clubsport V3 pedals
8.       N/A

Regards

Trevor Longden

Share this post


Link to post
Share on other sites
47 minutes ago, Lurtz said:

Hi,

In the very last week of using F1 2019, the game would crash as it tried to load my last savegame. It would run through the opening screens until it got to the point where it would need to open the savegame and then I would get the EGO Dumper 'We're sorry, but your game has crashed!' screen. At this point all I could do was hit the 'Send Report' button. I repeated this half a dozen times or more over a couple of days before admitting to myself that this was a game breaking issue that wasn't going to fix itself. The only option I had was to uninstall and reinstall the game which made no difference. Not knowing how the system works I could only assume that the savegame file was either in a location on my PC and was still being called up at the start of the game or it was being downloaded from somewhere else.

As it happened, it wasn't a huge deal as I knew I was going to get my copy of F1 2020 within a few days. However, the EGO Dumper page still appears when loading 2020 but doesn't crash the game. This is what happens;

a. I launch 2020 from the desktop shortcut

b. I see the Steam black box saying 'Preparing to launch F1 2020'

c. I get the EGO Dumper page and hit the 'Send Report' button.

e. The game then loads to the front page (with the 4 drivers and 'Press Any Button', and showing 'Version 1.05') but the screen is frozen - background music is playing but pressing any button on the keyboard doesn't do anything.

f. At this point the game hasn't gone full screen so I can see that in the quick launch bar the F1 2020 icon is showing orange so I press the Windows Start key which returns me to the desktop.

g. I click on the icon and it takes me back to the game front page where pressing any button now works and the game loads as it should.

I think I have covered everything you need in your 'bug report' template but I will continue with it here;

1.       As above

2.       PC
3.       V 1.05
4.       N/A
5.       As above - ie with F1 2019 probably 6 - 8. With F1 2020 every time I load the game (at least once per day).
6.       F1 2019 I uninstalled and reinstalled the game
7.       Fanatec McLaren GT3 wheel, CSL Elite wheelbase and Clubsport V3 pedals
8.       N/A

Regards

Trevor Longden

Hey Trevor, a dxdiag helps or (even better) the crash dump zip. 

Share this post


Link to post
Share on other sites

Sorry to have to ask, but where will I find the crash dump zips? Would it help if I sent the one from today and also one from when it happened loading F1 2019?

Share this post


Link to post
Share on other sites

@steviejay69 With reference to the issue quoted above, how do you know if the CM people have picked up on it? Do you get any kind of acknowledgement that it is being looked at?

Edited by Lurtz
Grammar

Share this post


Link to post
Share on other sites
50 minutes ago, Lurtz said:

@steviejay69 With reference to the issue quoted above, how do you know if the CM people have picked up on it? Do you get any kind of acknowledgement that it is being looked at?

If they reply or tag then that's it.

Share this post


Link to post
Share on other sites

Apologies. When @steviejay69 said; 

On 7/23/2020 at 2:56 PM, steviejay69 said:

a dxdiag helps or (even better) the crash dump zip. 

I thought it was a choice of either - not both. My mistake. Here is the file;

 

DxDiag.txt

Share this post


Link to post
Share on other sites

Loving the label printer as a DirectInput device.

There's some driver scaling going on with that display. Try disabling some audio devices and maybe look at updating the headset firmware if poss.

If you have MBAM (paid), try disabling the active scanning (or turn your trial to free).

But, I think the crash dump gives CM a bit more. 

Share this post


Link to post
Share on other sites

steviejay69 I am guessing the label printer being designated as a DirectInput device is not normal? It is just a pnp Dymo but it is plugged into a port on a monitor stand that I use. Must be because of that.

I'll look at disabling some of the audio devices but the Arctis is only 6 weeks old so the firmware will be current.

I don't have MBAM.

Thanks for your help with this.

 

Share this post


Link to post
Share on other sites

I have just come back to see if there is any progression on this and I noticed it says 'awaiting information'.

I filled out a bug report, posted crash dump .zips from both 2019 and 2020 games and also posted my dxdiag file.

What other information are you wanting?

Share this post


Link to post
Share on other sites
10 hours ago, Lurtz said:

I have just come back to see if there is any progression on this and I noticed it says 'awaiting information'.

I filled out a bug report, posted crash dump .zips from both 2019 and 2020 games and also posted my dxdiag file.

What other information are you wanting?

They will try to replicate your issue. The tag is outdated.

Share this post


Link to post
Share on other sites

@Lurtz from your initial report, have you tried Verifying your Steam Files at all? Doesn't say on there you have

Share this post


Link to post
Share on other sites

@BarryBL Please have a look at my original post (saves me explaining what was happening 😊). I have just Verified the files and now I get the EGO Dumper page, click on Send Report and that is it. No game. Nothing. At least before I had a work around but now I can't get anything to load. Then I had a thought. The original issue started with F1 2019, so I Verified those files. F1 2019 launched. No problem. OK - go back and try and launch 2020 - no go. Just the EGO Dumper page. Just to make sure, now that the 2019 issue was solved, I re-validated 2020 but no joy. I have also, as a matter of course, re-booted my PC but that didn't change anything.

The outcome then is that validating the F1 2019 files fixed 2019, but validating the 2020 files has broken 2020!

I would appreciate it if you could suggest a way forward.

 

 

Share this post


Link to post
Share on other sites
4 minutes ago, Lurtz said:

@BarryBL Please have a look at my original post (saves me explaining what was happening 😊). I have just Verified the files and now I get the EGO Dumper page, click on Send Report and that is it. No game. Nothing. At least before I had a work around but now I can't get anything to load. Then I had a thought. The original issue started with F1 2019, so I Verified those files. F1 2019 launched. No problem. OK - go back and try and launch 2020 - no go. Just the EGO Dumper page. Just to make sure, now that the 2019 issue was solved, I re-validated 2020 but no joy. I have also, as a matter of course, re-booted my PC but that didn't change anything. 

The outcome then is that validating the F1 2019 files fixed 2019, but validating the 2020 files has broken 2020!

I would appreciate it if you could suggest a way forward. 

 

 

Hi @Lurtz,

Another long-shot here: Have you tried a re-install with 2020 at all?

Share this post


Link to post
Share on other sites

The dynamic resolution is active because the display is a 720 TV.

Also, it's another Nvidia card 1070. Issue is here somewhere.

Share this post


Link to post
Share on other sites

@BarryBL. Do I un-install it from my PC, from Steam or both? I don't have the physical game - just a code. Also, if I remove and re-install, will I lose my current game data? 

@steviejay69. I don't understand what you mean. I have an HDMI switch which allows me to route the computer to either the TV in my racing setup or my ASUS monitor. Are you saying that this crash could be the result of my graphics card?

Share this post


Link to post
Share on other sites
17 minutes ago, Lurtz said:

@BarryBL. Do I un-install it from my PC, from Steam or both? I don't have the physical game - just a code. Also, if I remove and re-install, will I lose my current game data? 

@steviejay69. I don't understand what you mean. I have an HDMI switch which allows me to route the computer to either the TV in my racing setup or my ASUS monitor. Are you saying that this crash could be the result of my graphics card?

Uninstall via Steam. It won't remove the game from your library.

Yes, if the monitor is misdetected because of connected equipment. These cheap and nasty devices are responsible for a lot of issues (a bit like USB hubs).

  • Agree 1

Share this post


Link to post
Share on other sites

@BarryBL I have un-installed and re-installed but the problem is still there. 

@steviejay69 I have unplugged the HDMI switch and have my computer monitor back running directly from the graphics card. No change - still crashing.

  • Thanks 1

Share this post


Link to post
Share on other sites
5 hours ago, Lurtz said:

 I have unplugged the HDMI switch and have my computer monitor back running directly from the graphics card. No change - still crashing.

Delete the hardware_settings_config.xml and try to launch from Steam (it should launch DX12).

Please redo the dxdiag and upload the latest crashdump.

Share this post


Link to post
Share on other sites
18 minutes ago, Lurtz said:

Thanks for the reply @steviejay69. I deleted the hardware_settings_config.xml file and tried to launch via Steam but it again brings up the crash page.

Attached are the latest files.

678677-20200825-182935-0.zip

DxDiag.txt

OK so the printer is still connected....

The graphics card is still being misdetected.

DDU and revert to 446.14 (a better match for your Windows 10 1903)

Share this post


Link to post
Share on other sites

OK @steviejay69.......I really do appreciate all this help......but you have now started to speak in techno speak which has gone straight over my head :classic_blink: :classic_blush: 😊

Is the Dymo an issue? I can disconnect it and just plug it in when I need it.

I don't understand what you mean by 'misdirected'? Can I / should I change anything or will the steps re driver fix it?

I'll follow your suggestions re the driver and get back to you.........after I have had dinner (my wife is threatening physical violence if I let it go cold!!!) :classic_biggrin:

Again - thanks for your help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×