Jump to content
DiRT Rally 2.0 - New Player Guide Read more... ×

Archived

This topic is now archived and is closed to further replies.

F1 2015 - Fanatec CSP V2 does not work properly (Faulti Breaksensitivity)

Recommended Posts

It's not possible to adjust the brake fine. I need a hammer foot to brake ... The CSP Potti is already at 9 ...
Higher values of "Breake Deadzone" or "Breake Linearity" make the problem much worse...
I need negated values ... Is this possible?
I just want to set the Breaksensitivity like in the older games :-(

So expensive hardware and I can not play the game ... That can not be serious? I thought Fanatec would be compatibl?
thx in advance...






Share this post


Link to post
Share on other sites
Steering wheel works great but padels are terribly ... (can not be used at the moment) brakes react until about 90% braking distance

Asking for quick processing


Share this post


Link to post
Share on other sites
it acts as if the controller may be digital. nothing happens then it brakes fully

Share this post


Link to post
Share on other sites

My CSP v2's work fine in F1 2015 as long as I press them all fully after turning the wheel on and before launching the game.


It's quite normal behaviour in Codies games for this to be the case, although its not a bug and it normally affects all wheels/pedals... just a routine/ritual that needs to be followed before launching a Codies game.

Share this post


Link to post
Share on other sites
In our league 13 people have the problem ... we just want to set only the sensitivity. When we breake 40% in the Fanatec driver-menu (function test) the car should breake 100% in the game.
In all older games it was the Brake pedal saturation setting for example 35%
Then it was possible to break gently... The brake pedal should simply not be fully depressed...

If this is not solved , we can return the game ... :-(





Share this post


Link to post
Share on other sites
Suat Tombul (Fanatec Support Team) has confirmed the problem, it is clearly game problem.

Asking for quick processing!!! :-(

Share this post


Link to post
Share on other sites
Same problem here. Brake pedal pressure function only at 95%. So you destroy the Fanatec pedals. Proper braking is not possible ... We need a option to set the sensitivity!!!!!

Share this post


Link to post
Share on other sites
I have he sim pedals and mines are the same its like a big deadzone on both gas and brake pedals.

Share this post


Link to post
Share on other sites
exactly what I mean...The Brake Saturation is reversed you should be able to set negative values ​​to change the sensitivity ... Is this possible via XML ?





Share this post


Link to post
Share on other sites
exactly what I mean...The Brake Saturation is reversed you should be able to set negative values ​​to change the sensitivity ... Is this possible via XML ?

Share this post


Link to post
Share on other sites
+1 .
 Fanatec Club Sport Pedal V2 : massive throttle deadzone !!!  :(

Share this post


Link to post
Share on other sites

I join the line

Fanatec CRS Elite EU

Braking gently i.g. easing off the brake gently is impossible. Need to stomp the pedal like an elphant. Worked in all other games. This really Needs Fixing Codemasters. 3X Pleeeeaaaassse....(with sugar on top).

Share this post


Link to post
Share on other sites
+1  that should be a racing game and you can not break. That is one of the biggest faults since the fps bug in f1 2013. our league is stunned.......

Share this post


Link to post
Share on other sites
Same problem here with CSP V2 and another person I know has the issue with CSR Elites.
This is genuinely a game-breaking bug, it's unplayable.

Share this post


Link to post
Share on other sites
So much for new driving experience ... our league is stunned ? Satuartion setting just missing ....
But Codemaster makes now weekend and lets us sit ... just sad


Share this post


Link to post
Share on other sites
Simsel said:
So much for new driving experience ... our league is stunned ? Satuartion setting just missing ....
But Codemaster makes now weekend and lets us sit ... just sad



i think i found a Workaround!

i use the fanatec csr elite EU pedals with a G27 or GFDT on PC

Well the pedals only work if you configure breaking and throttle via the menu. in my case the axis the game showed was y-  but when i pushed the brake it showed axis y- Rotation.

So I checked the Action map in the f1 2015 steam Folder and found the Settings for fanatec usb pedals. by Default the axis are

ActionMap actionMapName="Fanatec_USB_Pedals" deviceName="{18390EB7-0000-0000-0000-504944564944}" priority="5">
    <Action actionName="Accelerate">
        <Axis axisName="di_z_axis_rotation" type="uniDirectionalNegative" deadZone="0.0" saturation="1.0" />
    </Action>
    <Action actionName="Brake">
        <Axis axisName="di_y_axis" type="uniDirectionalNegative" deadZone="0.0" saturation="1.0" />

so I changed it to the actual axis the game tells me when i configure the pedals manually That is:

<ActionMap actionMapName="Fanatec_USB_Pedals" deviceName="{18390EB7-0000-0000-0000-504944564944}" priority="5">
    <Action actionName="Accelerate">
        <Axis axisName="di_x_axis_rotation" type="uniDirectionalNegative" deadZone="0.0" saturation="1.0" />
    </Action>
    <Action actionName="Brake">
        <Axis axisName="di_y_axis_rotation" type="uniDirectionalNegative" deadZone="0.0" saturation="1.0" />
    </Action>
</ActionMap>

Bold print are the changes.

This is what the game actually Shows you when I push the pedals. The logitec Default for the DFGT still Shows the z-axis Rotation in game, but the pedals work now nevertheless.

After that everything is roses! Pedals are working fine and the load cell works as it should!

Please try it for yourself and give Feedback Hope that helps!

Share this post


Link to post
Share on other sites
Thank you you're my hero *kiss*
Codemaster plz fix that and add a saturaition option ....

Share this post


Link to post
Share on other sites
you can also change the saturation in the action map, i just tried it myself, used to drive with 25% saturation for my load cell don't add the 25 to the 1.0 (1.25) this makes the brakes less responsive. you have to substract the percentage from the 1.0. so in my case i set it to 0.75. now the brakes react like they used to in the other games

Share this post


Link to post
Share on other sites
Murax said:
Simsel said:
So much for new driving experience ... our league is stunned ? Satuartion setting just missing ....
But Codemaster makes now weekend and lets us sit ... just sad



i think i found a Workaround!

i use the fanatec csr elite EU pedals with a G27 or GFDT on PC

Well the pedals only work if you configure breaking and throttle via the menu. in my case the axis the game showed was y-  but when i pushed the brake it showed axis y- Rotation.

So I checked the Action map in the f1 2015 steam Folder and found the Settings for fanatec usb pedals. by Default the axis are

ActionMap actionMapName="Fanatec_USB_Pedals" deviceName="{18390EB7-0000-0000-0000-504944564944}" priority="5">
    <Action actionName="Accelerate">
        <Axis axisName="di_z_axis_rotation" type="uniDirectionalNegative" deadZone="0.0" saturation="1.0" />
    </Action>
    <Action actionName="Brake">
        <Axis axisName="di_y_axis" type="uniDirectionalNegative" deadZone="0.0" saturation="1.0" />

so I changed it to the actual axis the game tells me when i configure the pedals manually That is:

<ActionMap actionMapName="Fanatec_USB_Pedals" deviceName="{18390EB7-0000-0000-0000-504944564944}" priority="5">
    <Action actionName="Accelerate">
        <Axis axisName="di_x_axis_rotation" type="uniDirectionalNegative" deadZone="0.0" saturation="1.0" />
    </Action>
    <Action actionName="Brake">
        <Axis axisName="di_y_axis_rotation" type="uniDirectionalNegative" deadZone="0.0" saturation="1.0" />
    </Action>
</ActionMap>

Bold print are the changes.

This is what the game actually Shows you when I push the pedals. The logitec Default for the DFGT still Shows the z-axis Rotation in game, but the pedals work now nevertheless.

After that everything is roses! Pedals are working fine and the load cell works as it should!

Please try it for yourself and give Feedback Hope that helps!

Actionmap download, PLS !! :D

Share this post


Link to post
Share on other sites
i can' t upload it to the net somewhere, but if you send me a pm i can mail you my actionmap. not sure if that will help you, cos i think the axis problem the game has depends a lot on the device used, so it might not work for you. might have to adjust it to your needs yourself.

Share this post


Link to post
Share on other sites

×