Jump to content
Motorsport Games, Codemasters and FIA World Rallycross Championship presented by Monster Energy partner to create the World RX Esports Invitational Read more... ×

Archived

This topic is now archived and is closed to further replies.

F1 2015 Big fps drops

Recommended Posts

Does anyone still have the problems after the latest patch - I certainly do. 

Also, how do you bring up those details in the top left (on fps etc.)?

Share this post


Link to post
Share on other sites
Hi @Literalzero, just want to check if this was intended to be part of those addressed in the v2.5 patch?  I doubt it was as I've been encountering this same problem (starts at 70fps, goes down to only 20-30+fps).  Either Championship, Quick Race, or Benchmark.  So screens gets stuttery.  This is only at High (not Ultra) settings w/ Motionblur and DepthofField=Off.  For reference, using a GTX970, i5-4670k and 16Gb Ram.

Share this post


Link to post
Share on other sites
TomCur56 said:
Does anyone still have the problems after the latest patch - I certainly do. 

Also, how do you bring up those details in the top left (on fps etc.)?
Yes, problem still persists for me aswell.

Share this post


Link to post
Share on other sites
sherp said:
Hi @Literalzero, just want to check if this was intended to be part of those addressed in the v2.5 patch?
There was nothing in the release notes that suggested this would be fixed.

Share this post


Link to post
Share on other sites
I don't know how bad the issue is for everyone else but I find the FPS drops to about 5-10fps.

Share this post


Link to post
Share on other sites
Hey @TomCur56 and @scottishwildcat, what GPU do you use?

@Literalzero, can you at least acknowledge this, and/or just give some feedback if you've replicated this, or is it just us experiencing this?  So we can also look further into our system, if you can confirm that it's not the game causing it.  I tried moving the game to an SSD and performance improved for a while.  I thought it was already fine, but next time I tried (Championship), FPS started dipping again to 20's-30fps (using NVidia v353.38).  Seems it goes down and stays there, so have to exit and restart the game where it starts at 70's, then dips again after some laps.  GPU temp maxes at 58deg only.

Share this post


Link to post
Share on other sites
Anti-Aliasing, Vsync and Anistropic Filtering are all very GPU heavy, turning them off will certainly help.


Share this post


Link to post
Share on other sites
@sherp AMD Radeon R9 M370X here. Pretty sure @LiteralZero has already confirmed in other threads that the team is aware of this issue.

@Fitzsteve Have tried turning all those off, makes no difference to this particular issue.

Share this post


Link to post
Share on other sites
@sherp AMD Radeon R9 M370X here. Pretty sure @LiteralZero has already confirmed in other threads that the team is aware of this issue.

@Fitzsteve Have tried turning all those off, makes no difference to this particular issue.
I see. I asked as I haven't seen any update on their findings, or at least initial, but hope they get it fixed soon. It appears fps drops are different from each setup. Some say 5-10fps, while it reached up to 50fps (75fps, down to 20+fps) for me after several laps.

Share this post


Link to post
Share on other sites
Will this shit ever get fixed? I cant for the life of me play the game i bought with my hard earned cash, expecting it to be amazing and not a massive fuck up...
As soon as i plug my controller my FPS drop from 70-80 with maxed out setting to 10-20 FPS and my GTX 970 cant do anything about it.

FIX IT AS ITS UNPLAYABLE.


I bought this and Grid 2 from a codemasters employee (QA) and he warned me that both games were not great and company was in trouble, i didnt believe him then but i sure as hell believe him now.

Share this post


Link to post
Share on other sites
FWIW, I tried removing my G27 (tried both xbox controller and keyboard) but the FPS dips still happened.  So in my case, it doesn't seem to be the controller.  What driver version you using with your GTX970?  I tried both 353.38 and 353.30, w/ no improvement.

Share this post


Link to post
Share on other sites
Im using 353.30, its just unplayable. First the game wouldn't even start so i had to figure out a way which was set compatibility with windows 8 on.
Now i cant even race since FPS just drops massively. I knew i shouldn't have bought this piece of junk.

Share this post


Link to post
Share on other sites
I had this problem with an older AMD driver on a preview build of Windows 10 (so not sure which was the problem).

Since upgrading Windows 10 to the latest release (rumored to by the final), and using AMD drivers 15.7 I have had no FPS drops at all, running on Ultra with a locked 60fps (v-sync).

Share this post


Link to post
Share on other sites
@Literalzero, can we at least have some feedback on this, and to know if the team has replicated it?  Let us know what info you need hopefully to help address the issue.  Still happens with latest patch 4.  

Share this post


Link to post
Share on other sites
@LiteralZero doesn't work for CM any more. They've previously indicated that they're aware of the issue and were looking into it, but if you can reliably reproduce it, I'm sure they'd welcome the details.

Share this post


Link to post
Share on other sites
@LiteralZero doesn't work for CM any more. They've previously indicated that they're aware of the issue and were looking into it, but if you can reliably reproduce it, I'm sure they'd welcome the details.
Oh ok, guessed it right, soon it would happen with the issues prevalent.

What details are needed so I can provide them? A lotof which I've given in previous posts. 

Share this post


Link to post
Share on other sites
Friends , I found a solution for low FPS in the " championship mode " . I reviewed the file of graphic settings of the game and found the ' vsync ' was enabled by default so it was disabled within the settings of the game.
Well, I will give you instructions if they want to try :

1. Contact Documents / My Games / F1 2015 / hardwaresettings and open the text file " hardware_settings_config " .

2. In the notebook look ' vsync = "true "> ' and change it to ' vsync = " false"> ' .

3. Save the changes and run the game.

It worked for me , I hope that works for them friends,greetings !

Share this post


Link to post
Share on other sites
Friends , I found a solution for low FPS in the " championship mode " . I reviewed the file of graphic settings of the game and found the ' vsync ' was enabled by default so it was disabled within the settings of the game.
Well, I will give you instructions if they want to try :

1. Contact Documents / My Games / F1 2015 / hardwaresettings and open the text file " hardware_settings_config " .

2. In the notebook look ' vsync = "true "> ' and change it to ' vsync = " false"> ' .

3. Save the changes and run the game.

It worked for me , I hope that works for them friends,greetings !
Thanks for the suggestion.  Doesn't seem to help with my setup.  What gpu do you have and firmware version?  

Share this post


Link to post
Share on other sites
I had that problem with my 360 Controller for Windows and I went to re-calibrate the controller in the Control Panel => Material and Audio => Peripherals and Printers. Right-click on the Controller image and select Properties, re-calibrate all axes from there, click Apply once done.

It seems the FPS isn't dropping too much after I've done that (and I reduced the Shadows setting in Graphics Options from HIGH to MEDIUM, the Postprocess setting from HIGH to LOW, and the Particles one to LOW also).

Share this post


Link to post
Share on other sites
Finally, seems I've resolved my FPS-dropping issue.  I had my shortcut set run with Vista SP2 compatibility mode because it wasn't saving my progress w/o it.  Removed it and fps seems to running fine now, while saves are still made.  

Problem though is the huge steering dead zone with the latest patch.  Have to keep remapping steering every time you start the game to remove this dead zone.

Share this post


Link to post
Share on other sites
I cant believe this hasnt been resolved yet by CM, after latest patch I still get FPS drop after couple of laps.

Share this post


Link to post
Share on other sites
AlpineLV said:
I cant believe this hasnt been resolved yet by CM, after latest patch I still get FPS drop after couple of laps.
I understand, it's really frustrating.  What gpu do you have, and driver version?  From what FPS, down to what FPS?  

Share this post


Link to post
Share on other sites
Actually, it was fixed for me by updating my AMD video card drivers (which I wasn't able to do for a while, until Apple updated them in BootCamp).

Share this post


Link to post
Share on other sites

×