Jump to content
F1 2020 Forum Championship SPACES AVAILABLE Read more... ×

Your connection is garbage?

Recommended Posts

My internet is great and has a steady speed but when I play your game I get kicked half way through 3 games in a row. Common this is extremely frustrating.

Please dont delete this post because I'm pointing our a flaw in your matchmaking... just fix it please.

  • Agree 1

Share this post


Link to post
Share on other sites

My Third World country 120MB internet connection gets me through alright on my weekly events.

Please don't delete this post because I'm pointing out that our individual experiences don't make for the whole functionality of the game and for insinuating that there are so many possibilities of user error underlying the issue that a two-liner generic brings jack poop useful data for the devs.

Share this post


Link to post
Share on other sites

Usually when you get kicked during a game, it's because you've lost connection to your platforms' matchmaking servers (Steam Friends, Xbox Live, PSN).

Steam servers went down during the Forum Championship Azerbaijan GP, which was fun. Only those who weren't in Europe could continue 😛 

Share this post


Link to post
Share on other sites

That’s funny, we have a driver in the league  who’s car will disappear from 3rd to 1st to 4th to 1st in the blink of an eye. 

It’s really annoying to all the others drivers around him. 

It only happens to him and all others players can see and have noticed this. He says it’s his connection but it has never kicked him from the game. The drivers are from all over the world, this particular driver is front the UK like most of the team. Even the players in the States on the team don’t have this issue. 

Is this really an Internet connection issue or maybe some new form of cheat?

The platform is PS4
 

 

Share this post


Link to post
Share on other sites

@2fast4yal please complete the Multiplayer bug reporting template, and add report codes, and I can try and diagnose this for you. 

Also, if you are reporting an issue, please add to the Technical Assistance page. Thanks 👍

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×