Jump to content
Bug Reporting - PLEASE FOLLOW RULES AND COMPLETE REPORTS Read more... ×
F1 2021 | BETA | Details and how to Apply Here Read more... ×
FORUM MAINTENANCE | 11/05/2021 AM Read more... ×

WRONG FORCE FEEDBACK ON LOGITECH G29 IN F1 2020 (PROBLEM IDENTIFIED)

Recommended Posts

  • A detailed description of the issue. Please include any error codes here.
    •  

      I had been using the G29 on F1 2020 since the launch date.
      The force feedback had been working fine but since yesterday (October 11, 2020), FFB through high speed corners has gotten reversed.

      For example, turning right through Copse, the wheel offers no resistance and gives FFB in the direction of the corner. So I'm turning right for Copse and the wheel adds extra force towards the right.

      Did I change any settings?
      -
      NO. I just increased FFB strength (in-game) from 42 to 46 two days before.

      Is there a problem with the wheel?
      -
      NO. It works fine on all other games including F1 2019.

      The FFB feels alright in slow-speed corners.
       

       

      The problem occurs in both multiplayer and solo TT.
      Attaching a report code of a multiplayer practice around Silverstone where I observed the same issue through T2 and then by weaving on the straights.
      JASG-KTGC-BBPE-PSVG

  • Platform
    • PC
  • What version of the game you are using (Shown on the start screen in the bottom left corner of the screen) 
    • 1.10
  • Game-mode?
    • Both Multiplayer and SOLO
  • We need to be able to make your problem happen internally so we can fix the issue. Can you make the problem happen again?
    • Yes
  • How do you make the problem happen?
    • Take high speed corners. Weaving on the straights will give you extremely unexpected FFB.
  • What troubleshooting have you attempted? Please always try to attempt to fix the issue 
    • I have tried reconfiguring the wheel, reinstalling wheel drivers, verifing game integrity on Steam and reinstalling the game.
      Nothing has worked so far
  • What peripherals are you are using (gamepad, wheel make & model etc) 
    • Logitech G29
  • Any screenshots or video of the issue? If the video is long, please include a timestamp for when the issue appears.   
    • https://youtu.be/lDsIslEcVdc

      0:00 - 0:14: NO ISSUE
      0:15 - 0:23: The wheel feels light through T1 and there is a heavy force towards right after taking T2
      0:24 - 0:36: NO ISSUE
      0:37 - 0:39: Heavy force towards right which after weacing right and left once
      0:40 - 1:00: NO ISSUE
      1:01 - 1:05: Wheel automatically tried to go left after taking corner
      1:06 - 1:11: Wheel gives FFB towards right on its on entry to Maggotts2
      1:12 - 1:17: NO ISSUE
      1:18 - 1:22: HEAVY FFB TOWARDS RIGHT AFTER WEAVING
      1:19 - 1:50: NO ISSUES
      1:51 - END: STRONG FFB TOWARDS LEFT ON FLICKING THE WHEEL RIGHT AFTER T2



      I TRIED FINDING WHAT IS WRONG AND I ONLY GOT THE ISSUE ON THE DEFAULT BALANCED SETUP. I DON'T GET THE ISSUE ON CUSTOM SETUPS

 

 

Edited by PrakharVats
FOUND THE PROBLEM

Share this post


Link to post
Share on other sites

Might want to try the below: (Credit to @steviejay69

Go into the game, delete the custom control scheme for the wheel.

Verify the game files in Steam, delete the hardware_settings_config.xml and restart the PC. Check for correct operation in GHub.

Also check the Steam controller settings

Share this post


Link to post
Share on other sites
1 minute ago, BarryBL said:

Might want to try the below: (Credit to @steviejay69

Go into the game, delete the custom control scheme for the wheel.

Verify the game files in Steam, delete the hardware_settings_config.xml and restart the PC. Check for correct operation in GHub.

Also check the Steam controller settings

I tried doing all of these things.  There was no difference. As I said, it only happens on the balanced default setup for some reason!

 

Share this post


Link to post
Share on other sites

I'm not sure what to suggest to be honest.  Based on the evidence it seems to be something coming from F1 2020 somewhere, especially as it only seems to happen in the default balanced setup?  It's definitely odd that it just started happening though as it doesn't coincide with the release date for the latest patch for F1 2020 (unless @PrakharVats has only just allowed the patch to download and install at the weekend?!  Unlikely, especially if they play online...) Certainly, we've made no changes to the SDK for the wheels recently.

I guess the follow-up questions would be what force feedback settings are applied and also what level of assists?  And does altering any of those assists makes any difference to the feelings that are being experienced through the wheel?

  • Thanks 1

Share this post


Link to post
Share on other sites
17 minutes ago, LogiUK said:

I'm not sure what to suggest to be honest.  Based on the evidence it seems to be something coming from F1 2020 somewhere, especially as it only seems to happen in the default balanced setup?  It's definitely odd that it just started happening though as it doesn't coincide with the release date for the latest patch for F1 2020 (unless @PrakharVats has only just allowed the patch to download and install at the weekend?!  Unlikely, especially if they play online...) Certainly, we've made no changes to the SDK for the wheels recently.

I guess the follow-up questions would be what force feedback settings are applied and also what level of assists?  And does altering any of those assists makes any difference to the feelings that are being experienced through the wheel?

I downloaded the patch when it came out, but it was definitely the first time I tried the default balanced setup after the patch, so it could be that.
Also, I'm not using any assists, and I even deleted my custom control profile and tried changing FFB strength and calibrations but the issue still persists on the balanced default setup. (You can watch the video I tagged in the initial report)

 

Share this post


Link to post
Share on other sites

Understood.  It's difficult to analyse the video without actually feeling what the wheel is doing too!   Regarding FFB settings, it was more the other settings (On track effects, dampening etc.) that I was intrigued to see. 

Share this post


Link to post
Share on other sites
8 hours ago, PrakharVats said:

I downloaded the patch when it came out, but it was definitely the first time I tried the default balanced setup after the patch, so it could be that.
Also, I'm not using any assists, and I even deleted my custom control profile and tried changing FFB strength and calibrations but the issue still persists on the balanced default setup. (You can watch the video I tagged in the initial report)

Can you post a dxdiag and include the make and model of the motherboard please?

Also, are you using any passive or powered USB hubs? Can you ensure your Logitech wheel is plugged into a USB 2.0 port? Also, ensure your wheel is powered and has completed calibration before launching the game.

Share this post


Link to post
Share on other sites
  • A detailed description of the issue. Please include any error codes here. 
    • While using a Logitech G29 wheel, I experience severe understeer in slow speed corners. Not as bad in high speed and medium speed corners. Very noticeable at hairpin in Abu Dhabi for example. Even with the wheel cranked at all the way to the left or right at corners, I fail to make the corners without running wide. Have also noticed that my brakes do not slow me down as fast as they should.
  • Platform
    • PC
  • What version of the game you are using (Shown on the start screen in the bottom left corner of the screen) 
    • 1.10
  • Game-mode?
    • Career, time trial, multiplayer (probably all, just only use those ones)
  • We need to be able to make your problem happen internally so we can fix the issue. Can you make the problem happen again?
    • Yes.
  • How do you make the problem happen?
    • When ever I use the G29 wheel, I experience this understeer issue.
  • What troubleshooting have you attempted? Please always try to attempt to fix the issue 
    • Calibrating the wheel in Windows, changing setups in game, changing settings in G Hub, un and reinstalling game, verifying game files, updating Logitech drivers, deleting and reinstalling Logitech drivers.
  • What peripherals are you are using (gamepad, wheel make & model etc) 
    • Logitech G29 wheel
  • Any screenshots or video of the issue? If the video is long, please include a timestamp for when the issue appears.   
    • No

Share this post


Link to post
Share on other sites

Suggestion: When using the G series wheels in F1, you need to start with a DOR of 360 and tweak from there. The G series wheels are 900 DOR by default. Profiles for F1 2020 are advisable.

Suggestion: When using assists the braking assist is very difficult to understand with a wheel, I think it should be restricted to pad players.

Suggestion: The G series wheels use potentiometer pedals, please check for full registration against pedal travel in GHub. Modifying the brake pedal by removing the rubber is not advisable as the extra travel is not recorded. Also the potentiometers can become dirty, so please check and clean them (be careful when opening the pedals as the signal wire is clipped against the pedal body with not a lot of spare travel).

Suggestion: If cleaning the pedals is not enough, use the deadzone to eliminate a bit of 'flicker' (pedal registering without input) but bear in mind the pedal will need to be pressed further to start to register.

Suggestion: If the pedal does not meet full travel after cleaning / inspection you can use saturation to increase the input response from the same travel.

Suggestion: Linearity can be used to adjust how fast the pedal swings from not registered to full registration (adding Linearity means the initial response will be slower, allowing finer control on the first part of travel with smaller braking effort). It will also adjust the rate of response as the pedal approaches full travel.

None of the settings are mutually exclusive, you can combine all of them.

Check also the calibration settings in Windows Control Panel (this may only apply to those still using LGS - haven't owned a G wheel since GHub replaced LGS). 

Sometimes deleting the in-game custom control schemas, verifying the game files and deleting the hardware_settings_config.xml (on PC only) can rectify a misconfigured pedal. Using Geek Uninstaller, Logitech Driver Cleaner or USBDeView can remove software issues regarding USB detection. Always use the latest software drivers and update your PC.

Edited by steviejay69

Share this post


Link to post
Share on other sites
On 10/19/2020 at 6:47 AM, steviejay69 said:

Suggestion: When using the G series wheels in F1, you need to start with a DOR of 360 and tweak from there. The G series wheels are 900 DOR by default. Profiles for F1 2020 are advisable.

Suggestion: When using assists the braking assist is very difficult to understand with a wheel, I think it should be restricted to pad players.

Suggestion: The G series wheels use potentiometer pedals, please check for full registration against pedal travel in GHub. Modifying the brake pedal by removing the rubber is not advisable as the extra travel is not recorded. Also the potentiometers can become dirty, so please check and clean them (be careful when opening the pedals as the signal wire is clipped against the pedal body with not a lot of spare travel).

Suggestion: If cleaning the pedals is not enough, use the deadzone to eliminate a bit of 'flicker' (pedal registering without input) but bear in mind the pedal will need to be pressed further to start to register.

Suggestion: If the pedal does not meet full travel after cleaning / inspection you can use saturation to increase the input response from the same travel.

Suggestion: Linearity can be used to adjust how fast the pedal swings from not registered to full registration (adding Linearity means the initial response will be slower, allowing finer control on the first part of travel with smaller braking effort). It will also adjust the rate of response as the pedal approaches full travel.

None of the settings are mutually exclusive, you can combine all of them.

Check also the calibration settings in Windows Control Panel (this may only apply to those still using LGS - haven't owned a G wheel since GHub replaced LGS). 

Sometimes deleting the in-game custom control schemas, verifying the game files and deleting the hardware_settings_config.xml (on PC only) can rectify a misconfigured pedal. Using Geek Uninstaller, Logitech Driver Cleaner or USBDeView can remove software issues regarding USB detection. Always use the latest software drivers and update your PC.

Nothing changed, still experiencing problems. Also, I thought I made this a post not a reply?

Share this post


Link to post
Share on other sites

You can see for your self. Car is steering it self. FFB settings are all on highest setting. And the problem isn't car setup dependent, so this happens on any car setups.

 

https://youtu.be/posiSXqdjHs

Share this post


Link to post
Share on other sites

I have a very similar issue, but on a different wheel, i have a Fanatec F1 Esports wheel with the CSL Elite PS4 wheel base, whenever i am in game and i turn the wheel, no matter what car setup i have selected, it is super hard for me to actually turn the thing around the corner. It's just all around stiffer, i haven't messed with absolutely anything in the game settings, as well as in the settings that are integrated in the wheel itself, last time i played the game before i had this issue was probably on friday, and then when i started playing again, which was yesterday this issue occurred, i've also heard Tiametmarduk speak about some update to the in game force feedback in his latest career mode video, so it could be an update that codemasters have put out, despite me not downloading anything after update 1.13 - as an fyi the wheel was working perfectly when it came out so it can't be due to this

Share this post


Link to post
Share on other sites

Logitech G29 on F1 2020 with PS4. I have NO force feedback using custom wheel settings. It's my first wheel and I don't know anyone else with a wheel to compare, so I don't

know exactly what I should feel. During a recent online race someone said G29's are loud and they can usually hear them thru my mic in the game party. So I tried the wheel in

Gran Turismo (first time using the wheel in that game) and could immediately feel the force feedback so it has to be something in F1 2020. I will try with the default wheel setting today

and report back

Share this post


Link to post
Share on other sites
On 11/21/2020 at 12:47 PM, smonska said:

You can see for your self. Car is steering it self. FFB settings are all on highest setting. And the problem isn't car setup dependent, so this happens on any car setups.

 

https://youtu.be/posiSXqdjHs

find a fix?

Share this post


Link to post
Share on other sites

I have the same problem with my game and it is really weird, my friend got the same steering wheel and he has no problems. I tried to run the game on my laptop i use for school instead of my desktop I play games on and it worked perfectly fine. I tried a lot of things but nothing fixed the issue.

Share this post


Link to post
Share on other sites
12 hours ago, Roderiek said:

I have the same problem with my game and it is really weird, my friend got the same steering wheel and he has no problems. I tried to run the game on my laptop i use for school instead of my desktop I play games on and it worked perfectly fine. I tried a lot of things but nothing fixed the issue.

It seems that many people have this problem with codemasters games. You should make a new support request, the do not answer to this thred.

Share this post


Link to post
Share on other sites

Laptops and desktops use different USB power management. Unless the laptop is plugged in and set to maximum performance, it will not perform like the equivalent desktop. Thermal throttling is also a major problem on particularly non-gaming laptops.

Many newer laptops also come with USB C or USB 3.2 spec. The wheels prefer USB 2.0, it is electronically different and logically different. USB 3.0 is compatible with older devices, but it is not true compatibility. Hubs and adapters are a no-no. 

For troubleshooting on desktops, I recommend the use of a USB 2.0 port (all the wheels I have ever owned work at USB 1.1 speeds anyway).

I have owned Logitech, Thrustmaster and now Fanatec wheels.

The newer versatility of USB-C may just cause as many issues as the versatility it adds. 

Share this post


Link to post
Share on other sites
On 12/10/2020 at 11:42 AM, steviejay69 said:

Laptops and desktops use different USB power management. Unless the laptop is plugged in and set to maximum performance, it will not perform like the equivalent desktop. Thermal throttling is also a major problem on particularly non-gaming laptops.

Many newer laptops also come with USB C or USB 3.2 spec. The wheels prefer USB 2.0, it is electronically different and logically different. USB 3.0 is compatible with older devices, but it is not true compatibility. Hubs and adapters are a no-no. 

For troubleshooting on desktops, I recommend the use of a USB 2.0 port (all the wheels I have ever owned work at USB 1.1 speeds anyway).

I have owned Logitech, Thrustmaster and now Fanatec wheels.

The newer versatility of USB-C may just cause as many issues as the versatility it adds. 

I really do not think that the problem is in the usb connection, as Dirt Rally 1 and 2 (and all other games from different studios) are working perfectly fine with identical usb connection. My bet is that there is a haywyre peace of code (a bug) in the way codemasters make their fbb work. This exact problem is also on my friends drirt rally 1, but not in dirt rally 2 and f1. He has G29.

Share this post


Link to post
Share on other sites

There’s nothing wrong with the code.

You just stated that your Dirt Rally 1 and other games work with the exact same USB connection.

Your friend’s Dirt Rally doesn’t work.

The issue is in your configurations. They’re incorrect in different ways.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×