Jump to content
Sign in to follow this  

"Your connection is not private" Cannot access certain websites anymore.

Recommended Posts

First of all, I am running Windows 7 off a Dell Optiplex 790. Intel i7 CPU, with a GTX 960. Not sure any other hardware would be relevant to the problem.

Starting yesterday, I had this problem returning to my computer. Certain websites would restrict my access such as: Reddit, Facebook, YouTube. It would give me the error of "Your connection is not private" It gives the generic error message, with the code "NET::ERR_CERT_AUTHORITY_INVALID"

The weird part, is that it is only affecting one of my machines in my household, and that it only restricts certain sites. It seems to be mainly affecting websites with a SSL, but I can still access some sites that do, such as Netflix, IMDB, etc.

Well, I tried to Google some ideas, and so far what I came up with (and already tried), is making sure that the date/time on the machine is correct, clearing the SSL cache, resetting Chrome's setting (and, I'll also mention that Internet Explorer is the same way, so I don't think the problem lies solely with Chrome). I ran scans with Avast and MalwareBytes, which didn't pop anything. My called my ISP (Spectrum) to see if there was an issue which yielded no results (to no ones surprise). Lastly, I tried to rollback to a previous update with System Restore to several days ago, and it didn't do any good. I'm really baffled as to what is going on.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this