Jump to content Jump to content

Very Low Frame Rate on PC (below 20fps) GTX 650TI boost


tulloch100

Recommended Posts

I have an I5 3330 8GB Ram Gtx 650ti Boost and Win 7 64bit and I am getting some very low frame rates even on High Settings in the benchmark test I only got a max of 20fps in other games like assetto corsa and project cars I can get above 30fps 

I get good frame rates in the menus but as soon as I go to track and the games runs really slow and has a black screen for 10 seconds till the cut scene starts playing (even though I can here crofty)

I have seen other people post with the same card and they said there getting 40fps on high (as you can see https://www.youtube.com/watch?v=5tCAlvnPahg) so I dont know what im doing wrong  








Link to post
Share on other sites
I have an I5 3330 8GB Ram Gtx 650ti Boost and Win 7 64bit and I am getting some very low frame rates even on High Settings in the benchmark test I only got a max of 20fps in other games like assetto corsa and project cars I can get above 30fps 

I get good frame rates in the menus but as soon as I go to track and the games runs really slow and has a black screen for 10 seconds till the cut scene starts playing (even though I can here crofty)

I have seen other people post with the same card and they said there getting 40fps on high (as you can see https://www.youtube.com/watch?v=5tCAlvnPahg) so I dont know what im doing wrong  
is your problem solved?
Link to post
Share on other sites
sods said:
I have an I5 3330 8GB Ram Gtx 650ti Boost and Win 7 64bit and I am getting some very low frame rates even on High Settings in the benchmark test I only got a max of 20fps in other games like assetto corsa and project cars I can get above 30fps 

I get good frame rates in the menus but as soon as I go to track and the games runs really slow and has a black screen for 10 seconds till the cut scene starts playing (even though I can here crofty)

I have seen other people post with the same card and they said there getting 40fps on high (as you can see https://www.youtube.com/watch?v=5tCAlvnPahg) so I dont know what im doing wrong  
is your problem solved?
no i did update to new nivida drivers but still only got a max of 30fps and that does drop to 20 most of the timee
Link to post
Share on other sites

to be honest your card is outdated now should consider upgrading to something like a gtx 960 to run 1080p.

I run a gtx 560 ti 1gb at 1280x1024 and I get around  30 to 50 fps.

most settings on high and msaa no AF. 


Link to post
Share on other sites
Cap10 said:

to be honest your card is outdated now should consider upgrading to something like a gtx 960 to run 1080p.

I run a gtx 560 ti 1gb at 1280x1024 and I get around  30 to 50 fps.

most settings on high and msaa no AF. 


yeah I wan't to upgrade to a 970 but a little things called paying bills gets in the way so it will have to wait 

I did change the virtual sync and triple buffering settings and managed to get up to 31fps 



then I ran the game in 1366 x 768 and only got 15fps so I have no idea what is going on

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...