Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

Archived

This topic is now archived and is closed to further replies.

How to set up your Logitech Steering Wheel in F1 2015

Recommended Posts

I have spent a lot of time setting up my wheel or F12015 and found that the in game tools are really not up to the task or ATM at least not playing ball.

Here I will be explaining how to get your wheel performing almost as you want it to. if you follow these steps then it should save a lot of time and injury by not banging you head against a brick wall trying.

1. Connect up your wheel and start the game.
2. Hopefully the wheel will be detected and you can navigate the menus 
3. In the MY F1>settings> custom controls>Driving Controls...select the INPUT DEVICE AS "Custom" option.
4. Manually map each function to your wheel, for examp if your brake pedal is already mapped to breakin then you must Re assign the axis, if you run out of buttons map them to your keyboard to be safe.
5. Leave all the advanced settings to default for now.
6. once everything is mapped come out and go to track to see if everything is working as you had assigned them. you will probably find you can NOT drive in a straight line but check them none the less.
7. If you want to make some changes, do so and then exit the game properly.
8. Open your Logitech profiler.
9. Create a new profile for 2015. >Profile>New.
10. Click on "steering wheel" select "Axis properties" and bring the Sensitivity bar right down to 10%
11. Click on the Option tab and then click on "Global device settings"
12. In that window I increased the , spring effect and damper effect strength to 150 (Max) and check the Enable Centring spring in FF games
13. uncheck report the box, combined pedals and set the degree of rotation to 180
14. Check the box, Allow games to adjust settings.
15. Click on the option tab again and select Global profiler settings select Apply persistent profile and choose the profile you have created for 2015.



After you have changed the above its then all about fine tuning.. reduce the Centring spring if the wheel is too heavy and so on.

Then look into further fine tuning by using the in game Advanced settings if needed.

I really hope this helps you out. And also hope that the codies look into creating a fix for this.

UPDATE....

After last patch any settings in the advanced wheel settings i have to move the setting up one and then down one, everytime i open the game.


Salute

Sods


hope to see you in game.

Share this post


Link to post
Share on other sites
Thanks Sods i had so much hassle trying to get this to work tanks for your post. BTW do you have arms the size of tree trunks because the wheel is heave and i had loads of  force feed back from my wheel. i reduced the spring effect to 120 it suited me better. i can actually now drive in a straight line and making the driving experience fun.

Share this post


Link to post
Share on other sites
Tip number 10 is the best I got since the game was deployed!
Just setting the sensitivity to 10% solved my problems with Logitech MOMO Racing wheel. I can drive in a straight line! 

Share this post


Link to post
Share on other sites
john101 said:
Thanks Sods i had so much hassle trying to get this to work tanks for your post. BTW do you have arms the size of tree trunks because the wheel is heave and i had loads of  force feed back from my wheel. i reduced the spring effect to 120 it suited me better. i can actually now drive in a straight line and making the driving experience fun.


Hi John,
Yes i do have rather large arms LOL

Share this post


Link to post
Share on other sites
This may work for g27 but not for g29. Logitech had a preschooler dev the profiler so adjusting center spring, spring effect and dampers, not any more. I have remapped the buttons on g29 and wheel weight came back for a very brief moment then back out it went. CODIES NEEDS TO FIX THEIR GAME PROPERLY! 

Share this post


Link to post
Share on other sites
This may work for g27 but not for g29. Logitech had a preschooler dev the profiler so adjusting center spring, spring effect and dampers, not any more. I have remapped the buttons on g29 and wheel weight came back for a very brief moment then back out it went. CODIES NEEDS TO FIX THEIR GAME PROPERLY! 

Hi Shablam420, try...

14. UN-Check the box, Allow games to adjust settings

I know its a game issue and not the wheel/driver/profile. but like an expecting father we wait for fixes and wait and wait and........

Share this post


Link to post
Share on other sites
Hi guys

Just thought id add some info that might help someone,  I have a g27 and did exactly what sods said,  when I tried playing  the game the throttle and brake were combined even though I had unchecked the combined pedal box, I resolved this issue by not applying a persistent "f1 2015" profile, it now works much better and the ffb is quite close to how I had it in f1 2014, still fine tuning but its so much better, thanks sods, awesome work.

Share this post


Link to post
Share on other sites
YUSUFH said:
Hi guys

Just thought id add some info that might help someone,  I have a g27 and did exactly what sods said,  when I tried playing  the game the throttle and brake were combined even though I had unchecked the combined pedal box, I resolved this issue by not applying a persistent "f1 2015" profile, it now works much better and the ffb is quite close to how I had it in f1 2014, still fine tuning but its so much better, thanks sods, awesome work.
Dear Yusufh

I also did exactly what Sods said and also have the same combined pedals problem.
When I change the Driving Controls Input Device  from Custom to Logitech G27, the pedals works fine, but the brake pedal is the middle one.
I'd like to change the brake to the left pedal, the clutch one.
When I do that by customizing the Driving controls, the pedals are combined.
I tried to unchecked the combine pedal box and also NOT applying a persistent f1 2015 profile - nothing changed.

Please help me with this problem. The Sods settings seem to be very good, driving is fun, but there is stil a one thing missing to be perfect:
Just to have the brake under the clutch pedal.

Does anybody knows how to do it ?

Thank you.

Share this post


Link to post
Share on other sites

×