Jump to content

Archived

This topic is now archived and is closed to further replies.

I can't get more than 49 fps in Dirt Rally, please help.

Recommended Posts

Hi there, I am having a strange issue. If I use vsync in game it says my options are 29 or 49 fps. I get the same fps limit using nvidia control panel but if I turn vsync off in control panel and in game I then get 120-130 fps in game. I am using an LG 3440x1440 Screen which I have no problem running other games at 60 FPS on. I am also using displayport 1.2 so it shouldn't be an issue with that. I am using 2x 980's as GPU's which can push the game to 130 fps as stated above, this just seems overkill to me as my monitor's max refresh rate is 60. Any suggestions? I would obviously like to have this running @ 60fps  for a smooth non tearing experience.

System spec is:
5820k @ 4.4
16 GB @ 3000
2x 980 using 350.12 Drivers

Share this post


Link to post
Share on other sites
I have read this and I am not sure how it is relevant to my problem. I am using two nvidia 980 cards. My monitors native refresh rate is 60hz, when I run Dirt rally with either vsync on in the game settings or switched on in Nvidia control panels the two options I get for refresh rate in the Dirt Rally graphics menu are either 29 hz or 49 hz. There is no option for 60. However if I turn vsync off (as in off in game and off in Nvidia control panel I get 130 fps which shows my setup is totally capable of running it @ 60fps. I want to lock the game at 60 fps which is normally very easily done using a games in built vsync or Nvidia's adaptive vsync via Nvidia control panel. How ever as stated above with either of these options enabled I am limited to 29 or 49 fps in the Dirt rally menu. Every single other game I own works fine @ 60 fps and works fine with either in game vsync or adaptive vsync. Can anyone help me work out what is going on? 

Share this post


Link to post
Share on other sites
Ah right, my bad I misread it as 290's :/

1, update your Nvidia drivers, we're on 353.30 at the moment.
2, go to your Nvidia control panel.
3, select 'Change resolution' from the 'Display' options.
4, 'Refresh Rate', set it to 60hz

That'll lock your cards to 60fps to match your monitor.

And don't forget to turn V-Sync off in-game.

Share this post


Link to post
Share on other sites
Hi there, thanks for your reply. My monitor is already set to 60hz. I am only using the slightly older driver as I get a lot of "display driver has stopped responding and recovered"errors whith any driver past the one I am using. This is a known issue with Nvidia who are supposedly working on it. However it is a NOT a hardware issue as everything is perfectly stable with the drivers I am currently using. Here is a screen of my Nvidia control panel. 


Share this post


Link to post
Share on other sites
There is also another way, using Nvidia Inspector.

http://www.guru3d.com/files-details/nvidia-inspector-download.html

https://www.youtube.com/watch?v=lKgC3CdZYh0

There was a problem with DiRT Rally and the older Nvidia drivers, you can tell if your driver is pre fix or after fix by going to 3D Settings and looking for the DiRT Rally folder. If it is called DiRT Rally (drt.exe), you have the fixed drivers, if it say DiRT4 (drt.exe) you have the older ones and that maybe your problem. Here's what it looks like in my 3D Settings








Share this post


Link to post
Share on other sites
Ah ok, well it seems I have the problem drivers as mine says Dirt 4. I will try upgrading my drivers and see if that helps, hopefully the latest version will not cause me the same TDR problem the two driver versions after mine caused. Thank you for your help, I will let you know if it still is a problem. Obviously if I get the TDR problem back with the drivers that is nothing to do with you and I will again ask Nvidia tech support what to do about that. I normally keep my drivers up to date but the TDR problem has prevented me from doing so.

Share this post


Link to post
Share on other sites
We had a lot of people on the forum with the higher spec GTX's complaining about quite a few problems, frame stuttering and SLI problems a while back. The Nividia driver update and Nvidia Inspector seems to have fixed most peoples problems.

Good luck :)

Share this post


Link to post
Share on other sites
Well I now can run the game properly with the newest drivers and get a solid 60 fps. However the TDR problem has returned, I get the "display driver has stopped working and successfully recovered" message even just browsing the web so I will go back to Nvidia and see what they have to say, thanks again for your help.

Share this post


Link to post
Share on other sites
I think I finally found a solution, Nvidia have released a hotfix driver which allows me to play at 60fps without the TDR's. Anyone else experiencing this problem try this driver https://forums.geforce.com/default/topic/853781/announcing-geforce-hotfix-driver-353-49-released-7-8-15-/ .

Share this post


Link to post
Share on other sites

×