Jump to content Jump to content

Lag Spike Issue


Elfster85

Recommended Posts

Hi,

I have to make a new post for the issue as the previous one was marked as complete and no one would reply to it. The issue is still the same although there is a partial fix:

  • A detailed description of the issue. Please include any error codes here: Lag spikes in all game modes. FPS is fine usually but then sudden freeze and unfreeze. Tried lowering graphics and no change. The game used to be fine but ever since the last update this started happening Code: AAXG-RBDC-JPBH-PBJE
  • Platform: PC (Graphics card is GTX 1050Ti)
  • What version of the game you are using (Shown on the start screen in the bottom left corner of the screen): 1.13
  • Game-mode? All 
  • We need to be able to make your problem happen internally so we can fix the issue. Can you make the problem happen again? 
  • How do you make the problem happen?
  • What troubleshooting have you attempted? Please always try to attempt to fix the issue. I've tried changing priority in task manager to high, used game booster, reinstalled game on SSD, lowered graphics, tried launching with Dx11 (which used to solve the issue back in September) 
  • What peripherals are you are using (gamepad, wheel make & model etc): Wheel is Logitech DFGT, pedals are Fanatec CSL Elite (no loadcell)
  • Any screenshots or video of the issue? If the video is long, please include a timestamp for when the issue appears. Video attached

 

One solution I found on the forums is deleting the hardware_settings_config file which solves the issue. However, the issue comes back if I restart the game so I have to delete the file every time I play the game. The other solution @BarryBL suggested on the previous post was to delete the custom controller settings, verify the integrity of files and reboot. Although it does solve the issue the first time I launch the game, it returns if I restart the game a second time or play the next day. 

Would really appreciate help on this!

Previous post: https://forums.codemasters.com/topic/66181-pc-wheel-lag-spikes-every-lap/?tab=comments#comment-582444

Thanks!

 

Link to comment
Share on other sites

On 12/9/2020 at 4:59 PM, steviejay69 said:

308 UEFI

Disconnect the Wacom tablet.

Please also remove the audio dongle from the G430 headset and plug into the audio jacks of the sound card.

Delete the hardware_settings_config.xml and re-launch the game.

Thanks for the suggestion @steviejay69. The Wacom tablet was never connected but I uninstalled the drivers for it. Unplugging the headset dongle seems to have solved the issue. However, I do need to use the headphones with the dongle as my laptop only has 1 audio input, is there any way I could solve the issue and still use the dongle? 

Link to comment
Share on other sites

1 hour ago, Elfster85 said:

Thanks for the suggestion @steviejay69. The Wacom tablet was never connected but I uninstalled the drivers for it. Unplugging the headset dongle seems to have solved the issue. However, I do need to use the headphones with the dongle as my laptop only has 1 audio input, is there any way I could solve the issue and still use the dongle? 

Use GHub to try update the headset firmware (the dongle - it might already have been, think my G430 had a 'weak mic' update). That's all I can suggest but I'm tagging @LogiUK as I sold my Logitechs and bought Kingston HyperCloud Xs because of the silly dongle. And @BarryBL to see if the devs can sort this. It's probably Windows audio that's the issue but if at least these headsets are part of the dev kit it would stop a lot of forum issues.

And improve customer perception of the game and Logitech compatibility.

Link to comment
Share on other sites

  • 1 month later...
  • Administrator

You could try copying or dropping the settings in your Advanced setup (Graphics) as well. Turning off 'Asynchronous Compute' will help too. Turning down/off things like Skidmarks and SSRT Shadows will help too.

20210120164216_1.jpg

Link to comment
Share on other sites

Ok I’ll try do your changes. I just tried scaling my display from 125% to 100% and it seems to have removed the lag (restarted laptop and it’s solved). However, my this isn’t really viable for me as everything apart from the game looks incredibly small...

Link to comment
Share on other sites

I reverted back to the original 125% scaling and the lag spikes are not there. I've got no clue why it's suddenly solved as scaling is the only thing I've been changing... 

So I guess the issue has solved itself. Thanks for helping out though. I'll post here if something changes.  

Link to comment
Share on other sites

I really don't know what's going on because I just went onto the game and the issue is there... I tried your suggestions @BarryBL but there's no difference. I'll try scaling again in a bit. The lag spike is less frequent and smaller in time but it still happens at least once a lap. 

image.thumb.png.52c8906659c40d9d6caa238650b1c9eb.png

Link to comment
Share on other sites

3 hours ago, Elfster85 said:

I really don't know what's going on because I just went onto the game and the issue is there... I tried your suggestions @BarryBL but there's no difference. I'll try scaling again in a bit. The lag spike is less frequent and smaller in time but it still happens at least once a lap. 

image.thumb.png.52c8906659c40d9d6caa238650b1c9eb.png

DDU the display driver. Restart without internet and reinstall your latest display driver without customisation.

Delete the hardware_settings_config.xml

Start the game after verifying Steam files and go into the menu and select the Low preset. Set the framerate cap to 69FPS.

Enable the Steam FPS counter and see if it maxes out (69) if it does, up the preset to Medium and restart the game. When you are hitting around 60FPS during regular gameplay then you have found the right setting. Let me know how the lag is then.

Link to comment
Share on other sites

43 minutes ago, steviejay69 said:

DDU the display driver. Restart without internet and reinstall your latest display driver without customisation.

Delete the hardware_settings_config.xml

Start the game after verifying Steam files and go into the menu and select the Low preset. Set the framerate cap to 69FPS.

Enable the Steam FPS counter and see if it maxes out (69) if it does, up the preset to Medium and restart the game. When you are hitting around 60FPS during regular gameplay then you have found the right setting. Let me know how the lag is then.

Where can I find the display driver to install it?

Link to comment
Share on other sites

1 hour ago, Elfster85 said:

Where can I find the display driver to install it?

461.09

Actually, seeing as you have a hybrid laptop it might be interesting to see if the issue goes away if the desktop driver is also WDDM 2.7.

IDSA

https://downloadmirror.intel.com/30148/a08/igfx_win10_100.9168.exe (again, you may need to uninstall your existing driver and install without internet)

Link to comment
Share on other sites

3 hours ago, steviejay69 said:

DDU the display driver. Restart without internet and reinstall your latest display driver without customisation.

Delete the hardware_settings_config.xml

Start the game after verifying Steam files and go into the menu and select the Low preset. Set the framerate cap to 69FPS.

Enable the Steam FPS counter and see if it maxes out (69) if it does, up the preset to Medium and restart the game. When you are hitting around 60FPS during regular gameplay then you have found the right setting. Let me know how the lag is then.

Just finished doing all the steps and the lag spike issue was present at low graphics

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...