Jump to content Jump to content

Problems connecting to Racenet in GRID 2


Recommended Posts

Hmmm, yeah, Racenet not available for Global Challenge for past ten minutes, no sessions in Online. So, racing not possible.

Maybe some other time. Grid Autosport and DLC are not of interest to me. I have no reason to believe they'll work any better... And I have a dis-inclination to throw good money after bad...

This would be a perfect example of why it's a good idea to allow me to create a race with just me against AIs. I'd start, other people would discover it, and could join in. Right now, I check, find nothing, and leave.

This is a reason why allowing newcomers to join an in-progress race is a good thing - less waiting, more driving. Someone else looking for a race could just join mine, without having to wait 10 minutes for my eight laps to finish.

Link to post
Share on other sites

What's really frustrating is when you have a "private war" going, let's say with your brother, :-) and he gets good scores that I then can't beat because I can never get on again.

Or, if I beat, and he can not because he can't get on again. Where's the fun in winning by default? 

We don't count those. Those don't reflect on us, they reflect on Codemasters / Racenet..

Any suggestions? I was looking forward to an hour of tearing up a track...

Oh, and by the way, just leaving Grid2 running, just idling on the welcome screen, costs my machine an extra 150-200 watts, as measured with a Kill-A-Watt meter.

Link to post
Share on other sites
  • 2 weeks later...

Hi all. This Racenet unavailable crap has been going on for a very long time now and has never been "fixed" so to speak. I have had Grid 2 since its release and I believe sometime after one of the earlier game updates this problem began. Well it did for me anyway. I have multiple profiles used with the game and play it on PS3 [Disc version] and PC [downloaded via steam] and have actively taken part in global challenges on a weekly basis. The problem is a real disappointment as I personally have had days at a time being unable to connect to Racenet ingame, to participate in global challenges. I do have Autosport and the original Grid also but the appeal with Grid 2 is with the global challenges as the online playlist modes are nothing short of a ram-fest and sooks who accuse anyone who beats them of cheating and tries voting them out of the lobby which simply makes others leave emptying a race of 12 people to something like 3 to 5 and the out of those are the ones sooking and making silly accusations to  anyone who beats them.

A lot of the time simply reloading/relaunching the game will see you be able to connect though its not a guaranteed fix. Please Codemasters, can you actually rectify the issue affecting all platforms and version of the game, or at least give us some feedback on whats going on in any attempts to fix it. It is something you kind of expect as a customer, after paying good money for these games and all the DLC sold making them rather expensive tittles in the end. Marketed and sold to us with the belief we can go against mates and the rest of the world through Racenet etc. Your games are mostly great to play and all that and ive been a fan and purchasing them long before Grid 2, but the lack of support is a big let down.

Link to post
Share on other sites
  • 2 weeks later...
  • 2 months later...
  • 10 months later...
  • 5 months later...
  • 11 months later...
  • 1 month later...
  • 1 year later...
  • 2 years later...

still not working, "unable to establish secure communication with racenet " when trying to launch racenet out of the game. I got GRID 2 via Steam. Maybe there is some issue with the certificate via steam browser ? On the other side, i can successfully connect via Firefox Browser to the racenet Homepage with https. I also resetted my firewall profile in hope of an automated hint for setting up a firewall rule. But no reaction. I try again and let you know if something works for me.

Link to post
Share on other sites
9 hours ago, krrrrzzzzz said:

still not working, "unable to establish secure communication with racenet " when trying to launch racenet out of the game. I got GRID 2 via Steam. Maybe there is some issue with the certificate via steam browser ? On the other side, i can successfully connect via Firefox Browser to the racenet Homepage with https. I also resetted my firewall profile in hope of an automated hint for setting up a firewall rule. But no reaction. I try again and let you know if something works for me.

tested several configurations with or without firewall etc but nothing worked. I am also able to connect racenet homepage via steam browser. The only possibility left is my internet router. I'll check this tomorrow.

Link to post
Share on other sites

enabling tls 1.1 and tls 1.2 , discribed in this post, may help.

https://docs.microsoft.com/en-us/windows-server/security/tls/tls-registry-settings#tls-dtls-and-ssl-protocol-version-settings

that solved my problem connecting from windows 7 64 bit to racenet ingame via steam grid 2.

local firewall or router settings weren't necessary.

other thing i did btw: setting the dynamic ports used by windows 7 to higher range, like e.g. from udp/tcp 49000 to 65000.

https://docs.microsoft.com/en-us/troubleshoot/windows-server/networking/default-dynamic-port-range-tcpip-chang

dont know if this is necessary.

Edited by krrrrzzzzz
forgot to mention something
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...