Jump to content Jump to content

No in game sound over HDMI


lock2nl

Recommended Posts

 

 

1.       A description of the issue. Please include any error codes here.

After the issues with the servers a couple of weeks ago the latest version of F12020 was introduced. Unfortunately, It came with the loss of my sound on my gaming TV, which is connected by ultra speed HDMI cable to my NUC. The sound is gone directly after starting up the game.

Sound is fine on the TV with anything, but the game. Also, the head phones work fine (realtek driver). No in game error codes

2.       What version of the game you are using (Shown on the start screen in the bottom left corner of the screen)

No in game error codes

1.14

3.       Game-mode?

Mostly Solo time trial

4.       Are you able to recreate the issue? If so, please include recreation steps on how you encountered this issue.

It is there constantly.

5.       How often do you see this problem? Is it the only time or does it always happen?

See 4.

6.       Have you tried any troubleshooting? We recommend the steps here as a starting point for any issues. Please let us know what troubleshooting methods you have tried while creating this post.

Uninstalling the intel display audio driver. Multiple times either bij deleting drivers and let Windows solve it it at reboot, or by using the latest Intel driver set:gfx-win10-27.20.100.8681_BE

7.       Any accessories you are using (gamepad, wheel etc)

Thrustmaster T150 pro

8.       Any screenshots or video of the issue? If the video is long, please include a timestamp for when the issue appears.

Is this usefull at at all?

Link to comment
Share on other sites

Set the default sound source in Windows. 

Bear in mind that the installation of new Graphics drivers can upset this and you should check before starting the game. I don't think there's mileage in removing just the Display Audio driver, it's integrated into the driver set and the IDSA will keep it updated.

Delete the hardware_settings_config.xml before launching once the default is set.

Link to comment
Share on other sites

Hi Stevie.

The default sound source is display audio driver. That is not the issue.

I've made some steps in the mean time.

I also posted the issue on the intel forum and I received the following response:

Thank you for posting on the Intel® communities.   

I would like to let you know that Intel has already identified this issue, and it seems to come from the game(s) code. The reason why this issue does not occur on previous drivers is due to a code bug. Intel has been reaching out to most developers so they can look into this and fix their code. 

A workaround you can try is making sure that the game resolution matches the one set in Windows (e.g. in the game settings set 1920x1080 if that is the one you have in Windows). https://www.intel.com/content/www/us/en/support/articles/000035049/intel-nuc/intel-nuc-kits.html  

I tested the option to lower the resolution of the TV to the in game resolution (1600*900) but that did not work. However, if I set the TV to 4k 3860 wide and I do the same thing in the game and use full screen windowed mode, than the sound comes back.

So, while they are working on it, I simply start the game with these settings. After start up I go into the graphics menu and revert to 1600*900. I can play the game with sound as a result. Before I close off, I put the resolution back to 4k. 

Link to comment
Share on other sites

15 hours ago, lock2nl said:

Hi Stevie.

The default sound source is display audio driver. That is not the issue.

I've made some steps in the mean time.

I also posted the issue on the intel forum and I received the following response:

Thank you for posting on the Intel® communities.   

I would like to let you know that Intel has already identified this issue, and it seems to come from the game(s) code. The reason why this issue does not occur on previous drivers is due to a code bug. Intel has been reaching out to most developers so they can look into this and fix their code. 

A workaround you can try is making sure that the game resolution matches the one set in Windows (e.g. in the game settings set 1920x1080 if that is the one you have in Windows). https://www.intel.com/content/www/us/en/support/articles/000035049/intel-nuc/intel-nuc-kits.html  

I tested the option to lower the resolution of the TV to the in game resolution (1600*900) but that did not work. However, if I set the TV to 4k 3860 wide and I do the same thing in the game and use full screen windowed mode, than the sound comes back.

So, while they are working on it, I simply start the game with these settings. After start up I go into the graphics menu and revert to 1600*900. I can play the game with sound as a result. Before I close off, I put the resolution back to 4k. 

This is good. It might explain the Nvidia crashes also when the resolution / refresh is off between game and desktop.

@BarryBL

Link to comment
Share on other sites

  • 1 month later...

Intel has updated their drivers because it contained a bug. The changed drivers causes the above issue. 

Intel is in contact with the developers to solve the issue. But Codemasters seemingly doesn't do anything to change it. So when is this going to be picked up?

Link to comment
Share on other sites

On 1/23/2021 at 2:27 PM, lock2nl said:

Intel has updated their drivers because it contained a bug. The changed drivers causes the above issue. 

Intel is in contact with the developers to solve the issue. But Codemasters seemingly doesn't do anything to change it. So when is this going to be picked up?

If the driver caused the bug it would be solved.

If the driver is fixed. 

The Intel driver before this one didn't detect the correct refresh rates on my laptop panel. So I wouldn't exactly say the Intel drivers are the most reliable. Likewise the Nvidia drivers, lots of Nvidia users have issues and immediately blame Codemasters. Nvidia write garbage and frequently. So I wouldn't hold out hope for Intel. I've tried with issues I've had with them that I've proved, they are very slow to acknowledge and fix issues. 

Link to comment
Share on other sites

In this case, Intel has acknowledged the issue. They actually described it on their website and used my workaround in the description.

It would be nice to know from Codemasters whether they are actually in contact with Intel about this. Anyone from Codemaster .....???

Link to comment
Share on other sites

  • 4 weeks later...

Hi Guys. I just noticed this same issue this weekend and i freak out. 

I'll get an optical cable and avoid the crappy Intel HDMI audio manager. It really sucks and gave a lot of headaches untill i find this thread.

I have tried everything you mentioned before, and nothing solved the issue. 

thanks again

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...