Jump to content
Bug Reporting - PLEASE FOLLOW RULES AND COMPLETE REPORTS Read more... ×
F1 2020 | 1.15 PATCH NOW LIVE Read more... ×

[F1 2020] [MULTIPLAYER] [1.14] Freeze and crash during race

Recommended Posts

Hello,

  • A detailed description of the issue : The game is freeze during almost every multiplayer race. This happens usually in the second half of the race (ranked 25%). The screen freeze, the force feedback on wheel keeps pulling one direction, then after a few seconds EGO dumper pops up (see attached picture)DxDiag.txt.  After sending the report, the game closing itself. Moreover the game considers this crashes as if I willingly abadon the race, and reduces my stats. The bug happens is solo mode, but not so ferquently. 
    I attached the egodumper.log, in that you can see that the game crashes every day at least once, since I bought it.
  • Platform: PC (Ryzen5 3600, NVidia GTX 1660 6Gb; 16 GB RAM) All drivers are up to date. Game files verified several times via Steam. DxDiag attached.
  • Version: 1.14
  • Ranked (never tried unranked or league so far)
  • Connection: wired (1 Gbps)
  • Amount of players: it varies from 5 to 20
  • Were you the host? I have no idea, I played only ranked so far.
  • Did this issue happens for everyone in the session, just some people or just yourself? What did they see?
    I have no idea if this happens the other players in the session.. Ranked.. If I restart the game instatly never puts me back in the same session.
  • We need to be able to make your problem happen internally so we can fix the issue. Can you make the problem happen again?
    Yes, based on my experiences so far, I'm sure that it will happen at least every second ranked race.
  • How do you make the problem happen? Simply playing...
  • Report code: XRTK-SXRE-HTKC-CEEE image.png.4a72474c1b98fe2e5b7444ab73f40b9d.png
    RHHA-EXSR-TSXX-BDVGimage.png.0880ae1bc3048bf279a6540336c9a8f2.png 
  • I have no video of the issue, but I'm about to make one. (I'll update this post as soon as I have)
    UPDATE: Video of the BUG: Short version    Full version (full version starts after I joined the current session. This represents the usual behaviour of the game.)

Is there any suggestion to make these crashes disappear? If you need any further information, let me know.

 

Screenshot.png

 

DxDiag.txt

egodumper.log

Edited by Sylraw
Title modification
  • Like 2

Share this post


Link to post
Share on other sites

Trired to increase the size of the pagefile to 10 GB (altough 16 GB RAM should be enough), it does not solved the problem. Here is the next report code: image.png.fa55dbbb644eaeafba1a230e86fa7276.png  egodumper.log

FYI: If the pagefile is set to 1024 Mb then the egodumper.exe is unable to start, therefore the game crashes at the start.

 

  • Like 1

Share this post


Link to post
Share on other sites

I have the same problem, but sometimes the game closes without egodumper.  
As hardware I have the fanatec podium dd1 en formula v2 wheel. 

Share this post


Link to post
Share on other sites

Are you running on wired or wireless connection @Sylraw? Does this also happen to you in other game modes, like MyTeam or Grand Prix for example. Adding your in-game graphical settings  will help too.

Share this post


Link to post
Share on other sites
26 minutes ago, BarryBL said:

Are you running on wired or wireless connection @Sylraw? Does this also happen to you in other game modes, like MyTeam or Grand Prix for example. Adding your in-game graphical settings  will help too.

Running on wired connection. Only happens in multiplayer mode. Never happened in other modes yet. 

graphical settings: hardware_settings_info.xml

hardware_settings_config.xml

Benchmark: Benchmark_2020-12-30_at_22-54-21.xml

Benchmark_2020-12-30_at_22-54-21_frametimes.csv

image.thumb.png.e0b4837450c024db9244b01f96cc0113.png

image.png.7e7fc3c8eaad36bd6e9c1ab5cc1abf0a.png

+ Asyncronous compute --> ON

Edited by Sylraw
Added benchmark files

Share this post


Link to post
Share on other sites
16 minutes ago, steviejay69 said:

Post the board model please, it's a MSI B450 based effort.

My board is a MSI B450-A ProMax.

Now that you mentioned, I checked and see that there is an updated Bios and drivers available.. I'll install them and see what happens 🙂

  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, Sylraw said:

My board is a MSI B450-A ProMax.

Now that you mentioned, I checked and see that there is an updated Bios and drivers available.. I'll install them and see what happens 🙂

AGESA updates can have a big bearing.

Share this post


Link to post
Share on other sites

460.89 is a WDDM 2.7 driver with W10 2004 or 20H2, maybe try DDU to sort out any driver related issues and delete the hardware_settings_config.xml then try the update to sort out Windows?

Share this post


Link to post
Share on other sites
On 12/31/2020 at 8:38 AM, Sylraw said:

My board is a MSI B450-A ProMax.

Now that you mentioned, I checked and see that there is an updated Bios and drivers available.. I'll install them and see what happens 🙂

Okay, so since I updated the Bios (to version 7B86vMB) and the chipset driver ( to v 2.10.26.336) of the board, I played some hours and there was no lag freeze or crash. I hope it stays that way, but I'd play a couple more hours before I say the problem is gone for sure.

Share this post


Link to post
Share on other sites

The freeze and crash happened again. report code: image.png.3ef8b06925b8a7b650e8b1e6a9b5d2b7.png

So bios and chipset driver update alone not helped. Now I'll try to update windows to 20H2 + DDU as suggested.

Share this post


Link to post
Share on other sites
On 12/31/2020 at 7:31 PM, steviejay69 said:

460.89 is a WDDM 2.7 driver with W10 2004 or 20H2, maybe try DDU to sort out any driver related issues and delete the hardware_settings_config.xml then try the update to sort out Windows?

All of above was done, but problem still persist. Difference only that this time the crash happened right after the checkered flag. Report code: image.png.01b04ece95f850bc11f0524cff6302a4.png 

egodumper.log

Share this post


Link to post
Share on other sites

Try turning down Vehicle Reflections and Skimarks @Sylraw ( was a old troubleshooting issue in 2019) and turning off Asynchronous Compute. Do you experience this issue if you are the host of the lobby, only when joining a lobby in session, or both?

Thanks for the report codes. I'll get these sent over to the Network team today

Share this post


Link to post
Share on other sites
7 hours ago, BarryBL said:

Try turning down Vehicle Reflections and Skimarks @Sylraw ( was a old troubleshooting issue in 2019) and turning off Asynchronous Compute. Do you experience this issue if you are the host of the lobby, only when joining a lobby in session, or both?

Thanks for the report codes. I'll get these sent over to the Network team today

Most of the time I join an existing lobby. Now I tried with the suggested settings... joined the lobby (ranked 25% Italy) -> same freeze and crash during qualy (last turn). This was the first time that the crash happened during the qualification. Report code: image.png.844b9c5d05191b6e6222ec4fb61fad17.png   

Share this post


Link to post
Share on other sites

If you are running a Firewall, ensure it is set to allow the game to communicate on the following ports for both inbound and outbound traffic: TCP and UDP port 3074 as another suggestion. I suspect there is possibly a connection issue somewhere here.

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, BarryBL said:

If you are running a Firewall, ensure it is set to allow the game to communicate on the following ports for both inbound and outbound traffic: TCP and UDP port 3074 as another suggestion. I suspect there is possibly a connection issue somewhere here.

I have a GData firewall, but for this attempt, I turned it off completely. I also checked the router/modem, there isn't any kind of filtering (firewall or else) on it. The game lasted nearly 2 lap on race (ranked 25% Russia) This time probably I was the host since there was nobody in the lobby for like 10-15 sec, only me.

Report code: image.png.1faa3a6b45f16b28e96ca418bf922474.png  

egodumper.log

If there is any further method to diagnose/debug/trace etc. apart from egodumper + report code, let me know. Now I'm kinda curious of what is the cause. Apart of getting a little frustrated 😅

UPDATE: tried once more, this time the game simply closed itself without egodumper, during the 2nd race (ranked 25%). Report code: image.png.d637f76c18565ab1b018be59fbd787b4.png 

Edited by Sylraw

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Sylraw said:

I have a GData firewall, but for this attempt, I turned it off completely. I also checked the router/modem, there isn't any kind of filtering (firewall or else) on it. The game lasted nearly 2 lap on race (ranked 25% Russia) This time probably I was the host since there was nobody in the lobby for like 10-15 sec, only me.

Report code: image.png.1faa3a6b45f16b28e96ca418bf922474.png  

egodumper.log

If there is any further method to diagnose/debug/trace etc. apart from egodumper + report code, let me know. Now I'm kinda curious of what is the cause. Apart of getting a little frustrated 😅

UPDATE: tried once more, this time the game simply closed itself without egodumper, during the 2nd race (ranked 25%). Report code: image.png.d637f76c18565ab1b018be59fbd787b4.png 

I would advise you use nothing more than the Windows firewall and have your modem router in the default state. If you uninstall using Geek Uninstaller

Please factory reset it after applying any available firmware updates. Then configure only what you require to connect to your ISP.

Edited by steviejay69

Share this post


Link to post
Share on other sites
17 minutes ago, steviejay69 said:

I would advise you use nothing more than the Windows firewall and have your modem router in the default state.

Please factory reset it after applying any available firmware updates. Then configure only what you require to connect to your ISP.

The router/modem is in it's original state, as the ISP provided me. For the last two attempt, I turned off the firewall on the PC completely, as I wrote earlier.

Anyway in my opinion, a network error shouldn't trigger a program crash.

Other question: Is there any way to rejoin the online race after the game crashed? In F1 2018 if the race was still on and I restarted the game after a crash it puts me back to the race. In F1 2020 never puts me back the same session.

Share this post


Link to post
Share on other sites
Posted (edited)
11 minutes ago, Sylraw said:

The router/modem is in it's original state, as the ISP provided me. For the last two attempt, I turned off the firewall on the PC completely, as I wrote earlier.

Anyway in my opinion, a network error shouldn't trigger a program crash.

Other question: Is there any way to rejoin the online race after the game crashed? In F1 2018 if the race was still on and I restarted the game after a crash it puts me back to the race. In F1 2020 never puts me back the same session.

To answer your question, yes the game allows rejoin to an online race exactly like the previous games that supported it.

I will qualify that you need either an open session, a friends only session (and join on a player that is in session) or an invite to an invite only session.

A network error can trigger a program crash if the network driver or the software firewall is faulty.

Edited by steviejay69
Qualification
  • Agree 1

Share this post


Link to post
Share on other sites
6 minutes ago, steviejay69 said:

To answer your question, yes the game allows rejoin to an online race exactly like the previous games that supported it.

Well, than I have another problem 😕 😕 but since the rule is 1 bug / topic, stick with the original one

Share this post


Link to post
Share on other sites
1 minute ago, Sylraw said:

Well, than I have another problem 😕 😕 but since the rule is 1 bug / topic, stick with the original one

You introduced it. 😉

Sounds like a connectivity issue then, on balance. Who is your ISP?

Share this post


Link to post
Share on other sites
18 minutes ago, steviejay69 said:

I will qualify that you need either an open session, a friends only session (and join on a player that is in session) or an invite to an invite only session.

Ohh sorry I didn't noticed that you edited your post 😅, so if this means that rejoin to ranked session is not allowed, than I don't have that "another problem" 😄 

 

4 minutes ago, steviejay69 said:

You introduced it. 😉

Sounds like a connectivity issue then, on balance. Who is your ISP?

It is a Hungarian ISP called DIGI. The ethernet adapter is the onboard adapter of the MSI B450-A ProMax mainboard (driver updated 2 days ago). The router/modem is a Huawei EchoLife HG8121H Gpon terminal, provided and configured by the ISP.

I frequently playing games like League of Legends, which are quite sensitive to any network error, but there wasn't any issue with it... So I don't know.. I'm not sure that this will be a connectivity issue. But if there is some kind of settings that can help ,I will try it. 🙂 

  • Thanks 1

Share this post


Link to post
Share on other sites
2 minutes ago, Sylraw said:

Ohh sorry I didn't noticed that you edited your post 😅, so if this means that rejoin to ranked session is not allowed, than I don't have that "another problem" 😄 

It is a Hungarian ISP called DIGI. The ethernet adapter is the onboard adapter of the MSI B450-A ProMax mainboard (driver updated 2 days ago). The router/modem is a Huawei EchoLife HG8121H Gpon terminal, provided and configured by the ISP.

I frequently playing games like League of Legends, which are quite sensitive to any network error, but there wasn't any issue with it... So I don't know.. I'm not sure that this will be a connectivity issue. But if there is some kind of settings that can help ,I will try it. 🙂 

And you don't use a VPN or use any other bandwidth sucking apps?

Yeah I guess because the Ranked sessions are match made and people can join during, you could have problems rejoining if the lobby fills. However, if it's still joinable, and you can find it listed, then you should theoretically be able to spectate and rejoin via the spectator cam 'take control'. But I haven't disconnected from a Ranked lobby often enough - I don't play Ranked mode or the actual game enough....

Share this post


Link to post
Share on other sites
14 minutes ago, steviejay69 said:

And you don't use a VPN or use any other bandwidth sucking apps?

Nope, nothing like that. And the bandwidth is 1000/300 Mbit/s (approx. 300/75 if I measure it).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×