Jump to content
Bug Reporting - PLEASE FOLLOW RULES AND COMPLETE REPORTS Read more... ×
F1 2021 | Arrives July 16 | First Look Here Read more... ×
Sign in to follow this  

Connecting to online servers and loading

Recommended Posts

Hi guys, I just downloaded the schumacher edition onto my PS4 and when moving between time trials or finishing races, the game will get stuck on the screen 'connecting to online servers'. The only way to deal with this has involved turning the game off and restarting. It's incredibly annoying. I have both 2017 and 2019 and neither presented with such issues. 

It seems this appears to be an issue. Any ideas? 

Many thanks

Share this post


Link to post
Share on other sites

Hi guys, I just downloaded the schumacher edition onto my PS4 and when moving between time trials or finishing races, the game will get stuck on the screen 'communicating with online servers'. The only way to deal with this has involved turning the game off and restarting. It's incredibly annoying. I have both 2017 and 2019 and neither presented with such issues. 

It seems this appears to be an issue from reading other comments online, but no fix has been reported. Any ideas? 

Many thanks

Share this post


Link to post
Share on other sites

I am having the same issue and it is really annoying! The game works fine otherwise but every time I switch to another game mode I get this prompt big across the screen saying "communicating with online services" and i am unable to select any other option. 

I really hope there is some feedback on this soon. 

Share this post


Link to post
Share on other sites

I've been experiencing this issue on PS4 and PS5 and it's most annoying when you have to close the game every time you want to change a track in time trial because it just won't load the next track and/or it won't load any time trial times when you load up the track record tables. This issue extends to league races, after each league race finishes I have to close the whole game to be able to do anything.

To investigate further I purchased the game on PC to see if it was my internet that was the issue and it works absolutely perfectly on my PC with no issues whatsoever.

My friend who lives just down the street has the exact same internet provider and modem as me and is connected via ethernet. We both have PS5 and obviously F1 2020 - he experiences no issues at all but I have to quit the game after doing anything online on PlayStation.

What would be causing this continual "communicating with online services" screen or the games inability to load TT times on the PlayStation?

So far I haven't found any solutions and I hope with every patch that it gets fixed, but it hasn't been fixed yet.

Share this post


Link to post
Share on other sites
Posted (edited)

You're absolutely correct! I also have issues loading the TT times and I am also connect via ethernet. 

I was thinking to reinstall the game. 

Edited by sully868

Share this post


Link to post
Share on other sites
1 hour ago, sully868 said:

You're absolutely correct! I also have issues loading the TT times and I am also connect via ethernet. 

I was thinking to reinstall the game. 

I thought it would fix itself when I got the PS5 and it didn't. I have done several clean installs on the PS4 and PS5 but nothing has ever fixed it.

  • Agree 1

Share this post


Link to post
Share on other sites

Hi,
 
Thanks for adding your issue. However, we require all bug reports to follow the templates below. This is critical information Codemasters needs to be able to see your bug clearly. Link:

 I'd recommend checking Internet connections, NAT types and If you are running a Firewall, ensure it is set to allow the game to communicate on the following ports for both inbound and outbound traffic: TCP and UDP port 3074.
 
Please add your bug report onto this thread or I will not be able to replicate or diagnose   

Share this post


Link to post
Share on other sites

My Internet connection is absolutely fine and have never had this issue with any other game (Inc their other f1 titles). Today, I can't even play the game as when it tries to start I get this..... 

It's a disgrace 

20210104_125211.jpg

Share this post


Link to post
Share on other sites

I've played 2019 and never had this issue. 

My internet connection should not be an issue but I will have a look. 

Share this post


Link to post
Share on other sites

Hi @Mushak69 and @sully868

Completing the bug report template, and adding details like NAT Type and Connection Details will also be helpful. At the moment, I don't have enough information to diagnose the issues.

  • Agree 1

Share this post


Link to post
Share on other sites

@Mushak69, please refrain from double posting the same issue. Adding a bug report will give myself and others chance to help.

Share this post


Link to post
Share on other sites
Posted (edited)

I have the same issue, tried to reinstall the game and I even made a complete reset o my PS4.

  • A detailed description of the issue. Please include any error codes here. 

No error code, the leaderboard in time trial mode is not loading in the track selection screen. When I select a track the game is loading but nothing happens. Sometimes a restart helps.

  • Platform

PS4

  • What version of the game you are using (Shown on the start screen in the bottom left corner of the screen) 

1.14

  • Game-mode?

time trial

  • We need to be able to make your problem happen internally so we can fix the issue. Can you make the problem happen again?

yes

  • How do you make the problem happen?

No error code, the leaderboard in time trial mode is not loading in the track selection screen. When I select a track the game is loading but nothing happens. Sometimes a restart helps.

  • What troubleshooting have you attempted? Please always try to attempt to fix the issue 

restart of the game, restart of PS4, reinstalled the game, reset of ps4 and reinstalled the game

  • What peripherals are you are using (gamepad, wheel make & model etc) 

Ps4 controller

  • Any screenshots or video of the issue? If the video is long, please include a timestamp for when the issue appears.   

 

NAT Typ 2

Edited by HerbertH85
  • Like 1

Share this post


Link to post
Share on other sites

Hi @HerbertH85,

Your issue is different to the original here, but thanks for the completed report. You may want to check your connectivity settings, and consider moving to NAT type 1 if your ISP allows. This is something under investigation with the developers 👍

Share this post


Link to post
Share on other sites

Hi @BarryBL,

I checked your recommendations in the other "connection to online servers" thread and I changed the ip address of my PS4 from automatic to manual and next to that I opened the Port 3074 in my router menu. I only had the time to check it once but I could see the leaderboard in the track selection menu and I was also able to change the track after driving a fast lap in TT. Hope this solved my issue.

Thanks

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×