Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×
Sign in to follow this  

[PC] F1 2018 Crash to desktop but nothing helped yet

Recommended Posts


I buy and installed F1 2018 with Steam just a few days ago, but I cannot play with it because of the familiar: "Crash to Desktop" problem. When I try to start a race (or career) the game exit to desktop without any warning message. I read many forum topics and tried everything, but nothing helped. I read that many gamers had same problem so I really hope that since 2018 there are a good solution for that.

The main specs of my notebook (Lenovo Legion):

  • Win 10 Pro
  • RAM: 8 GB
  • CPU: Intel i5-8300H 2,3 GHz
  • GPU: NVidia GeForce GTX 1050 (Game ready driver version: 460.89) (beside of that: Intel UHD Graphics 630)

What I could not try out: Change the game to v1.04.01 beta version (key: c7EFPdFd6XADgGL7X284D4m8N6gYZmvb). I gave this key in Steam, but Steam say's: Its invalid code.

I tried the followings:

  • Change the .exe properties: "run as administrator, run in win 8 mode".. etc
  • In the game change some points below the video settings: "change the frame limits, change the resolution, windowed mode".. etc
  • I tried to verify the game files in Steam below the game properties.

Thank you for your help!

Share this post

Link to post
Share on other sites

This problem just occurred to me today. After running the practice match, the automatic save flash crashed to the desktop, and then I could not enter it all the time, But I can rebuild the save when palying.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this